none
求助sql2005sa用户名登陆问题 RRS feed

  • 问题

  • 我的网站数据库是用sa用户名登陆,但最近总是出现网页无法显示,错误提示:

     

    运行时错误 
    说明服务器上出现应用程序错误。此应用程序的当前自定义错误设置禁止远程查看应用程序错误的详细信息(出于安全原因)。但可以通过在本地服务器计算机上运行的浏览器查看。
     

    详细信息若要使他人能够在远程计算机上查看此特定错误消息的详细信息,请在位于当前 Web 应用程序根目录下的“web.config”配置文件中创建一个 <customErrors> 标记。然后应将此 <customErrors> 标记的“mode”属性设置为“Off”



    <!-- Web.Config 
    配置文件 -->

    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>
     

    注释通过修改应用程序的 <customErrors> 配置标记的“defaultRedirect”属性,使之指向自定义错误页的 URL,可以用自定义错误页替换所看到的当前错误页。



    <!-- Web.Config 
    配置文件 -->

    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
     

    但进入服务器手动更改sa密码后,又能够正常显示。数据库中强制密码策略和强制密码过期都已经取消。请教高声该如何解决。(注:我的系统是win sever 2003

    2011年3月2日 2:37

答案

  • Web app uses sa to talk to sql server? You are asking for trouble, should change it asap. App user should have minimum sql permission that keeps app working. 
    • 已标记为答案 Ai-hua Qiu 2011年3月9日 7:08
    2011年3月2日 4:15

全部回复

  • Please check

    1. Connect pool setting, too high value may cause similar scenario

    2. Instance network setting, static or dynamic port?

    3. Firewall setting, allow the port(TCP setting on instance)

    2011年3月2日 3:15
  • Web app uses sa to talk to sql server? You are asking for trouble, should change it asap. App user should have minimum sql permission that keeps app working. 
    • 已标记为答案 Ai-hua Qiu 2011年3月9日 7:08
    2011年3月2日 4:15
  • 建议在web服务器上看下具体的错误信息。
    另外,强烈建议不要用sa当应用程序的数据库连接帐号;连接字符串里面指定服务器,尽量用IP+Port的方式

    2011年3月2日 6:28
    版主