none
更新.Net Core至1.0.1后 编译时报System.Runtime版本不一致的错误

    问题

  • Unhandled Exception: System.IO.FileLoadException: Could not load file or assembly 'System.Runtime, Version=4.2.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. The located assembly
    's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    
    "system.collections.nongeneric/4.3.0": {
            "dependencies": {
              "System.Diagnostics.Debug""4.3.0",
              "System.Globalization""4.3.0",
              "System.Resources.ResourceManager""4.4.0-beta-24903-02",
              "System.Runtime""4.4.0-beta-24903-02",
              "System.Runtime.Extensions""4.4.0-beta-24903-02",
              "System.Threading""4.4.0-beta-24903-02"
            },
            "runtime": {
              "lib/netstandard1.3/System.Collections.NonGeneric.dll": {}
            },
            "compile": {
              "ref/netstandard1.3/System.Collections.NonGeneric.dll": {}
            }
          },
          "system.collections.specialized/4.3.0": {
            "dependencies": {
              "System.Collections.NonGeneric""4.3.0",
              "System.Globalization""4.3.0",
              "System.Globalization.Extensions""4.3.0",
              "System.Resources.ResourceManager""4.4.0-beta-24903-02",
              "System.Runtime""4.4.0-beta-24903-02",
              "System.Runtime.Extensions""4.4.0-beta-24903-02",
              "System.Threading""4.4.0-beta-24903-02"
            },

    2017年3月14日 6:30

答案

全部回复