none
在wp7.5种通过反射加载文件 提示: Assembly load 不存在 RRS feed

  • 问题

  •             Assembly asm = null;
                foreach (XElement xElement in deploymentParts)
                {
                    string source = xElement.Attribute("Source").Value;
                    AssemblyPart asmPart = new AssemblyPart();
                    StreamResourceInfo streamInfo = Application.GetResourceStream(new StreamResourceInfo(e.Result, "application/binary"), new Uri(source, UriKind.Relative));
                    if (source == Menudllname)
                    {
                        asm = asmPart.Load(streamInfo.Stream);
                    }
                    else
                    {
                        asmPart.Load(streamInfo.Stream);
                    }
                }

    对应的 load 事件提示不存在,是缺少什么引用吗?,请指教 


    Grant

    2012年9月6日 1:57

答案

全部回复

  • 你好,

    AssemblyPart 类的新实例。" data-guid="feead73c-df34-ef0a-dbf0-65bc631b8805" id="mt1">AssemblyPart 位于System.WindowsAssemblyPart 类的新实例。" data-guid="feead73c-df34-ef0a-dbf0-65bc631b8805" id="mt1">命名空间,添加的引用为:

    using System.Windows; // AssemblyPart

    具体请参考MSDN:AssemblyPart 类


    Keep Fighting

    2012年9月7日 6:26
  • 你好,

    AssemblyPart 类的新实例。" data-guid="feead73c-df34-ef0a-dbf0-65bc631b8805" id="mt1">AssemblyPart 位于System.WindowsAssemblyPart 类的新实例。" data-guid="feead73c-df34-ef0a-dbf0-65bc631b8805" id="mt1">命名空间,添加的引用为:

    using System.Windows; // AssemblyPart

    具体请参考MSDN:AssemblyPart 类


    Keep Fighting

    可是 System.Windows 已经引用了,但依然提示不存在

    Grant

    2012年10月6日 2:35