none
Sliverlihgt 的SDK与插件不能共存? RRS feed

  • 问题

  • 大家好:

        我是vs2010 + SL4 4.0.50401.0版的sdk,编译运行一切正常。可目前很网上多新的sl的应用已经是4.0.51204.0版了,运行它们会提示我安装插件,装完后虽然可以正常浏览了,但在vs2010里却不能编译了,提示版本不匹配,我只能在这两者中反复卸载安装,这令我十分郁闷,有解决办法吗???

    2011年1月13日 9:38

答案

  • 这和developer runtime有关。你开发期间还是用原来的版本开发吧,到运行的客户端再用最新版本的runtime,新的runtime增加了没有那么严格的自动更新功能,你可以按说明做就行了,不用在程序开发期也这样去测试。
    • 已标记为答案 Mog Liang 2011年1月20日 9:29
    2011年1月16日 9:45
    版主

全部回复

  • 您好,

    可以嘗試把Silverlight 4 Tools for Visual Studio 2010還有Silverlight SDK都移除後再重安裝看看


    2011年1月13日 11:00
  • 移除后是正常的,但我再次看新的sl程序还是会提示我升级插件,我一旦升级回头vs2010里又不能编译了,难道只能反复安装卸载吗?
    2011年1月14日 6:20
  • 这和developer runtime有关。你开发期间还是用原来的版本开发吧,到运行的客户端再用最新版本的runtime,新的runtime增加了没有那么严格的自动更新功能,你可以按说明做就行了,不用在程序开发期也这样去测试。
    • 已标记为答案 Mog Liang 2011年1月20日 9:29
    2011年1月16日 9:45
    版主
  • 4.0.51204.0 可能会有,但不会很多吧,,,多到你每次看都会遇到....除非你看你同事发布的测试版本.

    这个问题,我没有解决方法,但给你一个建议,为你照顾你的开发,就不要让更新就更新,,,,真正发布到网上的4.0.51204.0并不多,,,,

    2011年1月17日 7:27