none
win7+sql2008 这个环境中建立了一个2.0的程序,添加了一个WPF互操作控件!!无法再一个XP上已安装2.0fame的机器上运行!在不安装fame3.0的情况下 RRS feed

  • 问题

  • win7+sql2008 这个环境中建立了一个2.0的程序,添加了一个WPF互操作控件!!无法再一个XP上已安装2.0fame的机器上运行!,用到的dll都引用过来,在不安装fame3.0的情况下 能不能运行此程序!

    我看到程序引用里面有2.0 3.0 3.5 的什么版本dll引用都有,我都拷到本地目录又重新引用,本地正常运行

    放到XP上就不行了,不安装3.0或者3.5   只有2.0能不能运行,还缺少什么环境dll吗??


    vc815
    2010年7月29日 2:34

答案

全部回复

  • 我恐怕你必须安装程序集需要的补丁包(从2.0~3.5)。因为Win7内置了2.0~3.5的,而XP没有。
    2010年7月30日 1:21
    版主
  • 我恐怕你必须安装程序集需要的补丁包(从2.0~3.5)。因为Win7内置了2.0~3.5的,而XP没有。


    famework 只是个框架 最终不是运行在虚拟机上吗?

    我想知道 如果只是应用我所需要的dll ,引用, assmbly  应该可以好使  不用安装整个framework!

    知道具体细节吗?


    vc815
    2010年7月30日 3:56
  • 您的xp需要安装 .net 2.0 sp1 以上 才能运行3.5的wpf dll
    成为 Microsoft V Dash了。。。 欢迎各位前辈同事在OCS加我
    2010年7月30日 7:55
    版主
  • 您的xp需要安装 .net 2.0 sp1 以上 才能运行3.5的wpf dll
    成为 Microsoft V Dash了。。。 欢迎各位前辈同事在OCS加我

    已经安装2.0 sp1 已安装

    vc815
    2010年7月31日 7:44
  • WPF 功能至少需要 .NET 3.0 才支持,.net 2.0 sp1 并不包含 WPF 相关组件,

    注意,所谓基于 .NET 2.0/3.0/3.5  的程序,其运行时都是 .net 2.0,3.0, 3.5 不同之处支持体现在其功能上,比如 3.0包含了wpf/wcf/wwf


    问题要简单,错误须详细@错误/异常/堆栈信息+操作系统+软件版本+all the context of the issue Hope Helpful | http://www.leoworks.net

    2010年8月2日 10:02
  • WPF 功能至少需要 .NET 3.0 才支持,.net 2.0 sp1 并不包含 WPF 相关组件,

    注意,所谓基于 .NET 2.0/3.0/3.5  的程序,其运行时都是 .net 2.0,3.0, 3.5 不同之处支持体现在其功能上,比如 3.0包含了wpf/wcf/wwf

     


     

    问题要简单,错误须详细@错误/异常/堆栈信息+操作系统+软件版本+all the context of the issue Hope Helpful | http://www.leoworks.net

    我把程序的用到的版本dl2.0或者3.0 3.5 l引用挑出来,重新添加引用地址(本地文件夹中)在发布这个文件夹 理论应该可以运行吧?

    vc815
    2010年8月3日 2:57