none
AjaxToolkit问题 RRS feed

  • 问题

  • 问题描述:我在VS2005里使用AjaxToolkit,但系统在编译时报错,内容如下:

    错误 1 程序集“AjaxControlToolkit, Version=3.0.11119.17169, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e”所使用的“System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35”版本高于所引用的程序集“System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35”的版本

    我的机器上同时装了VS2005+SP1和VS2008+SP1。请教各位:为什么会这样?有什么解决方案没?有一点:VS2008是不能卸载的,因为需要用。

    2009年1月24日 8:32

答案

全部回复

  •  

    应该是引用的版本不同,重新在VS2005里添加 AjaxControlToolkit的1.0.61025.0版本引用
    2009年1月24日 9:35
    版主
  •  

    建议重灌 OS, VS,
    或卸除 VS 2005,
    VS 只要安装 VS 2008 + SP1 即可,不要装 VS 2005。

    因用 VS 2008 即可选择要开发、维护的 .NET 版本,新创建项目或网站时,可选 .NET 2.0、3.0、3.5 三种。

    维护旧的 ASP.NET 2.0 项目时,VS 2008 会先问要不要升级版本,选择「不要」即可 (默认是要升级,不要选错)。

     

     

     

    -------------------------------------------------
    Wizard 编程网 :
    http://www.cnblogs.com/WizardWu

     

    2009年1月24日 10:37