none
请问大家设置SQLSERVER的时候有没有勾选强制实施密码策略复选框 RRS feed

  • 问题

  • 请问大家设置SQLSERVER的时候有没有勾选强制实施密码策略复选框

    sql版本:sql2005企业版  操作系统 Windows2003 SP2

    我们安装在客户的有些系统是不需要连上互联网的,所以我们的设置odbc跟连接字符串的时候都是

    Server=myServerAddress;Database=myDataBase;User ID=sa;Password=myPassword;
    密码是4个英文字母

    反正不上网,密码就设置得比较简单

    但是问题来了,安装人员安装sqlserver的时候都勾选了 “强制实施密码策略”

    导致有时候delphi程序连接不上 ,密码更改了,需要重新打开程序,重新打开程序之后又正常了,密码没有变 ,究竟是不是密码更改了,还是SQL判断密码太简单

    我也无从确认,因为我也是查sql errorlog ,sql errorlog没有显示密码是否更改了,只是显示login failed,请大家看下面我给出的sql errorlog

    具体的描述我写在下面 跟我昨天发的帖子是一样的环境:

    数据库跟我们的程序都在同一台电脑,我们的程序使用包含两个系统,一个系统使用delphi开发(使用odbc连接数据库),

    一个系统使用C#开发(使用sqlclient连接数据库)

    客户那边使用的是局域网,当重启路由器的时候,delphi那个系统就断开了数据库链接

    听经理说,delphi系统是程序一打开就open 数据库连接直到程序关闭不像C#那样open -》执行数据库操作-》close

    现在把odbc配置那里 改为127.0.0.1就没有出现这种情况了

    ODBC的连接使用local

    昨天我发的帖子:http://social.technet.microsoft.com/Forums/zh-CN/sqlserverzhchs/thread/2c293875-529c-4469-95fa-fd899d88f851

    今天我在自己机器上测试了一下,测试使用SSMS,登录用户:sa 密码:4个英文字母 跟客户那边设置一样

    今天我一上班的时候就使用SSMS登录,使用sa来登录,结果sql弹出18456错误, sa登录失败,隔了十分钟之后我再登录,居然登录成功了

    说明一下,这期间我没有动过任何东西


    给我写信: QQ我:点击这里给我发消息

    2013年1月14日 3:04

答案

全部回复

  • 请问大家设置SQLSERVER的时候有没有勾选强制实施密码策略复选框

    sql版本:sql2005企业版 操作系统 Windows2003 SP2

    我们安装在客户的有些系统是不需要连上互联网的,所以我们的设置odbc跟连接字符串的时候都是

    Server=myServerAddress;Database=myDataBase;User ID=sa;Password=myPassword;
    密码是4个英文字母

    反正不上网,密码就设置得比较简单

    但是问题来了,安装人员安装sqlserver的时候都勾选了 “强制实施密码策略”

    导致有时候delphi程序连接不上 ,密码更改了,需要重新打开程序,重新打开程序之后又正常了,密码没有变 ,究竟是不是密码更改了,还是SQL判断密码太简单

    我也无从确认,因为我也是查sql errorlog ,sql errorlog没有显示密码是否更改了,只是显示login failed,请大家看下面我给出的sql errorlog

    具体的描述我写在下面 跟我昨天发的帖子是一样的环境:

    数据库跟我们的程序都在同一台电脑,我们的程序使用包含两个系统,一个系统使用delphi开发(使用odbc连接数据库),

    一个系统使用C#开发(使用sqlclient连接数据库)

    客户那边使用的是局域网,当重启路由器的时候,delphi那个系统就断开了数据库链接

    听经理说,delphi系统是程序一打开就open 数据库连接直到程序关闭不像C#那样open -》执行数据库操作-》close

    现在把odbc配置那里 改为127.0.0.1就没有出现这种情况了

    ODBC的连接使用local

    昨天我发的帖子:http://social.technet.microsoft.com/Forums/zh-CN/sqlserverzhchs/thread/2c293875-529c-4469-95fa-fd899d88f851

    今天我在自己机器上测试了一下,测试使用SSMS,登录用户:sa 密码:4个英文字母 跟客户那边设置一样

    今天我一上班的时候就使用SSMS登录,使用sa来登录,结果sql弹出18456错误, sa登录失败,隔了十分钟之后我再登录,居然登录成功了

    说明一下,这期间我没有动过任何东西


    给我写信: QQ我:点击这里给我发消息

    2013年1月14日 3:09
  • Sql installation enforces it by default, you can disable it first thing after installation.
    2013年1月14日 4:17
  • 是啊,安装完之后默认就已经勾选了,关键是现在很多客户都在使用,不可能出差给每个客户去设置一下

    头痛

    最烦的是SQLSERVER一时可以登录成功一时不能登录成功 ,前提是什么都没有动过,跟我上面说的环境一样


    给我写信: QQ我:点击这里给我发消息

    2013年1月14日 6:07
  • Every dba can disable it.
    2013年1月14日 13:56
  • 没。。通常自己管理的DBMS自己能完全控制,没那么复杂的环境会让N个人且不被信任的人去随意操刀

    就像在自家卧室,没必要再装防盗网一样


    Try SQL Server 2008 QQ:315054403 dgdba@hotmail.com

    2013年1月15日 3:19
  • 就是说dgdba大侠也没有勾选“强制实施密码策略复选框”

    那也是,机器是我们自己装的,如果客户那边的环境是不能上网的,设置4位英文字母的密码也无所谓

    如果客户那边环境是联网的,我们也是设置比较长的英文数字混合的密码

    因为我们的机器都是配置好才发货给客户,系统坏了也是我们出差上门维护


    给我写信: QQ我:点击这里给我发消息

    2013年1月15日 3:30
  • Then you should change your configuration process. 
    2013年1月15日 3:47
  • 我现在都没有勾选了,看来这次有得忙了


    给我写信: QQ我:点击这里给我发消息

    2013年1月15日 3:50
  • Hi,

    你发了2个重复的帖子,我将他们合并了哈。

    Best Regards.


    Amy Peng
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    2013年1月21日 2:33
    版主