none
关于.NET安装的几个问题 RRS feed

  • 问题

  • 一、安装.NET Framework 3.5 SP1 (Full Package) 是否不需要先安装.NET Framework 3.5?
    二、其它.NET Framework版本,如3.0、2.0、1.1、1.0等在安装SP时是否也不需要先安装相应版本的.NET Framework ?
    三、根据微软描述,.NET Framework2.0、1.1、1.0是互相独立的版本,那么.NET Framework3.5、3.0、2.0是否是升级版本?也就是说,.NET Framework3.5能够取代3.0,3.0能够取代2.0;而.NET Framework2.0不能取代1.1,1.1不能取代1.0?如此表述是否正确?
    2009年10月24日 18:12

答案

  • 事实上3.5根本没有多大 因为它包括所有当前版本
    还有你觉得这些对你有帮助的话 请你设置标识 谢谢
    • 已标记为答案 tiger121 2009年10月25日 15:13
    2009年10月25日 13:58

全部回复

  • 1 不需要
    2 不需要
    3 是的  不能说3.5取代3.0和2.0 因为3.5只是增加几个类库 你只安装3.4 然后看看C:\Windows\Microsoft.NET\Framework 就知道了
    1.X和 2.0是核心修改 所以不能取代
    2009年10月25日 4:15
  • 不能说3.5取代3.0和2.0 因为3.5只是增加几个类库
    那么需要.NET Framework3.0运行环境不能用安装.NET Framework3.5代替么?必须安装.NET Framework3.0么?另外安装.NET Framework3.0或.NET Framework3.0 SP1必须在线么?能否离线安装?
    2009年10月25日 11:46
  • 可以替代的 一个3.5完整安装包包括1.0 2.0 3.0 所有类库 安装时候分别所有旧版本文件夹和新的版本文件夹
    比如说你的系统已经有3.0的话 那么安装程序可以跳过1.0 2.0 3.0安装过程 直接更新3.5

    2009年10月25日 12:11
  • 非常感谢您的回答!另外,.NET Framework3.0 SP1是否可以不使用引导文件在线下载,直接下载到完整的离线安装包?

    2009年10月25日 13:26
  • 非常感谢您的回答!另外,.NET Framework3.0 SP1是否可以不使用引导文件在线下载,直接下载到完整的离线安装包?


    很遗憾 这个3.0sp1版本不提供vs支持!微软不提供下载
     3.5已经包括3.0sp1所有功能
    2009年10月25日 13:41
  • 确实有点遗憾!其实我只是安装ThinkPad的个别程序需要.NET Framework3.0的运行环境,装原版的.NET Framework3.0似乎老了点,而装新的.NET Framework3.5 SP1似乎又太大了点,毕竟仅安装文件就有231M呐!因此才想找一个.NET Framework3.0 SP1,不过要是靠引导程序在线安装,估计得点时间吧!
    再次感谢您的回答!

    2009年10月25日 13:52
  • 事实上3.5根本没有多大 因为它包括所有当前版本
    还有你觉得这些对你有帮助的话 请你设置标识 谢谢
    • 已标记为答案 tiger121 2009年10月25日 15:13
    2009年10月25日 13:58