none
关于程序部署的问题 RRS feed

  • 问题

  • 看到一本书上介绍有关c#数据库编程的内容。介绍了一个学生选课系统实例,程序为C/S模式,使用SQL数据库。最后讲到在客户机上安装程序时,必须要求先安装.NET FRAMEWORK。我想不大可能吧,没见过安装一c#语言编写的应用软件还要在机器中先安装.NET FRAMEWORK。请释疑。

     

    2010年11月24日 1:19

答案

  • 另外,现在的 Windows 操作系统,除了 Windows XP pre-SP2 的之外,都已经内置了 Microsoft .NET Framework。具体说来:

    Windows XP Professional / Home with Service Pack 2 or later - .NET Framework 2.0 SP2
    Windows Vista - .NET Framework 3.0
    Windows Vista SP2 - .NET Framework 3.0 SP2
    Windows 7 - .NET Framework 3.5 SP1
    Windows "8" - .NET Framework 4.0 或者是 .NET Framework 4.0 SP1,有 .NET Framework 是确定的,但不清楚会集成哪一个版本。


    Mark Zhou
    • 已标记为答案 牛先生 2010年11月29日 1:48
    2010年11月24日 8:51

全部回复

  • dear

    C#.NET/VB.NET 要执行必须要有CLR(Common Language Runtime ),也就是.Net Framework,还得看你使用啥版本的C#,然后安装正确版本的.NetFramework。请参考以下

    http://msdn.microsoft.com/zh-tw/library/zw4w595w.aspx

     


    秘訣無它,唯勤而已 http://www.dotblogs.com.tw/yc421206/
    2010年11月24日 2:55
  • 另外,现在的 Windows 操作系统,除了 Windows XP pre-SP2 的之外,都已经内置了 Microsoft .NET Framework。具体说来:

    Windows XP Professional / Home with Service Pack 2 or later - .NET Framework 2.0 SP2
    Windows Vista - .NET Framework 3.0
    Windows Vista SP2 - .NET Framework 3.0 SP2
    Windows 7 - .NET Framework 3.5 SP1
    Windows "8" - .NET Framework 4.0 或者是 .NET Framework 4.0 SP1,有 .NET Framework 是确定的,但不清楚会集成哪一个版本。


    Mark Zhou
    • 已标记为答案 牛先生 2010年11月29日 1:48
    2010年11月24日 8:51