none
关于智能设备开发 RRS feed

  • 问题

  • 在使用VS进行智能设备项目的开发时,不仅需要选择.net compact framework的版本,还需要选择.net framework的版本,为什么呢?
    轻轻的我来了... ...
    2010年9月25日 7:21

答案

  • 第一个选.NET Framework框架的那个ComboBox是项目模板类型的过滤,选.net 2.0的时候,不支持2.0的项目模板就会被隐藏。

    同时,该ComboBox会决定项目属性的目标框架(Target Framework)的值。

    但智能设备项目是不受目标框架影响的,新建的时候随便选哪个,都能创建智能设备项目,并且项目属性中的目标框架下拉框是灰的。


    Love Your Neighbor as Yourself
    2010年9月26日 7:34

全部回复

  • 你好,

    用Visual Studio开发智能设备应用的时候,没有这个.Net Framework要求的吧。


    施炯
    2010年9月26日 0:33
    版主
  • 不知道您能不能把问题描述的稍微详细一点,比如用什么语言开发的,在新建工程的时候,哪一步出现确定.net framework版本的信息。
    施炯
    2010年9月26日 0:37
    版主
  • 应该是只有“目标平台”(WM5,WM6)和.NET CF的版本吧!?
    Love Your Neighbor as Yourself
    2010年9月26日 1:58
  • 你好,我把问题再说的详细点。

    使用的开发工具是VS2008

    打开VS2008后,选择“文件-》新建-》项目”,在弹出的“新建项目”对话框的右上角,有个combobox可以选择.net framework的框架,如2.0 ,3.0,3.5.我的问题就是如果开发的是智能设备项目,使用的的是.net compact framework,那么这里对.net framework的选择对后面的开发有什么影响?


    轻轻的我来了... ...
    2010年9月26日 7:24
  • 你好,

    我看了一下,的确是出现了你说的情况。但是这个应该对后面的.net compact framework开发没有影响,因为后面要重新选择.net compact framework的版本的。


    施炯
    2010年9月26日 7:27
    版主
  • 第一个选.NET Framework框架的那个ComboBox是项目模板类型的过滤,选.net 2.0的时候,不支持2.0的项目模板就会被隐藏。

    同时,该ComboBox会决定项目属性的目标框架(Target Framework)的值。

    但智能设备项目是不受目标框架影响的,新建的时候随便选哪个,都能创建智能设备项目,并且项目属性中的目标框架下拉框是灰的。


    Love Your Neighbor as Yourself
    2010年9月26日 7:34
  • 如果选择的是智能设备的开发,上面的.net framework选择就没有意义了,因为后面还可以选的。所以这个选项没用的,不用关注它。
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    2010年9月27日 9:49
    版主