none
WP 8.1包不能在 WP8 上部署 RRS feed

  • 问题

  • 我用WP 8.1 SDK 编译的xap包,在WP8的手机上不能安装,提示的错误信息:The target device is running an unsupported version of the operating system.
    2014年7月14日 2:15

答案

  • 是的,这种项目是无法在8.0 设备上部署的。

    目前WP应用的向下兼容,是指的高系统版本的设备可以支持低系统版本的应用。比如说WP8.1的设备可以支持WP8.0的应用。

    由于Windows Phone Silverlight 8.1 和 Windows Phone 8.1 中加入了很多WP8.0系统的设备不支持的特性,所以不支持也是可以理解的。

    2014年7月14日 3:12

全部回复

  • 你好。

    请查看你的项目类型是 Windows Phone Silverlight 8.1 , 还是 Windows Phone Silverlight 8。

    如果是8.1,那么只能在WP 8.1 的手机上部署。如果是8.0, 那么可以在WP8.0 手机上部署。

    2014年7月14日 2:22
  • 我的项目类型是Windows Phone Silverlight 8.1, 我就是想知道它为什么不能在8.0上部署?为什么不向下兼容
    2014年7月14日 2:58
  • 是的,这种项目是无法在8.0 设备上部署的。

    目前WP应用的向下兼容,是指的高系统版本的设备可以支持低系统版本的应用。比如说WP8.1的设备可以支持WP8.0的应用。

    由于Windows Phone Silverlight 8.1 和 Windows Phone 8.1 中加入了很多WP8.0系统的设备不支持的特性,所以不支持也是可以理解的。

    2014年7月14日 3:12