none
新建的windows通用应用在release下无法调试 RRS feed

  • 问题

  • 我使用vs2015社区版 新建了一个windows同应用,在debug模式下调试没出问题,但是在release下出现了错误;

    错误如下:

    激活 Windows 应用商店应用“6b6c0776-4461-462a-87f1-6e68dd23562e_9bakykmnpqw32!App”失败,错误为“应用未启动”。


    2015年9月8日 5:45

全部回复

  • 首先请楼主确认一下Develop License是否过期。

    然后确认一下所在硬盘是不是NTFS格式。

    如果以上都没问题,再试一下官方下载的DemoCode运行是否正常。


    专注于Windows Phone

    2015年9月8日 6:24
    版主
  • 你可能要Delete 一些 build folder 或 "Clean Solution"

    http://michaelcrump.net/resolution-unable-to-activate-windows-store-app-the-activation-request-failed-with-error-e-fail/


    大家一齊探討、學習和研究,謝謝!
    MCSD, MCAD, MCSE+I, MCDBA, MCDST, MCSA, MCTS, MCITP, MCPD,
    MCT, Microsoft Community Star(TW & HK),
    Microsoft MVP for VB.NET since 2003
    My MSMVP Blog

    請記得將對您有幫助的回覆標示為解答以幫助其他尋找解答及參與社群討論的朋友們。
    Please remember to clickMark as Answer on the post that helps you. This can be beneficial to other community members reading the thread.

    2015年9月8日 6:41
  • 我只是在本地调试应该跟Develop License没关系吧
    2015年9月8日 7:06
  • 没有发现文中说的那个bld文件,也尝试的删除了bin文件但是没有成功,为何debug模式下可以拉
    2015年9月8日 7:22
  • 我指的不是要申请软件商店的账号,而是Visual Studio本身需要使用微软账号激活,激活一次大概实效三个月,过期再次激活即可。

    这是完全免费的,应该是微软统计开发者的一种手段而已。


    专注于Windows Phone

    2015年9月8日 10:02
    版主
  • 我有在vs上更新过账户,但是还是没有有啊,为何debug模式就可以了,这是调试信息:

    “App1.exe”(Win32): 已加载“C:\Users\wangb\Documents\Visual Studio 2015\Projects\App1\App1\bin\x64\Release\AppX\App1.exe”。模块已生成,不包含符号。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\ntdll.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\kernel32.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\KernelBase.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\combase.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\msvcrt.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Windows\System32\rpcrt4.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    “App1.exe”(Win32): 已加载“C:\Program Files\WindowsApps\Microsoft.NET.Native.Runtime.1.1_1.1.23231.0_x64__8wekyb3d8bbwe\mrt100_app.dll”。已跳过加载符号。模块是本机的,当前禁用本机调试。
    线程 0x261c 已退出,返回值为 -1073741701 (0xc000007b)。
    线程 0x2b68 已退出,返回值为 -1073741701 (0xc000007b)。
    线程 0x2b94 已退出,返回值为 -1073741701 (0xc000007b)。
    程序“[7752] App1.exe”已退出,返回值为 -1073741701 (0xc000007b)。
    激活 Windows 应用商店应用“6b6c0776-4461-462a-87f1-6e68dd23562e_9bakykmnpqw32!App”失败,错误为“应用未启动”。

    2015年9月9日 3:56
  •  我想说我和楼主遇到了一样的情况,前一阵子还是可以在 release下进行调试,但是现在不能了。我们公司的我们这个开发小组都遇到了这种情况 ,我猜可能是微软推送的补丁导致的,反正到现在也没有解决,期待微软给个解决方案。
    • 已建议为答案 HippieZhou 2015年9月10日 13:31
    2015年9月9日 12:50
  • 是这样子的吗,如果是这样子那就等微软修复好了,至少还可以在debug下调试
    2015年9月9日 13:59
  • 换个VS版本试试

    新浪微博http://weibo.com/xianglitian,欢迎围观

    2015年9月11日 2:31
    版主