none
vs2017自带的git for windows和nodejs运行异常,cpu占用高 RRS feed

  • 问题

  • 系统环境:win10 1703, vs2017 15.3.3

    1、在安装vs2017之前已经独立安装了git for windows和nodejs
    2、在安装vs2017之前机器上已有项目是用了git在托管源代码,而且那个项目的分支比较多,解决方案中有项目用了nodejs
    3、安装vs2017会自动在vs2017的安装目录下再次安装git for windows和nodejs(PS. 我在安装vs2017时并未勾选任何git扩展和git for windows的选项,也没有勾选任何nodejs开发支持的选项)
    4、在安装完vs2017后打开这个已用git托管了代码和使用了nodejs的解决方案

    打开这样的解决方案,vs安装时自带的git和nodejs就会自动运行,而且打开项目后不进行任何编辑操作,cpu就占用了100%了,其中vs自带的git和nodejs占用分别都超过30%以上。而在打开其他未在git中托管代码和未使用nodejs的项目不会有这个现象。反复试过多次了,都是如此。

    所以,第一安装时能不能不要自动安装git和nodejs,第二机器上已独立安装了git和nodejs的,能不能通过配置使用外部的git和nodejs,第三如果非要有,在打开用了git在托管源代码,和用了nodejs的项目时自带的git和nodejs运行能正常


    2017年9月11日 3:31

全部回复

  • 你好:

    >>打开这样的解决方案,vs安装时自带的git和nodejs就会自动运行,而且打开项目后不进行任何编辑操作,cpu就占用了100%了,其中vs自带的git和nodejs占用分别都超过30%以上

    如果你没有勾选任何git选项和任何nodejs选项的话,请问你是如何看出vs安装时自带的git和nodejs就会自动运行。

    请提供一些相关截图


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年9月12日 7:21
  • 在任务管理器里把命令行列显示出来或在进程上右键打开程序所在目录都能确定
    2017年9月12日 7:24
  • 你好,

    正常情况下,git不会占用很高的内存,大概1M左右。

    为了更好的理解您的问题,可以给我们提供一下任务管理器里面的内存截图吗? 先在 Verify Account 40 发送请求验证账号才能上传图片。

    关于node.js占用内存的问题,请参考:

    Node.js server-side javascript process consuming too much memory

    可以尝试如下解决方案:

    菜单栏里面选择 工具>扩展和更新, 关闭 TypeScript


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年9月13日 8:32
  • 主要问题不在内存,而在cpu的持续占用
    2017年9月13日 9:22
  • 你好,

    这个论坛主要讨论VS IDE相关使用的问题,由于您的问题和CPU持续占用有关,我帮助您把这个帖子移动到一般性问题讨论区得到更加多样性的解答。

    感谢您的理解与配合。


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年9月15日 10:11
  • 我现在也是这个问题,请问你解决了没有?
    2017年9月25日 3:57
  • 我现在也是这个问题,请问你解决了没有?

    没有,这个工作项目还是一直用vs2015.

    到https://developercommunity.visualstudio.com 报告了问题也还没有解决,你也可以到这里把问题报告一下,把你的状况描述一下


    2017年9月25日 4:02
  • 昨天经过一整天反复的尝试,我觉得我已经找到了解决办法,现在我这边已经没有这个问题了

    你可以加一下我的微信(和此用户名同名),我把方法告诉你

    2017年9月26日 2:07
  • Tools > Options > Text Editor > JavaScript/TypeScript > Language Service...

    Uncheck 'Enable the new JavaScript language service'.

    • 已建议为答案 凸-.- 2019年7月10日 2:11
    2018年9月6日 6:16
  • Tools > Options > Text Editor > JavaScript/TypeScript > Language Service...

    Uncheck 'Enable the new JavaScript language service'.

    coooooooooooooooool.
    2019年7月10日 2:12