none
SQL Server 2005 SSAS EXCEL连接问题 RRS feed

  • 问题

  • 最近在安装SQL Server 2005企业版的分析服务时候,不管是64位的还是32位的,通过Excel和其他客户端连接分析服务器一直联系不上。不知道是什么原因,希望能帮忙看看。

    安装的时候,甚至都是默认的,连接选择的是本地系统。补丁时SQL Server 2005 SP3。安装完成后,在SSAS属性的安全选项里面添加属于管理员组的用户。在客户端安装了MSOLEDB for Analysis Services 9.0。连接时候选择了这个 (如图:数据链接-1),在接下来的页面填好相关信息后,提示连接失败(提示OLE DB访问接口中存在错误。无法连接到重定向程序。请确保服务器上正在运行SQLBrowser服务。)。服务器上SQL浏览器已经启动,TCP的2382端口和UDP的1434端口侦听状态,防火墙关闭。连接命名实例的数据库引擎成功,同时通过(IP地址:端口号)的方式也能正常连接。就是通过(IP地址\实例名)的方法始终失败。

    按照MSDN上介绍的命令行的方法启动SQL浏览器,好像都是到开始启动OLAP重定向服务的时候就不动了(SQLBrowser:Starting up OLAP redirection service)。

    网上说的检查ASConfig文件夹的权限,注册表中SQLBrowser Listen的值都是过了,不能解决问i题。请问是不是我忽略了什么,该怎么进一步检查问题所在和处理?

    谢谢!
    2010年3月22日 16:34

全部回复

  • Connect to sql server or ssas? Does user have permission to access cube?
    2010年3月22日 18:57
  • It is to connect to SSAS.  I do not think it is the user's permission that causes the problem.  Because I can connect the SSAS by using the IP:Port method from the same client.  It is also ok to connect to SSAS locally with the login of the same user. 

    I think at least part of the SQLBrowser functioning well because it can redirect database engine correctly on the server.  When starting SQLBrowser from the command line ("C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe" -c), it hangs on SQLBrowser: Starting up OLAP redirection service.  Is this normal?  The SQL Server 2005 SP3 is downloaded from Microsoft. 

    2010年3月23日 1:20
  • What's sql browser service account? Any error message about sql browser service failure in windows app event log?
    2010年3月23日 2:40
  • What's sql browser service account? Any error message about sql browser service failure in windows app event log?
    2010年3月23日 2:40
  • The SQLBrowser Service account is Local System.  There is no error message about sql browser in the windows app event log. 

    2010年3月23日 5:02
  • Tried start sql browser service in services applet?
    2010年3月23日 12:38
  • go to START MENU> RUN> services.msc, stop the SQL Server Browser service then start it again.  It still does not work.  Quite strange.  I tried this on different servers, including the Windows Server 2003 Enterprise SP2 X86 and Windows Server 2003 Enterprise SP2 X64 with the latest patch installed.  

    I appreciate your help.  Is there any other method that can help to track down the problem?  

    2010年3月23日 14:51
  • Got any error when try to start it? Event log should have something if failed to start service.
    2010年3月23日 20:20
  • There is only information but not error in the event log, which recording the SQL Browser is starting and started.  There is no error on the interface either when start from the services applet.  The thing I am not sure is when I start it from the command line, which it always stops at "SQLBrowser: Starting up OLAP redirection service".  Does this is what supposed to be or it should read something else that like "SQLBrowser is successfully listening on 0.0.0.0[1434]" after the line "SQLBrowser: starting up SSRP redirection service"?
    2010年3月24日 1:18
  • Tried stop sql and ssas then start sql browser?
    2010年3月24日 2:00
  • I just stopped all the SQL services.  Then start the SQL Browser, SQL Server, SSAS in order.  The message box still came out said "Errors in the OLE  <acronym title="Database">DB</acronym>   provider. Could not connect to the redirector. Ensure that the SQLBrowser service is running on the '192.168.0.xxx' server". 
    2010年3月24日 3:17
  • Is the workstation components the SQL Server Native Client?  I uninstalled the native client and reinstalled again on the server and it does not help. 

    I installed Windows Network Monitor.  There is TCP traffic between the server's 2382 port and the client when I was trying to connect SSAS using the UDL file.  Would there be UDP traffic if I am connecting with <IP>\<Instance Name> instead of <Machine Name>\<Instance Name>?

    2010年3月24日 11:15
  • Don't think workstation components are part of SQL Server Native Client. Tried connect with ip,port instead?
    2010年3月24日 13:27
  • Yes, I tried using <IP>:<Port> in the UDL file and it connected successfully.  It does not work with <IP>,<Port> in UDL file. 
    2010年3月25日 2:27