none
Visual Studio2008 在Win7下启动C\S程序特别慢 RRS feed

  • 问题

  • 最近发现我们的程序在Win7下启动特别慢,但在XP 和 Vista下都很快,不知道为什么?

    任何建议都非常感谢!!

    2010年11月22日 5:31

答案

  • 尝试这个方案(英文的):

    • Make sure Visual Studio 2005 SP1 is installed.
    • Turn off animation.
      Go to Tools | Options | Environment and uncheck Animate environment tools.
    • Disable Navigation Bar.
      If you are using ReSharper, you don't need VS2005 to update the list of methods and fields at the top of the file (CTRL-F12 does this nicely). Go to Tools | Options | Text Editor | C# and uncheck Navigation bar.
    • Turn off Track Changes.
      Go to Tools | Options | Text Editor and uncheck Track changes. This will reduce overhead and speeds up IDE response.
    • Turn off Track Active item.
      This will turn off jumping in the explorer whenever you select different files in different projects. Go to Tools | Options | Projects and Solutions and uncheck Track Active Item in Solution Explorer. This will ensure that if you are moving across files in different projects, left pane will still be steady instead of jumping around.
    • Turn off AutoToolboxPopulate.
      There is an option in VS 2005 that will cause VS to automatically populate the toolbox with any controls you compile as part of your solution. This is a useful feature when developing controls since it updates them when you build, but it can cause VS to end up taking a long time in some circumstances. To disable this option, select the Tools | Options | Windows Forms Designer and then set AutoToolboxPopulate to False.

    (更多参考:http://huan-lin.blogspot.com/2008/12/visual-studio-2008-ide.html,中文)

    2010年11月23日 3:03
    版主

全部回复

  • 你是说你们自己写的程序?

    可以把和启动有关的函数的执行时间计算出来输出到文件

    然后再有针对性的分析

    2010年11月22日 5:37
  • 谢谢!

    但我怀疑这是系统或Visual Studio2008 配置的问题,因为我在XP或vista下启动都非常快,只有在Win7下启用Visual Studio2008 启动我的项目特别的慢。

    Visual Studio2008 中用没有什么设置可以提高运行速度或是其它什么可能?

    2010年11月22日 5:42
  • 尝试这个方案(英文的):

    • Make sure Visual Studio 2005 SP1 is installed.
    • Turn off animation.
      Go to Tools | Options | Environment and uncheck Animate environment tools.
    • Disable Navigation Bar.
      If you are using ReSharper, you don't need VS2005 to update the list of methods and fields at the top of the file (CTRL-F12 does this nicely). Go to Tools | Options | Text Editor | C# and uncheck Navigation bar.
    • Turn off Track Changes.
      Go to Tools | Options | Text Editor and uncheck Track changes. This will reduce overhead and speeds up IDE response.
    • Turn off Track Active item.
      This will turn off jumping in the explorer whenever you select different files in different projects. Go to Tools | Options | Projects and Solutions and uncheck Track Active Item in Solution Explorer. This will ensure that if you are moving across files in different projects, left pane will still be steady instead of jumping around.
    • Turn off AutoToolboxPopulate.
      There is an option in VS 2005 that will cause VS to automatically populate the toolbox with any controls you compile as part of your solution. This is a useful feature when developing controls since it updates them when you build, but it can cause VS to end up taking a long time in some circumstances. To disable this option, select the Tools | Options | Windows Forms Designer and then set AutoToolboxPopulate to False.

    (更多参考:http://huan-lin.blogspot.com/2008/12/visual-studio-2008-ide.html,中文)

    2010年11月23日 3:03
    版主