none
安装vs2008sp1出错,麻烦帮忙看看 RRS feed

  • 问题

  • 产生的日志文件如下,谢谢先

    === Verbose logging started: 2010-1-12  20:04:19  Build type: SHIP UNICODE 3.01.4001.5512  Calling process: E:\Software\编程开发\C_C++\vs2008SP1\vs90sp1\SPInstaller.exe ===
    MSI (c) (D0:2C) [20:04:19:968]: Resetting cached policy values
    MSI (c) (D0:2C) [20:04:19:968]: Machine policy value 'Debug' is 0
    MSI (c) (D0:2C) [20:04:19:968]: ******* RunEngine:
               ******* Product: {90120000-0021-0000-0000-0000000FF1CE}
               ******* Action: 
               ******* CommandLine: **********
    MSI (c) (D0:2C) [20:04:19:968]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (D0:2C) [20:04:19:968]: Grabbed execution mutex.
    MSI (c) (D0:2C) [20:04:20:093]: Cloaking enabled.
    MSI (c) (D0:2C) [20:04:20:093]: Attempting to enable all disabled priveleges before calling Install on Server
    MSI (c) (D0:2C) [20:04:20:250]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (94:0C) [20:04:20:468]: Grabbed execution mutex.
    MSI (s) (94:08) [20:04:20:515]: Resetting cached policy values
    MSI (s) (94:08) [20:04:20:515]: Machine policy value 'Debug' is 0
    MSI (s) (94:08) [20:04:20:515]: ******* RunEngine:
               ******* Product: {90120000-0021-0000-0000-0000000FF1CE}
               ******* Action: 
               ******* CommandLine: **********
    MSI (s) (94:08) [20:04:20:515]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (94:08) [20:04:20:546]: End dialog not enabled
    MSI (s) (94:08) [20:04:20:546]: Original package ==> C:\WINDOWS\Installer\2c01997.msi
    MSI (s) (94:08) [20:04:20:546]: Package we're running from ==> C:\WINDOWS\Installer\2c01997.msi
    MSI (s) (94:08) [20:04:20:578]: APPCOMPAT: looking for appcompat database entry with ProductCode '{90120000-0021-0000-0000-0000000FF1CE}'.
    MSI (s) (94:08) [20:04:20:578]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (94:08) [20:04:20:656]: MSCOREE not loaded loading copy from system32
    MSI (s) (94:08) [20:04:20:671]: Machine policy value 'AllowLockdownBrowse' is 0
    MSI (s) (94:08) [20:04:20:671]: Machine policy value 'DisableBrowse' is 0
    MSI (s) (94:08) [20:04:20:671]: Unable to create a temp copy of patch 'E:\Software\编程开发\C_C++\vs2008SP1\vs90sp1\WebDesignerCore_KB950278.msp'.
    MSI (s) (94:08) [20:04:20:671]: Couldn't find local patch ''. Looking for it at its source.
    MSI (s) (94:08) [20:04:20:671]: Resolving Patch source.
    MSI (s) (94:08) [20:04:20:671]: User policy value 'SearchOrder' is 'nmu'
    MSI (s) (94:08) [20:04:20:671]: User policy value 'DisableMedia' is 0
    MSI (s) (94:08) [20:04:20:671]: Machine policy value 'AllowLockdownMedia' is 0
    MSI (s) (94:08) [20:04:20:671]: SOURCEMGMT: Media enabled only if package is safe.
    MSI (s) (94:08) [20:04:20:671]: SOURCEMGMT: Looking for sourcelist for product {FED55BA1-5A70-44B4-8EB1-E72274AED780}
    MSI (s) (94:08) [20:04:20:671]: Note: 1: 1706 2: {FED55BA1-5A70-44B4-8EB1-E72274AED780} 3:  
    MSI (s) (94:08) [20:04:20:671]: SOURCEMGMT: Failed to resolve source
    MSI (s) (94:08) [20:04:20:671]: Note: 1: 1708 
    MSI (s) (94:08) [20:04:20:671]: Note: 1: 2729 
    MSI (s) (94:08) [20:04:20:671]: Note: 1: 2729 
    MSI (s) (94:08) [20:04:20:671]: 产品: Microsoft Office Visual Web Developer 2007 -- 安装失败。
    
    MSI (s) (94:08) [20:04:20:671]: MainEngineThread is returning 1612
    这个产品的安装来源无法使用。请验证来源是否存在,是否可以访问。
    C:\WINDOWS\Installer\2c01997.msi
    MSI (c) (D0:2C) [20:04:20:687]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (D0:2C) [20:04:20:687]: MainEngineThread is returning 1612
    === Verbose logging stopped: 2010-1-12  20:04:20 ===
    
    
    2010年1月12日 12:10

答案

  • 谢谢,昨天我安装的时候把镜像文件解压了,今天直接用虚拟光驱加载就好了。

    谢谢大家的关注 :-)
    • 已标记为答案 YiChun Chen 2010年1月13日 14:01
    2010年1月13日 11:59
  • 你好!
         从日志来看,应该是安装源本身有问题,你从微软的站点重新下载,然后重新安装看看:
    http://www.microsoft.com/downloads/details.aspx?familyid=27673C47-B3B5-4C67-BD99-84E525B5CE61&displaylang=zh-cn
    周雪峰
    • 已标记为答案 gdstcwl 2010年1月13日 12:00
    2010年1月12日 14:12
    版主

全部回复

  • 你好!
         从日志来看,应该是安装源本身有问题,你从微软的站点重新下载,然后重新安装看看:
    http://www.microsoft.com/downloads/details.aspx?familyid=27673C47-B3B5-4C67-BD99-84E525B5CE61&displaylang=zh-cn
    周雪峰
    • 已标记为答案 gdstcwl 2010年1月13日 12:00
    2010年1月12日 14:12
    版主
  • 你安装SP1的时候,一定要确保是简体中文的
    努力+方法=成功
    2010年1月13日 1:18
  • 你好!

    你可以试一下周版主和开心的建议,可以使用一些下载工具来帮助你下载。

    如果不行的话,你能把你的临时文件夹里的Microsoft Visual Studio 2008 SP1*.* 相关的所有文件发到我的邮箱(v-yicche@microsoft.com)吗?

    谢谢!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    2010年1月13日 10:27
  • 谢谢,昨天我安装的时候把镜像文件解压了,今天直接用虚拟光驱加载就好了。

    谢谢大家的关注 :-)
    • 已标记为答案 YiChun Chen 2010年1月13日 14:01
    2010年1月13日 11:59
  • 你好!

    你可以试一下周版主和开心的建议,可以使用一些下载工具来帮助你下载。

    如果不行的话,你能把你的临时文件夹里的Microsoft Visual Studio 2008 SP1*.* 相关的所有文件发到我的邮箱(v-yicche@microsoft.com)吗?

    谢谢!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.

    谢谢回复,已经正常安装了 :-)
    2010年1月13日 12:03
  • 不客气啊!
    欢迎常来这里和大家交流啊!
    周雪峰
    2010年1月13日 12:42
    版主
  • 呵呵,客气了,很高兴你的问题被解决了! :)
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    2010年1月13日 14:01