none
Help! Can't deploy any Win8.1 App to Surface RT (os: windows RT 6.2 ver:9200) through vs2013 and remote debuger 2013 RRS feed

  • 问题

  • Error 2 Error : DEP0700 : Registration of the app failed. error 0xC00CE014: App manifest validation error: The app manifest must be valid as per schema: Line 25, Column 8, Reason: Element '{http://schemas.microsoft.com/appx/2013/manifest}VisualElements' is unexpected according to content model of parent element '{http://schemas.microsoft.com/appx/2010/manifest}Application'.
    Expecting: {http://schemas.microsoft.com/appx/2010/manifest}VisualElements.
     (0x80080204)

    Should I upgrade the surface RT os to windows RT 8.1?  Is this the real reason of this error?  

    thanks!

    nio


    nio

    2013年11月19日 3:16

答案

  • Hi zhiyong,

    Windows RT 6.2 9200 is a win8 operation system and therefore you cannot run win8.1 apps, to upgrade to win8.1 is necessary to run the win8.1 app.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • 已标记为答案 nio Pan 2013年11月21日 5:47
    2013年11月20日 2:53
    版主

全部回复

  • Hi zhiyong,

    Windows RT 6.2 9200 is a win8 operation system and therefore you cannot run win8.1 apps, to upgrade to win8.1 is necessary to run the win8.1 app.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • 已标记为答案 nio Pan 2013年11月21日 5:47
    2013年11月20日 2:53
    版主
  • Thanks James,

    OK. It seams like i must upgrade my surface RT to win8.1.  But, i still cannot understand why it throws the error log like that? Does the "VisualElements" has any relationship with the winRT version?  Why not  descript the error  more clearly?



    nio

    2013年11月21日 5:46
  • Take a look at this document, http://msdn.microsoft.com/en-us/library/windows/apps/br211471.aspx. VisualElements describes the visual aspects of the Windows Store app: its default tile, logo images, text and background colors, initial screen orientation, splash screen, and lock screen tile appearance.

    For instance the win8.1 application contains new size logo(310*310) and tile, the old version(8.0) can not recognize these and therefore an error thrown.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    2013年11月21日 7:01
    版主
  • Thanks James.

    nio

    2013年11月21日 10:28