locked
VIA High Definition声卡驱动组件化后进入系统声卡显示为“Unknown device” RRS feed

  • 问题

  • 开发平台是xp embedded sp3,机器的其他驱动都组件化成功了,就只有声卡不成功。声卡是VIA High Definition声卡,芯片是via vt1705
    出现的现象是:
    1、组件设计导入inf文件的时候没有出现错误,只有一些警告,目标设计的时候没有错误和警告。
    2、系统启动后在设备管理器里面声卡显示为“Unknown device”,而且设备前面没有黄色的感叹号。感觉好像已经驱动了,只是名字不对,但是不能

    发声。
    3、用更新驱动的方法手动安装驱动失败,有个失败码是“(code28)”,而且设备前面出现黄色叹号。
    4、后来重新进行目标设计,并且在目标设计的时候没有引入声卡的组件,进入系统后手动安装驱动成功。
    因为不希望在进入系统后手动安装驱动,希望有热心的前辈能点拨一下。是否在组件设计导入inf文件时还需要进行特殊的设置,请指教。

    2011年3月8日 3:16

答案

  • 开始不成功是用的最新版本的驱动做的,后来换成版本低点的驱动做就一次成功了。
    • 已标记为答案 flyerboys 2011年3月16日 2:54
    2011年3月16日 2:54

全部回复

  • 最好将导入INF的Log公布一下。建议:

    (1)现在普通XP安装声卡成功。

    (2)导入INF时,可以就在此安装了声卡的XP的\windows\inf目录导入,以免include文件丢失。


    http://wince.cn/ or http://windowsce.com.cn/
    2011年3月8日 9:55
    版主
  • 想问一下楼主,您上面用来制作组件的Inf是如何得到的,是通过驱动提取软件提取出的,还是该setup程序自带的?


    Stay Running
    MCTS:
    Windows Embedded Standard 2011,Development
    Windows Embedded Standard 2009,Development
    MSN:chenghufan@hotmail.com
    Beijing Strong Union Technology CO., LTD.
    2011年3月8日 15:19
  • 仔细检查导入驱动的log,看看有没有缺少文件的警告

    例如缺少ks.inf


    Zhengbo.Xiao
    硬件销售及IT技术外包
    我的WIndows Embedded中文技术BLOG:
    www.XPE.cc
    blog搬家了,欢迎访问: http://questor87.wordpress.com/
    为解决大陆的Windows Embedded的开发者无法访问http://questor87.wordpress.com/,特从2010年11月起,在
    QQ:1320232327(另外两个已满)
    MSN:questor_87@hotmail.com
    MCTS:
    Windows Embedded Standard 7 Development
    Windows Embedded Standard 2009 Development
    Windows Embedded Standard CE Development
    Microsoft MVP(2010)
    2011年3月10日 13:12
    版主
  • 开始不成功是用的最新版本的驱动做的,后来换成版本低点的驱动做就一次成功了。
    • 已标记为答案 flyerboys 2011年3月16日 2:54
    2011年3月16日 2:54