none
silverlight2.0安装问题 RRS feed

  • 问题

  •  

    以前版本的silverlight runtime已卸载

    安装新版silverlight2.0时,出现

     

     

    <无法安装silverlight

    您的silverlight开发人员组件已过期.>

     

     

    请问如何解决?

     

     

    2008年11月24日 3:44

答案

  • 现在报告什么错误提示?
    你下载的语言版本要与你的VS版本一致,另外,下载的地址都在

    http://www.microsoft.com/downloads/results.aspx?DisplayLang=zh-cn&nr=20&freetext=Silverlight&sortCriteria=date

    按日期倒序
    2008年11月24日 7:06
    版主
  •  MacBoA 写:

    我试过了您说的方法,可是仍然不能安装我的silverlight.....- -

     

    你要确认你的vs 08是否是sp1 你的vs08是否是 中文版,下载的sl tools是否是中文版

    今天中文版的sl tools刚刚更新到146版本,再下一次看看

    2008年11月24日 7:55
    版主

全部回复

  •  MacBoA 写:

     

    以前版本的silverlight runtime已卸载

    安装新版silverlight2.0时,出现

     

     

    <无法安装silverlight

    您的silverlight开发人员组件已过期.>

     

     

    请问如何解决?

     

     

     

    http://forums.microsoft.com/china/ShowPost.aspx?PostID=4120391&SiteID=15

    runtime sdk tools还有blend 2.5都要先卸载,注意帖子红字

    2008年11月24日 3:52
    版主
  •  

    非常感谢.我试试

    2008年11月24日 4:01
  • 我试过了您说的方法,可是仍然不能安装我的silverlight.....- -

    2008年11月24日 6:38
  • 给你个绝招:

     

    1. 备份注册表.

    2. 搜索注册表中的silver light, 删除全部相关键值.

    3. 重新安装silver light

     

    2008年11月24日 6:58
  • 现在报告什么错误提示?
    你下载的语言版本要与你的VS版本一致,另外,下载的地址都在

    http://www.microsoft.com/downloads/results.aspx?DisplayLang=zh-cn&nr=20&freetext=Silverlight&sortCriteria=date

    按日期倒序
    2008年11月24日 7:06
    版主
  •  MacBoA 写:

    我试过了您说的方法,可是仍然不能安装我的silverlight.....- -

     

    你要确认你的vs 08是否是sp1 你的vs08是否是 中文版,下载的sl tools是否是中文版

    今天中文版的sl tools刚刚更新到146版本,再下一次看看

    2008年11月24日 7:55
    版主