none
Win7 模拟器上网 RRS feed

  • 问题

  • 想请教的问题是:Win7下 VS2005  Mobile SDK 5.0如何实现模拟器上网?谢谢回复……


    Do a right thing then do it right!

    2012年2月21日 8:14

答案

  • 你好,

    不知道你有没有安装Windows Mobile设备中心,安装了这个软件,在模拟器启动以后,右键点击“cardle”,等待模拟器与PC机进行同步,同步以后,模拟器就可以使用PC的网络连接实现上网了。


    Keep Fighting

    • 已标记为答案 sleep87 2012年2月24日 8:08
    2012年2月21日 9:43
    版主

全部回复

  • 你好,

    不知道你有没有安装Windows Mobile设备中心,安装了这个软件,在模拟器启动以后,右键点击“cardle”,等待模拟器与PC机进行同步,同步以后,模拟器就可以使用PC的网络连接实现上网了。


    Keep Fighting

    • 已标记为答案 sleep87 2012年2月24日 8:08
    2012年2月21日 9:43
    版主
  • 你好,首先谢谢你的回复!

    我安装了那个Windows Mobile设备中心。在模拟器启动以后,右键点击“cardle”,一点变化都没有


    Do a right thing then do it right!

    2012年2月21日 9:59
  • 小歐ou

    谢谢你的回复,看了你推荐的这个文章,还是不行!


    Do a right thing then do it right!

    2012年2月21日 10:02
  • 我想问一下,这个开发环境有关系吗?我在网上看的有人用的是VS2008 而我用的是VS2005.这个会有影响吗?

    还有一个问题是这个Windows Mobile设备中心是不是对模拟器不适用,只使用于真实的设备?


    Do a right thing then do it right!


    • 已编辑 sleep87 2012年2月21日 10:31
    2012年2月21日 10:26
  • 你好,

    在设备中心的“连接设置”中,有一个“允许连接到以下任一端口”,在下拉列表中,选择DMA。


    Keep Fighting

    2012年2月21日 11:31
    版主
  • 你好,

    在设备中心的“连接设置”中,有一个“允许连接到以下任一端口”,在下拉列表中,选择DMA。


    Keep Fighting

    你好,这个我也设置了!

    Do a right thing then do it right!

    2012年2月22日 1:00
  • 设置完以后,模拟器与PC机同步了没?没同步的话,也无法上网的。

    Keep Fighting

    2012年2月22日 1:01
    版主
  • 模拟器和PC机没有实现同步……我通过设备仿真器管理器可以实现连接到指定的某个模拟器,但是在设备仿真器模拟器上点击“插入底座”没有反应!

    Do a right thing then do it right!

    2012年2月22日 2:17
  • 这个问题不好说了。楼主解决了吗?解决了的话,发上来共享一下。

    Keep Fighting

    2012年2月23日 2:14
    版主
  • 还没有解决呢,解决的时候一定会发上来共享一下的!:)

    Do a right thing then do it right!

    2012年2月24日 1:02
  • 问题解决了,但是还是不知道问题究竟是出在哪里!我是在原有环境的基础上装Windows Mobile 6 Professional SDK Refresh.msi以及Windows Mobile 6 Professional Images (CHS).msi然后又装了Virtual PC 2007.首先打开Windows Mobile设备中心,

    在连接设置

    启动模拟器后File-Configure-NetWork--选择Enable NE2000……然后设置模拟器 网络适配器、连接然后在设备仿真器管理器当前连接的模拟器上右击--Cradle,弹出提示框点击确定。然后Windows Mobile设备中心就会提示已连接

    直接选择第二个模拟器也是可上网的,选择第一个,选择想要同步的选项-然后“下一步”也是可以实现上网的。

    这次成功后,后来发现直接用设备仿真器管理器-启动相应的模拟器(对模拟器也不进行任何设置)然后再Cradle,Windows Mobile设备中心就会提示已连接,也可以实现模拟器上网。想知道问题究竟在哪里?就把后来安装的工具都卸载后再执行相应的操作依然可以!或许最开始在相应的工具安装好,没有重启导致的问题!!??

    在这里主要两点:

    高校青椒
    (MVP)  都有提到过

    1:Windows Mobile 设备中心连接设置-允许连接到以下任一端口选择 DMA.

    2:模拟器启动后,启动设备仿真器管理器在已经连接的模拟器上右击-Cradle(插入底座)下面按照提示来就可以了

        虽然还没弄清楚问题究竟出在哪里?但是问题解决了,还是很开心!难道有些事情,真的是没有答案的!?


    Do a right thing then do it right!

    2012年2月24日 8:20
  • 多谢分享!

    Keep Fighting

    2012年2月27日 0:17
    版主