none
inactivityTimeout,wshttpbinding 的问题 RRS feed

  • 问题

  • Frank 老师,
      以前有个帖子中您提到,  服务通道长久不使用的话,再次调用就会出错。显示通道状态处于Faulted。 因为 inactivityTimeout="0:0:5" 。
    我的问题是 :
    配置inactivityTimeout是不是必须把可靠性会话设定为enable="true"
    比如 wsHttpBinding,默认 reliable session 是关闭的.
    不启用reliable session是不是就没办法来控制通道的持续时间?


    2009年9月6日 4:11

答案

  • 如果这样的话,那ENABLE还有什么作用,如果不启用,其他的参数照样能够起作用,是有点怪。.
    • 已标记为答案 sofish 2009年9月6日 9:38
    • 取消答案标记 sofish 2009年9月6日 10:06
    • 已标记为答案 sofish 2009年9月6日 10:11
    2009年9月6日 9:37

全部回复

  • Hi,
    不要客气。

    要设置这个属性不是必须启用可靠性会话。
    这个是对通道两次活动之间时间间隔的设置。
    也就是闲置时间。

    我做了下测试,不启用安全会话也可以启用这个属性。
    <reliableSession enabled="false" inactivityTimeout="00:10:00" ordered="true"/>
    这个是参考设置。


    Frank Xu Lei--谦卑若愚,好学若饥
    专注于.NET平台下分布式应用系统开发和企业应用系统集成
    Focus on Distributed Applications Development and EAI based on .NET
    欢迎访问老徐的中文技术博客:Welcome to My Chinese Technical Blog
    欢迎访问微软WCF中文技术论坛:Welcome to Microsoft Chinese WCF Forum
    欢迎访问微软WCF英文技术论坛:Welcome to Microsoft English WCF Forum
    2009年9月6日 9:34
    版主
  • 如果这样的话,那ENABLE还有什么作用,如果不启用,其他的参数照样能够起作用,是有点怪。.
    • 已标记为答案 sofish 2009年9月6日 9:38
    • 取消答案标记 sofish 2009年9月6日 10:06
    • 已标记为答案 sofish 2009年9月6日 10:11
    2009年9月6日 9:37