none
Remoting组件,怎样设置访问权限,我指的是系统自定义的用户访问的控制。 RRS feed

答案

全部回复

  • 这要看你采用的是何种身份验证的形式。Windows集成身份验证还是自定义的验证方式。
    2007年7月25日 6:06
  • 这个似乎和我遇到的问题很相似,你可以看看我的问题:

    http://social.microsoft.com/Forums/zh-CN/2212/thread/a6415463-655e-482a-af6a-4e0860c420a8

    开发者对.NET采取的这种安全验证机制诟病颇多,因为这个安全机制把本来很简单的事情搞得非常麻烦。如果两台电脑不在同一个Domain当中,报错给出的提示并不能解决实际的问题。

    http://www.codeproject.com/answers/55152/How-do-I-configure-security-to-get-rid-of-a-NET-Re.aspx

    =========================================
    Everything works wonderfully when running both the client and the server on 
    one machine, but putting it on a different machine completely breaks it.

    I've tried just about every combination of impersonationLevel's, 
    tokenImpersonationLevels, authorizationModules, secure/unsecure, you name it 
    I've done it. All I want is anonymous access -- I have my own authorization 
    scheme damn it!

    GAHHHH!!!!!

    Sorry. Can anyone point me in the right direction? All I need is an example 
    of a remoting object that does absolutely no client validation. I would 
    think that would be so simple and yet Microsoft makes this so hard. Horrible 
    documentation on the subject of remoting IMHO.
    =========================================

    http://okquestions.com/c6f9ea1cc7ee15b674a912edf04cf62f-_2005_easy_remoting_question/


    =========================================

    This should be the easiest thing in the world to do, but it has turned into 
    a huge nightmare. No matter what I do, I cannot get rid of NT authentication 
    when using .NET remoting over the internet. I always end up getting "A 
    remote side security requirement was not fulfilled during authentication. 
    Try increasing the ProtectionLevel and/or ImpersonationLevel.", no matter 
    what I do.

    ALL I want to do is have a client-activated object, where the server does NO 
    authentication. I absolutely, for the life of me, cannot figure out how to 
    disable NT authentication. I've made an authorizationModule that always 
    returned true, I've disabled and enabled every single setting in the 
    IDictionary used to set up the different TcpChannels. Somebody out there 
    MUST have an example -- this is driving me NUTS.
    =========================================

     

    2010年4月8日 13:48