none
Team Foundation Service连接不上,求助。 RRS feed

  • 问题

  • 我在Team Foundation Service中注册了账号并添加了一个项目,可是我用VS2012怎么也连不上。如下图:

    而且,就算我用页面中的“Open new instance of Visual Studio”连接,虽然能打开VS,但是VS也没有连上TFS。

    请问如何修复这个问题呢?

    谢谢!

    PS:我的使用环境是 windows 7 ultimate chs + vs 2012 ultmate chs trial

    2012年10月21日 11:07

全部回复

  • Hi,

    我这边做了一个测试,我能够在VS2012中成功连接TFS Service Preview,所以说微软这边的服务器应该是没有什么问题的。另外你可以在浏览器中正确浏览,那么我想你所使用的账号应该也是正确的。

    请问你有自己配置过你的project 吗?默认情况下在Vs中连接TFS Service Preview时端口号是8080,协议是HTTP。还有,请你确认一下你确实是在使用VS2012 (从UI上看,个人认为你有可能在使用VS2010)。 如果你使用的是VS2010,如果要想要连接 TFS Service Preview, 你需要额外安装VS2010 SP1 和 VS2010 SP1 KB2581206。另外,Open new instance of Visual Studio 仅对于VS2012 起左右,如果你的机器上仅安装VS2010 那个feature是不好用的。


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    2012年10月23日 4:34
    版主
  • 首先,感谢你的热心回复。

    补充说明一下我的使用环境:windows 7 ultimate chs + VS2010 ultimate chs + VS2012 ultimate chs。

    另外说一下,我确定自己每次打开的都是VS2012,而不是2010。这个我还是分得清楚的。

    我今天又尝试了一次那个“Open new instance of Visual Studio”连接,这次VS2012打开后,弹出了一个对话框,里面好像在访问一个什么页面,然后这个对话框不停地弹出一个提示信息,弹了好多次,再然后页面显示让我输入live账号,我输入完成后,又弹出那个提示好多次。最后,这个弹出的对话框关掉了,但是VS还是显示无法连接。

    弹出的提示信息如下,我每次都选的“是”。

    最后VS显示的状态如下:

    这些之后,我把VS关掉了,IE也关掉了。然后我在用IE打开tfs的页面并点击那个“Open new instance of Visual Studio”连接,结果,VS成功启动,但是没有任何与tfs相关的信息显示出来,就好像我手动启动VS一样。

    2012年10月27日 5:19
  • 我在自己的笔记本一连这个服务就把vs2012挂掉啦,但在公司的台式机上就没问题。

    另外在笔记本我用浏览器可以查看tfsserver (visualstudio.com),但vs2012 就挂了莫名其妙

    2012年12月21日 9:00
  • 你好, 沉默的老虎

    可以看看是不是系统时间和tfs时间没有对上的原因?

    希望有帮助,谢谢:)


    Come back...... Welcome to my blog www.cnblogs.com/elvis0123

    2013年1月5日 5:57