none
VS2008中,添加新数据源 RRS feed

  • 问题

  •  

    安装好VS2008后,启动IDE,建立一个新解决方案,单击添加新数据源,怎么只出现一个“对象”啊?为什么不出现“数据库”和“WEB数据库”?我看帮助里说,是有3项的,做了系统,重新安装VS2008,问题还是一样。
    2008年10月20日 3:11

答案

  • 你新建一个网站 放到当前的 解决方案里,然后在 新建的网站(在App_Data上右键) 去新建,就可以了。
    2008年10月20日 3:52
    版主

全部回复

  • 你好!
       请问你安装的SQL Server是什么版本的,用SQL Server自带的Management Studio工具可以连接数据库吗?
    2008年10月20日 3:17
    版主
  •  

    我装的SQL2005,用企业管理器可以连接数据库
    2008年10月20日 3:27
  • 你把对象展开试试。
    2008年10月20日 3:42
    版主
  • 你新建一个网站 放到当前的 解决方案里,然后在 新建的网站(在App_Data上右键) 去新建,就可以了。
    2008年10月20日 3:52
    版主
  •  

    我把对象展开了,里面只有新建方案的一个界面元素,没有选择数据库的地方。一般选择添加新数据源,出来的那个对话框应该有3个选项的啊,我的没有,只有一个选项,就是对象。
    2008年10月20日 3:54
  • 你好!
       你新建一个项目,然后再试试添加数据源,如果问题还是存在,你再把问题发上来。
    2008年10月20日 4:33
    版主
  •  

    刚才吃饭去了,不好意思,事情是这样的,我本来装的是VS2005,SQL2005,后来装了个2008,添加数据源的时候发现的问题,然后做了系统,重新安装2008,结果还是不行,我在网上查了半天,没有结果,只好把2008删了,又重新做的2005.
    2008年10月20日 4:47
  •  

    我从微软的网站下了个2008,安装一切顺利,装好之后,新建项目,结果还是那样,选择的数据源只有一个“对象”
    2008年10月22日 1:14
  • 你的VS2005是哪个版本的呢?Express版,标准版,还是团队版 ?
    2008年10月22日 2:02
    版主
  • 是团队版的,我从新做了系统,什么都不装的情况下,直接安装2008的专业版,新建工程就是那个样子了,极度郁闷啊,现在我给XP打了SP3,然后修复2008,也不行,装了2008的SP1,还是不行,我真奇了怪了
    2008年10月22日 6:10
  •  

    我的系统里,现在2005和2008都有,我感觉好像我的系统少东西啊,

    2005的安装目录 Microsoft Visual Studio 8 下的SDK目录有222M

    2008的安装目录 Microsoft Visual Studio 9.0 下的SDK目录才55K,差的太多了吧?

    2008年10月22日 6:23
  • 原来不是我一个人有问题啊..大家都有问题...

    噢..还以为是我电脑出了问题..

    大家都一样..也只有一个对象.....

    极度郁闷.....我现在都不知道该怎么办了..

    2008年11月22日 0:15
  • 怎么就没有下文了?  没有解答啊!

     

    • 已建议为答案 Jlike 2009年2月19日 8:57
    2008年12月3日 13:32