none
Vista SP1,VS2008 SP1,IE 8下调试VS2008中Web Site出错 RRS feed

  • 问题

  • 描述如下:
    A、联网情况下
    在VS中按F5运行Web调试,出错提示为:“

    Internet Explorer 无法显示该页面

    ”此时IE8的地址栏中为“http://localhost:6999/Web/”
    将localhost改为“127.0.0.1”竟然可以!⊙﹏⊙b汗!
    B、断开网线,直接调试运行。无任何问题,(#‵′)靠!;此时IE8标题栏还是”http://localhost:6999/Web/“
    在没升级为IE8之前,我是IE7也出现过类似的问题,但是没注意,不知道这个Vista的问题呢,还是VS2008的问题,希望知道的同志能分析下,或者给个修复的办法!
    2009年3月31日 8:46

答案

  • 谢谢孟老师的回答,^_^
    问题解决了,竟然真的是host的问题
    解决问题的思路:
    不管如何现在host的可疑最大
    在cmd中输入 C:\WINDOWS\system32\drivers\etc\hosts
    发现host文件如下显示
    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host


    ::1             localhost
    ⊙﹏⊙b汗啊!
    没有 127.0.0.1 啊。~
    于是在做了如下修改
    127.0.0.1       localhost
    ::1             localhost
    再次运行VS调试,问题解决!
    但是,我还是不知道为啥 断开网络的时候确可以?


    2009年3月31日 9:14
  • ::1  localhost的原因是因为补丁 KB915597 造成的

    ::1  localhost 是IPv6的写法。


    孟宪会
    2009年3月31日 12:38
    版主

全部回复

  • 补充一下,在断网情况下杀毒软件和防火墙都是开着的,这样应该可以排除杀毒软件和防火墙的问题,
    在联网的情况下用别的浏览器(Firefox)也没连接成功。估计是ASP。NET Development Server的问题。或者是Host文件有问题,但是又说不清。哎!
    2009年3月31日 8:52
  • IE 8 has a feature called Loosely-Coupled Internet Explorer (LCIE) which results in IE running across multiple processes.
    http://www.microsoft.com/windows/internet-explorer/beta/readiness/developers-existing.aspx#lcie

    Older versions of the Visual Studio Debugger get confused by this and cannot figure out how to attach to the correct process.  You can work around this by disabling the process growth feature of LCIE.  Here's how:

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    Since you are running on Windows Server 2003, this is all you should need to do.  If you run into the same problem on Vista or newer, you will also need to turn off protected mode.

    看看是不是这个原因
    孟宪会
    2009年3月31日 8:58
    版主
  • 谢谢孟老师的回答,^_^
    问题解决了,竟然真的是host的问题
    解决问题的思路:
    不管如何现在host的可疑最大
    在cmd中输入 C:\WINDOWS\system32\drivers\etc\hosts
    发现host文件如下显示
    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host


    ::1             localhost
    ⊙﹏⊙b汗啊!
    没有 127.0.0.1 啊。~
    于是在做了如下修改
    127.0.0.1       localhost
    ::1             localhost
    再次运行VS调试,问题解决!
    但是,我还是不知道为啥 断开网络的时候确可以?


    2009年3月31日 9:14
  • ::1  localhost的原因是因为补丁 KB915597 造成的

    ::1  localhost 是IPv6的写法。


    孟宪会
    2009年3月31日 12:38
    版主