none
vs2008开发.net 2.0的项目,在客户机上是不是只要安装.net 2.0就可以运行了? RRS feed

答案

  • 嗯 如果你是基于.net2.0的,客户机也需要安装.net 2.0
    Wenn ich dich hab’,gibt es nichts, was unerträglich ist.坚持不懈!http://hi.baidu.com/1987raymond
    2009年7月2日 4:35
    版主
  • 你好!
         是的,需要安装.NET Framework2.0,或更高版本的(3.0,3.5等)也可以!
    周雪峰
    2009年7月2日 5:11
    版主
  • 注意还需要把你的项目引用的dll,配置文件等,也都打包在安装包里一起提供给客户!
    周雪峰
    2009年7月2日 8:55
    版主
  • vs2008开发.net 2.0的项目,在客户机上是不是只要安装.net 2.0就可以运行了?

    呵呵,如果你的项目是基于.net2.0开发的,使用到2.0的类库,是需要安装对应版本的的、.net framework 2.0;
    没使用到的话,就不需要。
    这个你可以再制作安装包的时候作为安装的必备条件添加到安装程序里。
    会自动检测客户机,没有的话会提示安装,你可以把2.0安装文件一次打包或者给你安装下载的地址即可~
    Frank.Xu Lei--谦卑若愚,好学若饥
    专注于.NET平台下分布式应用系统开发和企业应用系统集成
    Focus on Distributed Applications Development and EAI based on .NET
    老徐的博客:http://frank_xl.cnblogs.com
    2009年7月2日 10:19
    版主

全部回复

  • 嗯 如果你是基于.net2.0的,客户机也需要安装.net 2.0
    Wenn ich dich hab’,gibt es nichts, was unerträglich ist.坚持不懈!http://hi.baidu.com/1987raymond
    2009年7月2日 4:35
    版主
  • 你好!
         是的,需要安装.NET Framework2.0,或更高版本的(3.0,3.5等)也可以!
    周雪峰
    2009年7月2日 5:11
    版主
  • 必须安装对应的.net framework


    http://feiyun0112.cnblogs.com/
    2009年7月2日 6:16
    版主
  • 会不会有一些兼容性问题?另外有没有一些什么要特别注意的问题?
    2009年7月2日 7:56
  • 注意还需要把你的项目引用的dll,配置文件等,也都打包在安装包里一起提供给客户!
    周雪峰
    2009年7月2日 8:55
    版主
  • vs2008开发.net 2.0的项目,在客户机上是不是只要安装.net 2.0就可以运行了?

    呵呵,如果你的项目是基于.net2.0开发的,使用到2.0的类库,是需要安装对应版本的的、.net framework 2.0;
    没使用到的话,就不需要。
    这个你可以再制作安装包的时候作为安装的必备条件添加到安装程序里。
    会自动检测客户机,没有的话会提示安装,你可以把2.0安装文件一次打包或者给你安装下载的地址即可~
    Frank.Xu Lei--谦卑若愚,好学若饥
    专注于.NET平台下分布式应用系统开发和企业应用系统集成
    Focus on Distributed Applications Development and EAI based on .NET
    老徐的博客:http://frank_xl.cnblogs.com
    2009年7月2日 10:19
    版主
  • 你好,最好安装.NET Framework 3.5,它是向下兼容的。还有就是生产环境和运行环境是有区别的,很多问题在运行的时候才发现问题,比如说性能,安全等等。
    邹俊才
    2009年7月2日 14:47
    版主