none
sql连接字符串? RRS feed

  • 问题

  • 连接字符串中 server 是写机器名称还是IP地址? 为什么我有时候写机器名称无法连接到服务器?
    在建立与服务器的连接时出错。在连接到 SQL Server 2005 时,在默认的设置下 SQL Server 不允许进行远程连接可能会导致此失败。 (provider: 命名管道提供程序, error: 40 - 无法打开到 SQL Server 的连接)


    服务器:是SQL Server 2000 的数据库,系统是 Windows Server 2000.
    客户端:系统 Windows XP。

    • 已移动 Sheng Jiang 蒋晟 2010年3月15日 22:46 非System.Data (发件人:ADO.NET 与 LINQ)
    2010年3月4日 1:25

答案

  • 你好姚上东:
    1.用IP 地址来设置,特别桥接
    2.你的链接字符串用的是Server的那种吗?改成 Data Source=Aron1;Initial Catalog= pubs;UserId=sa;Password=asdasd;"
    不要用"Server=Aron1;Database=pubs;UserID=sa;Password=asdasd;Trusted_Connection=False" 这种
    希望可以解决你的问题





    我们要把爱心传递给更多需要帮助的人。
    博客:http://terryfeng.cnblogs.com
    微博:http://t.sina.com.cn/terryfeng
    个人:http://www.terryfeng.com
    • 已标记为答案 姚上东 2010年3月8日 4:44
    2010年3月6日 1:37

全部回复

  • 1) 确认你的Windows Server 2000 已经安装了SP4
    2) 确认你的SQL SERVER 2000 已经安装了SP3 或者更高版本的补丁
    3) 确认named pipe 打开


    你的错误提示是SQL 2005 的, 你又说你的数据库是SQL SERVER 2000 我搞不清楚你的问题到底是SQL 2005 还是 SQL 2000
    SQL 2005 有一个工具叫做SQL 2005 Configuration Manager ,在那里面找到Network proctol 节点,将Named pipe Enable
    2010年3月4日 2:23
  • 服务器:
    数据库 SQL SERVER 2000,操作系统 Windows Server 2000

    我客户端是用桥连的 一个连接内网,一个连接外网。访问的是内网的数据库。
    2010年3月4日 6:43
  • 你好姚上东:
    1.用IP 地址来设置,特别桥接
    2.你的链接字符串用的是Server的那种吗?改成 Data Source=Aron1;Initial Catalog= pubs;UserId=sa;Password=asdasd;"
    不要用"Server=Aron1;Database=pubs;UserID=sa;Password=asdasd;Trusted_Connection=False" 这种
    希望可以解决你的问题





    我们要把爱心传递给更多需要帮助的人。
    博客:http://terryfeng.cnblogs.com
    微博:http://t.sina.com.cn/terryfeng
    个人:http://www.terryfeng.com
    • 已标记为答案 姚上东 2010年3月8日 4:44
    2010年3月6日 1:37