none
vs2012 里没有.net4.0框架。 RRS feed

  • 问题

  • 系统是win8 64

    vs2012安装完后只有net2.0 net 3.5, 我又重新安装了一遍。NET4.5出来了,但是还是缺少net4.0的框架。

    下载了net4.0 ,无法安装,说是

    Microsoft .NET Framework 4 已是此操作系统的一部分。不需要安装 .NET Framework 4 可再发行组件包。<A HREF="http://go.microsoft.com/fwlink/?LinkId=164207">详细信息</A>。

    已在此计算机上安装相同或更高版本的 .NET Framework 4。

    控制版面里 添加或删除windows功能 里面也没有net4.0的选项,哎,我反复重装vs2012好几次了

    2012年11月6日 13:34

答案

  • Hi,

    Win8系统是自带.NET 4.5的,而且.NET 4.5是.NET 4.0的 替代升级版,所以当你在Win8的机器上安装.NET 4.0的时候你会得到上面的错误信息。

    在我的Win8机器上,我的VS2012里是可以找到4.0。请问你在安装VS2012的时候有遇到过什么错误吗?你使用的是什么edition的VS2012?或者你可以考虑把VS2012 先卸载掉然后再重新安装一下。


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    2012年11月8日 8:37
    版主

全部回复