none
C# 目标框架提示缺少.netfrramework4.5

    问题

  • C#编写的一个excel插件,当我用.netframework4.0编译成功后,放在xp上运行,却提示无.netframework4.5,应该提示没有.netframe4.0才对啊,我想这个程序能在xp运行,但是xp不支持4.5。

    另外新手不让上传图片。。。。

    2016年9月12日 9:22

答案

  • xp不支持4.5,这是事实,只能把它降级为.net 4.0才行。

    .net 4.5是.net 4.0的in-place update,也就是.net 4.5是直接替换.net 4.0的文件,你看下excel插件引用的类库,是不是有的是以.net 4.5编译的,要重新引用.net 4.0的程序再编译。


    专注于.NET ERP/CRM开发框架,C/S架构,SQL Server + ORM(LLBL Gen Pro) + Infragistics WinForms

    2016年9月12日 11:59