none
为什么最新版的VS2017没有net framework 4.6.2,且我无法安装? RRS feed

  • 问题

  • 如下图,我下载了完整了离线安装的net framework 4.6.2,双击安装发现此问题:

    这是为啥呢?是不是我有什么限制没有注意呢?

    这是我的VS,没有4.6.2:

    我的电脑:Windows 8.1:


    Reproduce your quesions with   ScreenToGif is your choice.
    For IIS: IIS Forum,
    For WebSite of .NET, ASP.NET Forum,
    For others, StackExchange
    For spam-sender or forum urgent issues, Send your Email at: forumsfeedback@microsoft.com



    2017年8月23日 4:04
    版主

答案

全部回复

  • 在安装VS 2017,4.6.2是可选组件!

    在设置中,需选择.net 4.6.2, 因为.net标准2.0将使用4.6.1,4.6.2默认情况下不启用,只有4.6.1。

    大多数C#7.0功能在VS2017中可用的默认4.6.1 .Net框架,也许是这个原因,VS在安装时,没有设定为default,所以你要手动再安装.NET Framework 4.6.2 Developer Pack。

    https://www.microsoft.com/zh-CN/download/details.aspx?id=55168

    下面是单纯的.NET Framework 4.6.2,是你安装在系统上.但是他并没有依附在开发package上。

    https://www.microsoft.com/zh-CN/download/details.aspx?id=53345

    另一个可能是你已经装了.net framework 4.7,所以当你在安装4.6.2,它就不会上去。

    因为我之前在安装时,也遇过相同的状况。 (我的经验)









    2017年8月23日 8:39
  • 您好:

    因为你已经安装.net framework 4.7, 所以.net framework 4.6.2无法安装。先安装低版本再安装高版本,所以请先卸载.net framework 4.7,然后安装.net framework 4.6.2.


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年8月23日 9:16