none
目标机连接开发主机时,出现Jumping to 0x0013A01C,请问如何解决? RRS feed

  • 问题

  • 在通过网络下载操作系统镜像时,目标机黑屏,显示Jumping to 0x0013A01C,开发主机接收不到信息。
    按Attach,则出现以下错误:
      CoreCon)  20:08:31 08/04/2009 中国标准时间:  Failed to connect debug message service! Please check the transport settings.
    (CoreCon)  20:08:31 08/04/2009 中国标准时间:  Transport service failed to connect
    (CoreCon)  20:08:31 08/04/2009 中国标准时间:  Warning:  One or more services failed to connect.  Make sure that the service is properly configured.

    按照有的说法,将CoreCon文件夹删除了,并重新安装了PB,还是不行。
    各位大侠,请问如何解决?
    2009年8月4日 12:45

答案

  • ICOP的BSP里面可以选择显卡的分辨率,你自己要选择了它的BSP下面还有选项 你必须打开就会看到Z9S的选项
    那个就是显示!

    • 已标记为答案 yannai 2009年8月25日 2:59
    2009年8月19日 10:40
  • 首先 Z9S是ICOP板块选用的一种显示芯片(其是以前的SIS公司分解出来的一个新的芯片公司)
    当然它的驱动也就是Z9S了,至于版本D和版本E中有何没有对分辨率的设置应该去问问
    ICOP做BSP的 可能是为了方便用户设置 所以人家自己加了LCD和普通的显示支持吧!
    • 已标记为答案 yannai 2009年8月25日 2:59
    2009年8月23日 8:55

全部回复

  • 没有人遇到过和我一样的问题吗?
    2009年8月5日 2:06
  • 你用的什么平台,能不能详细说明一下?
    Hello everybody
    2009年8月5日 3:26
    版主
  • 你用的什么平台,能不能详细说明一下?
    Hello everybody
    非常感谢你的回复,希望继续关注我的问题。
    我用的是ICOP的VDX-6354,详细信息如下:

    Specifications:

    SoC DM&P SoC CPU Vortex86DX- 800MHz
    Real Time Clock with Lithium Battery Backup
    Cache L1:16K I-Cache, 16K D-Cache, L2 Cache 128KB
    Bus PC/104 standard compliant
    PC-104, PC/104+ (Optional)
    BIOS AMI BIOS
    System Memory 256MB DDR2 Onboard
    Watchdog Timer 0 & 1 Sets Software programmable from 30.5 µsec. To 512 sec. x 2
    sets (Watchdog 1 fully compatible with M6117D)
    VGA XGI Volari Z9s Chipset
    VGA and TFT Flat Panel Interface Support
    Onboard 32MB VGA Memory, support resolution up to
    1280 x 1024, 16M colors
    LAN Integrated 10/100Mbps Ethernet
    Audio CM119 USB Audio controller
    Flash Disk Support Onboard 4MB SPI Flash Disk
    MSTI EmbedDisk Module (16MB and above)
    I/O Interface Enhanced IDE port (UltraDMA-100/66/33) x1
    RS-232 port x3
    RS-232/422/485 port x1
    USB port (Ver2.0) x2
    Parallel port x1
    16-bit GPIO port x1
    10/100Mbps Ethernet port x1
    Connectors 2.0mm 44-pin box header for IDE x1
    2.0mm 44-pin box header for LCD x1
    2.0mm 10-pin box header for VGA x1
    2.0mm 10-pin box header for USB x1
    2.0mm 26-pin box header for Printer x1
    2.0mm 20-pin box header for 16-bit GPIO x1
    2.0mm 10-pin box header for RS-232 x4
    2.0mm 8-pin header for Ethernet x1
    2.54mm 5-pin box header for Keyboard x1
    2.54mm 5-pin box header for Mouse x1
    2.54mm 4-pin header for -5V, -12V, +12V, GND, DC-in x1
    2.54mm 3-pin header for RS-485 x1
    2.54mm 2-pin header for Reset x1
    2.54mm 7-pin header for Redundancy Signal x1(Optional)
    2.54mm 2-pin header for System-Fail-SW x1(Optional)
    1.25mm 6-pin wafer for JTAG x1
    1.25mm 4-pin wafer for Line-out/MIC-in x2
    Power Requirement Single Voltage +5V @ 740mA
    Weight 90g
    Board Size 90 X 96mm (3.54 x 3.77 inches)
    Operating Temperature -20°C ~ +70°C
    -40°C ~ +85°C(Optional)



    以下是我今天用PB中的ceterm得到的串口调试信息:

    Microsoft Windows CE Ethernet Bootloader Common Library Version 1.1 Built Jun 21 2004 18:06:06
    Microsoft Windows CE Ethernet Bootloader 3.5 for CE/PC (Jun 21 2004)
    Boot Args @ 0x27746 and  ucLoaderFlags is 1
    FlashInit
    -FlashInit:Fails!!!!
    PCI Device Configurations (1 PCI bus(es) present)...
    ========================================================
     Bus, Device, Function = 0, 3, 0
     Vendor ID, Device ID  = 0x18CA, 0x0020
     Base Class, Subclass  = 3, 0 => DISPLAY_CTLR
     Interrupt             = 0
     BaseAddress[0]        = 0xF8000000 (Memory)
     BaseAddress[1]        = 0xFEFC0000 (Memory)
     BaseAddress[2]        = 0xDF80 (I/O)
    ========================================================
     Bus, Device, Function = 0, 8, 0
     Vendor ID, Device ID  = 0x17F3, 0x6040
     Base Class, Subclass  = 2, 0 => NETWORK_CTLR
     Interrupt             = 9
     BaseAddress[0]        = 0xDE00 (I/O)
     BaseAddress[1]        = 0xFEFBB400 (Memory)
    ========================================================
     Bus, Device, Function = 0, 10, 0
     Vendor ID, Device ID  = 0x17F3, 0x6060
     Base Class, Subclass  = 12, 3 => SERIAL_BUS_CTLR
     Interrupt             = 6
     BaseAddress[0]        = 0xE2000 (Memory)
    ========================================================
     Bus, Device, Function = 0, 10, 1
     Vendor ID, Device ID  = 0x17F3, 0x6061
     Base Class, Subclass  = 12, 3 => SERIAL_BUS_CTLR
     Interrupt             = 15
     BaseAddress[0]        = 0xE3000 (Memory)
    ========================================================
     Bus, Device, Function = 0, 11, 0
     Vendor ID, Device ID  = 0x17F3, 0x6060
     Base Class, Subclass  = 12, 3 => SERIAL_BUS_CTLR
     Interrupt             = 5
     BaseAddress[0]        = 0xE0000 (Memory)
    ========================================================
     Bus, Device, Function = 0, 11, 1
     Vendor ID, Device ID  = 0x17F3, 0x6061
     Base Class, Subclass  = 12, 3 => SERIAL_BUS_CTLR
     Interrupt             = 9
     BaseAddress[0]        = 0xE1000 (Memory)
    ========================================================
     Bus, Device, Function = 0, 12, 0
     Vendor ID, Device ID  = 0x17F3, 0x1010
     Base Class, Subclass  = 1, 128 => MASS_STORAGE_CTLR
     Interrupt             = 14
     BaseAddress[0]        = 0x1F0 (I/O)
     BaseAddress[1]        = 0x3F4 (I/O)
     BaseAddress[2]        = 0x170 (I/O)
     BaseAddress[3]        = 0x374 (I/O)
     BaseAddress[4]        = 0xFFF0 (I/O)
    ========================================================
    InitKitlNIC: Searching for PCI Ethernet NIC (dwIrq = 0, dwIoBase = 0, dwDfltType = 1) ...
    InitKitlNIC: Found PCI Ethernet NIC (type = 1, IRQ=9, IOBase=0xDE00).
    +EDBG:NE2000Init
    EDBG:NE2000Init using I/O range at 0x0000DE00
    EDBG:NE2000Init:HWInit failed to read cmd reg
    -EDBG:NE2000Init
    vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
    ---------------------------------------------
     Failed to initialize Ethernet board!
     Please check that the Ethernet card is
     properly installed and configured.
    ---------------------------------------------
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    目前正在尝试解决,但能否给我一些详细的建议?
    2009年8月5日 6:36
  • 换了一个新版本的BSP和eboot.bin,现在目标机和开发工作站已经可以连接起来了,目标机上显示Jumping to 0x0013AC2C,开发工作站能出现下载进度显示界面。
    但是下载结束后,出现如下Find Source的对话框,Please enter the path for driver.cpp.我添加了路径还是不对,在PB的debug中显示:
    4294775938 PID:a3f7b33e TID:a3e28fb6 0x83e1d000: Unknown: DEBUGCHK failed in file E:\gigantitin\private\winceos\COREOS\gwe\mgdi\base\.\driver.cpp at line 1363
    请问应该如何解决?
    2009年8月6日 4:23
  • 你用ICOP的应该是X86架构的,他们的BSP和技术支持还是不错的
    你解决了连接没有问题,出现那个错误是不是因为你没有添加USB所以开始系统启动后才出现那个问题!

    2009年8月6日 6:21
  • 你用ICOP的应该是X86架构的,他们的BSP和技术支持还是不错的
    你解决了连接没有问题,出现那个错误是不是因为你没有添加USB所以开始系统启动后才出现那个问题!


    我添加了USB,还是这样。不知道怎么办?
    2009年8月6日 8:39
  • 4294775938 PID:a3f7b33e TID:a3e28fb6 0x83e1d000: Unknown: DEBUGCHK failed in file E:\gigantitin\private\winceos\COREOS\gwe\mgdi\base\.\driver.cpp at line 1363
    是指你显卡有问题吧?建议LZ
    (1)检查BSP显卡驱动设置是否和目标板BIOS一致。或者
    (2)换用标准显卡VGA Linear (FLAT)试试。
    http://wince.cn/ or http://windowsce.com.cn/
    2009年8月6日 9:55
    版主
  • 4294775938 PID:a3f7b33e TID:a3e28fb6 0x83e1d000: Unknown: DEBUGCHK failed in file E:\gigantitin\private\winceos\COREOS\gwe\mgdi\base\.\driver.cpp at line 1363
    是指你显卡有问题吧?建议LZ
    (1)检查BSP显卡驱动设置是否和目标板BIOS一致。或者
    (2)换用标准显卡VGA Linear (FLAT)试试。
    http://wince.cn/ or http://windowsce.com.cn/

    我换了标准显卡VGA试了以后还是一样,并且rebuild以后还是同样的结果。
    另外“检查BSP显卡驱动设置是否和目标板BIOS一致”怎么做?摸索了很久还是不会如何查看,请赐教。
    2009年8月9日 3:20
  • 如果有KITL,可以调试看看。


    http://wince.cn/ or http://windowsce.com.cn/
    2009年8月12日 11:49
    版主
  • 如果有KITL,可以调试看看。


    http://wince.cn/ or http://windowsce.com.cn/
    我是做应用这一块的,ICOP那一边也不给我提供技术支持,所以我只有自己来找原因。
    现在wince系统启动不起来,调试时会出现一个错误:
    First chance exception in nk.exe(0xC00000C0 Invalid system service) 。

    4294780819 PID:c3f7a072 TID:43db2ebe 0x83dae800: Exception ffffffff Thread=83dae800 Proc=c3f7a072 'device.exe'
    4294780821 PID:c3f7a072 TID:43db2ebe 0x83dae800: AKY=00000009 PC=8025ea7b(NK.EXE+0x0003ea7b) ESP=0840f098 EA=00000000

    请问有什么办法解决吗?
    2009年8月18日 11:47
  • 我现在通过调试发现确实是显示驱动没起来,那我应该怎么办?BSP是从ICOP网上下的。
    2009年8月19日 7:34
  • ICOP的BSP里面可以选择显卡的分辨率,你自己要选择了它的BSP下面还有选项 你必须打开就会看到Z9S的选项
    那个就是显示!

    • 已标记为答案 yannai 2009年8月25日 2:59
    2009年8月19日 10:40
  • ICOP的BSP里面可以选择显卡的分辨率,你自己要选择了它的BSP下面还有选项 你必须打开就会看到Z9S的选项
    那个就是显示!

    非常感谢您的回复。 昨天没看到您的回复之前,我自己也是这样解决的。 但虽然问题已经解决了,我还是有一些疑问: Z9S是什么?和XDI有什么关系? 我查过,但不是很明白,开始我认为只是针对某一种特殊显卡的一个驱动,所以没有添加。我用的是LG的LCD,也是属于Z9S吗? 显示驱动不是最基本的吗?为什么还要用户自己另外添加?我看version D的BSP和version E的BSP中的platform.reg在显示驱动这一块不一样,BSP_version D的platform.reg中有对分辨率的设置。而version E的没找到。 期待您的回复。
    2009年8月20日 6:49
  • 首先 Z9S是ICOP板块选用的一种显示芯片(其是以前的SIS公司分解出来的一个新的芯片公司)
    当然它的驱动也就是Z9S了,至于版本D和版本E中有何没有对分辨率的设置应该去问问
    ICOP做BSP的 可能是为了方便用户设置 所以人家自己加了LCD和普通的显示支持吧!
    • 已标记为答案 yannai 2009年8月25日 2:59
    2009年8月23日 8:55