none
安装Microsoft Visual 2005出现问题 RRS feed

  • 问题

  • 安装Microsoft Visual 2005*64出现设置失败  

    代码为0*80070666

    日志文件为

    [31F0:2378][2018-01-06T20:53:35]i001: Burn v3.7.3813.0, Windows v10.0 (Build 10586: Service Pack 0), path: C:\Users\lizihan\Desktop\vc_redist.x64.exe, cmdline: ''
    [31F0:2378][2018-01-06T20:53:35]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\lizihan\AppData\Local\Temp\dd_vcredist_amd64_20180106205335.log'
    [31F0:2378][2018-01-06T20:53:35]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\lizihan\Desktop\vc_redist.x64.exe'
    [31F0:2378][2018-01-06T20:53:35]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\lizihan\Desktop\'
    [31F0:2378][2018-01-06T20:53:35]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.23026'
    [31F0:2378][2018-01-06T20:53:35]i100: Detect begin, 10 packages
    [31F0:2378][2018-01-06T20:53:35]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.10137.0'
    [31F0:2378][2018-01-06T20:53:35]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
    [31F0:2378][2018-01-06T20:53:35]i102: Detected related bundle: {f1e7e313-06df-4c56-96a9-99fdfd149c51}, type: Upgrade, scope: PerMachine, version: 14.10.25008.0, operation: Downgrade
    [31F0:2378][2018-01-06T20:53:35]i108: Detected compatible package: vcRuntimeMinimum_x64, provider: Microsoft.VS.VC_RuntimeMinimumVSU_amd64,v14, installed: {8D50D8C6-1E3D-3BAB-B2B7-A5399EA1EBD1}, version: 14.10.25008, chained: {0D3E9E15-DE7A-300B-96F1-B4AF12B96488}
    [31F0:2378][2018-01-06T20:53:35]i103: Detected related package: {8D50D8C6-1E3D-3BAB-B2B7-A5399EA1EBD1}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [31F0:2378][2018-01-06T20:53:35]i108: Detected compatible package: vcRuntimeAdditional_x64, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_amd64,v14, installed: {C668F044-4825-330D-8F9F-3CBFC9F2AB89}, version: 14.10.25008, chained: {BC958BD2-5DAC-3862-BB1A-C1BE0790438D}
    [31F0:2378][2018-01-06T20:53:35]i103: Detected related package: {C668F044-4825-330D-8F9F-3CBFC9F2AB89}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i052: Condition '(windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10137.0)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: vcRuntimeMinimum_x64, state: Obsolete, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: vcRuntimeAdditional_x64, state: Obsolete, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows81_x86, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows81_x64, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows8_x86, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows8_x64, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows7_MSU_x86, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: Windows7_MSU_x64, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: WindowsVista_MSU_x86, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i101: Detected package: WindowsVista_MSU_x64, state: Present, cached: None
    [31F0:2378][2018-01-06T20:53:35]i052: Condition 'VersionNT64 >= v6.0 OR (VersionNT64 = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
    [31F0:2378][2018-01-06T20:53:35]i199: Detect complete, result: 0x0
    [31F0:2CA4][2018-01-06T20:53:38]e000: Error 0x80070666: Cannot install a product when a newer version is installed.

    2018年1月6日 13:01

全部回复

  • 你好:

    如果你的电脑上安装了高版本的Visual C++ Redistributable,例如Visual C++ 2017 Redistributable。先在控制面板里卸载掉,运行visual studio 2015的安装包或者直接修复一下已经安装的vs2015,最后在装上高版本的Visual C++  Redistributable。

     


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2018年1月8日 5:35