none
[求助]VS2010安装后出现无法使用帮助的现象 RRS feed

  • 问题

  • 今天安装了VS2010中文旗舰版,前面的过程很顺利,没出现异常。但在安装完成后我选择了在本地使用系统帮助,结果却未能成功,而且至今没法使用帮助。

    当我选择了在本地使用帮助后,系统弹出一个对话框“Help Library 管理器 - Microsoft Help 查看器 1.0”,提示“请为本地内容选择位置”。默认的位置是在“C:\Documents and Settings\All Users\Application Data\Microsoft\HelpLibrary\”,我将其改变到“D:\Program Files\VS2010 Help Library”,点击“确定”后系统报错,提示“未能在指定文件夹中创建本地存储区,请选择其他位置。可以检查事件日志以了解详细信息”。

    我以为自己选定了一个系统不接受的位置,于是取消了操作,重新启动了“管理帮助设置”。这时对话框里默认的库位置恢复到了“C:\Documents and Settings\All Users\Application Data\Microsoft\HelpLibrary\”。点击“确定”,结果还是一样:未能在指定文件夹中创建本地存储区。

    我尝试着更换了好几个位置,对应的硬盘分区余量少则6G,多的有10多G,但结果一样。我又试着给相应的文件夹赋予全部权限,结果仍没变化。又尝试重启计算机再试,还是没用。也尝试过关掉所有安全程序,还是不行。

    不过,VS2010倒是成功安装了,也可以正常使用,就是无法启用帮助。

    我的计算机是DELL Inspiron 6000,操作系统是Windows XP 专业版,有SP3。

    请大家帮帮忙,谢谢。

    2010年6月5日 8:10

答案

  • 感谢刘天逸的提示,我终于摸索着把问题给解决了。

    本地库位置还是没法设置。我从另一台机器上复制了库位置的全部文件和文件夹,然后修改HelpLibManager.exe.config,把FirstTimeRun的值设置为False,再进入“管理帮助设置”就正常了。现已经成功的安装了光盘上的全部库文件,使用正常。

    可惜这个办法不能更改本地库文件位置。

    • 已标记为答案 muyi66 2010年6月6日 13:37
    2010年6月6日 13:33

全部回复

  • 在“帮助”的“管理帮助设置”里选择“选择联机帮助或本地帮助”-选“我要使用本地帮助”

    然后在“库位置”选择一个非系统盘的盘符,因为只要在把MSDN安装在杀毒软件扫描就很慢,

    在vs2010目录下,进入ProductDocumentation选择HelpContentSetup,选择安装即可!

     

    2010年6月6日 10:31
  • 谢谢楼上。可是我还是没法装。

    因为本地内容的库位置无法确定,我现在根本没法进入“管理帮助”界面,也就没法更改设置了。

    很奇怪,刚才在一台台式机上安装VS2010就一次成功,啥问题也没有。看来我是遇到幽灵了。

    2010年6月6日 12:27
  • 感谢刘天逸的提示,我终于摸索着把问题给解决了。

    本地库位置还是没法设置。我从另一台机器上复制了库位置的全部文件和文件夹,然后修改HelpLibManager.exe.config,把FirstTimeRun的值设置为False,再进入“管理帮助设置”就正常了。现已经成功的安装了光盘上的全部库文件,使用正常。

    可惜这个办法不能更改本地库文件位置。

    • 已标记为答案 muyi66 2010年6月6日 13:37
    2010年6月6日 13:33
  • 您好,我也撞上了同样的问题,郁闷,解决了请告诉我:

    qq:99016591谢谢

    2010年6月16日 1:07
  • 我也遇到这问题了,解决不了。只能用联机帮助。如果你解决了告诉我一声。QQ : 46380623
    2010年7月14日 6:07
  • 同问题,我的帮助管理点了没反应,帮助文档打开提示“没有ms-xhelp注册的协议”,郁闷,大侠帮忙指点一下,qq379712401
    2010年7月16日 6:11
  • 我这里也出现了你这种情况,我是因为安装了Windows Phone 7 Develop Tools,因为他也给提供了英文帮助管理器,然后和vs的中文管理器冲突了。所以我先安装英文的再安装中文的就没有问题了,所以你应该看看你是否重复安装过多个管理器什么的(都是自动安装的,好像没法选择的),然后清理干净了,在安装就可以了,保证中文是最后的应该比较好吧!!我是新手不对的请无视 .
    2011年2月1日 3:49
  • 感謝樓主的提示,我的也是同樣的錯誤。前兩次裝都正常,這次遇到類似問題。按提示操作,應該是設置為“True”。之後可以選擇mash後綴文件進進行安裝。感謝此貼前輩提示

    • 已建议为答案 dragon_son 2011年8月4日 18:31
    2011年8月4日 18:31