none
关于wince spi驱动的一个小问题 RRS feed

  • 问题

  • 我在写一个wince的spi驱动来读取ad的数值,
    使用查询方式读取2440 spi总线上的数据
    void write_spi(unsigned char txdata)
    {
       // Check the status of Transfer Ready flag(READY=1) ,and then write data to SPTDAT0
       v_pSPIPregs->SPTDAT0 = txdata; // Write Potentiometer value
       RETAILMSG(TRUE, (TEXT("INFO:write_spi data (%ld).\r\n"), v_pSPIPregs->SPTDAT0));
       RETAILMSG(TRUE, (TEXT("INFO:before while loop v_pSPIPregs->SPSTA0 is (%ld).\r\n"), v_pSPIPregs->SPSTA0));

       // Wait to complete write data
       while(!(v_pSPIPregs->SPSTA0 & 0x01== 0x01 ));     //SPSTA0的READY是否置位
      RETAILMSG(1,(TEXT("write_spi delay is over\n")));
    }
    每次调试到上述代码中的while(!(v_pSPIPregs->SPSTA0 & 0x01== 0x01 ));  时,下位机总是死机
    这是为什么呢 是不是wince的消息队列机制 不能让程序进入死循环 在裸机上这么写的时候调试通过 但是驱动中这么写就死机 麻烦谁给说说为什么啊 另外 我在while循环中添加打印语句时 会不停地打印该语句 就是无法跳出来 为什么啊。。

    2011年3月24日 4:43

答案

  • 我想问一下,你的SPI设备中的SPSTA0寄存器是不是auto reset的?就是那种读了之后所有bit都设成0的。

    如果是这样的话,你的while loop肯定是死循环。因为你所关心的bit在

    RETAILMSG(TRUE, (TEXT("INFO:before while loop v_pSPIPregs->SPSTA0 is (%ld).\r\n"), v_pSPIPregs->SPSTA0));

    这个时候已经被读掉了,所以,之后之后就没有机会读到1了。

     

     

    2011年3月27日 10:07
    版主

全部回复

  • Hi Rain_ning,

    估计是SPI寄存器映射到内存时有问题,建议你检查一下

    Regards,

    Avalanc

    2011年3月25日 6:03
  • 我想问一下,你的SPI设备中的SPSTA0寄存器是不是auto reset的?就是那种读了之后所有bit都设成0的。

    如果是这样的话,你的while loop肯定是死循环。因为你所关心的bit在

    RETAILMSG(TRUE, (TEXT("INFO:before while loop v_pSPIPregs->SPSTA0 is (%ld).\r\n"), v_pSPIPregs->SPSTA0));

    这个时候已经被读掉了,所以,之后之后就没有机会读到1了。

     

     

    2011年3月27日 10:07
    版主