none
关于wlk 1.5 Plug and Play Driver Test 的问题 RRS feed

  • 问题

  • 相關鏈接:
    http://social.msdn.microsoft.com/Forums/zh-TW/1295/thread/f769d664-60e2-4502-affc-51b8a80a350b
    http://social.msdn.microsoft.com/Forums/zh-TW/1295/thread/67101dd3-3037-49af-a5e2-1a4f12db8217

    我最近在測試Win7 x64下的虛擬網卡的時候,也遇到類似的問題。
    表現為Plug and Play Driver Test 通過,但Pnpdtest with concurrent IO in parallel with DevPathExer 失敗。
    task log中提示Invalid driver service name 。

    我后來看了一下WLK的測試過程,發現Plug and Play Driver Test 通過后,虛擬網卡被設置為“禁用”狀態。這樣后面的測試自然是無法通過的。
    如果在Plug and Play Driver Test后,手動啟用虛擬網卡,則整個測試沒有問題,最后用cpk log viewer看也都是綠色的。

    網卡被設置為禁用的具體位置,應該是在通過pnptest測試Cancelstop,remove等IRP后。因為機器上沒有studio,所以無法說出具體的測試項名稱。
    反正就是Plug and Play Driver Test里面那個不斷的啟用禁用設備,測試各種移除IRP的測試之后。注意是之后,這個子測試項本身通過后,虛擬網卡還是處于啟用狀態的。但整個Plug and Play Driver Test完成,就變成禁用了。

    所以想問幾個問題:
    1、wlk 1.3發布了一個qfe用于解決類似的問題,為什么1.4/1.5再次出現?
    2、我手動啟用虛擬網卡,最后完成整個測試拿到的cpk,是否可以提交ms并通過。注意cpk viewer里面顯示全部pass。
    3、如果我還是想通過wlk來自動測試并通過,應該如何處理?比如我是否可以調整測試項順序,讓Plug and Play Driver Test最后進行測試。

    多謝各位!
    2010年1月11日 3:24

答案

  • 1、wlk 1.3發布了一個qfe用于解決類似的問題,為什么1.4/1.5再次出現?
    [A] 这个问题我不是很清楚了。至于1.4 QFE有解,1.5仍出现问题。这个需要再调查。


    2、我手動啟用虛擬網卡,最后完成整個測試拿到的cpk,是否可以提交ms并通過。注意cpk viewer里面顯示全部pass。
    [A] 可以


    3、如果我還是想通過wlk來自動測試并通過,應該如何處理?比如我是否可以調整測試項順序,讓Plug and Play Driver Test最后進行測試。
    [A] 先测Pnpdtest with concurrent IO in parallel with DevPathExer,等1,2 分钟后再安排Plug and Play Driver Test等其它测试。


    http://www.microsoft.com/china/whdc http://ctcwhql.spaces.live.com/blog/
    • 已标记为答案 jxxy1234 2010年1月11日 9:05
    2010年1月11日 5:48
    版主

全部回复

  • 1、wlk 1.3發布了一個qfe用于解決類似的問題,為什么1.4/1.5再次出現?
    [A] 这个问题我不是很清楚了。至于1.4 QFE有解,1.5仍出现问题。这个需要再调查。


    2、我手動啟用虛擬網卡,最后完成整個測試拿到的cpk,是否可以提交ms并通過。注意cpk viewer里面顯示全部pass。
    [A] 可以


    3、如果我還是想通過wlk來自動測試并通過,應該如何處理?比如我是否可以調整測試項順序,讓Plug and Play Driver Test最后進行測試。
    [A] 先测Pnpdtest with concurrent IO in parallel with DevPathExer,等1,2 分钟后再安排Plug and Play Driver Test等其它测试。


    http://www.microsoft.com/china/whdc http://ctcwhql.spaces.live.com/blog/
    • 已标记为答案 jxxy1234 2010年1月11日 9:05
    2010年1月11日 5:48
    版主
  • 1、wlk 1.3發布了一個qfe用于解決類似的問題,為什么1.4/1.5再次出現?
    [A] 这个问题我不是很清楚了。至于1.4 QFE有解,1.5仍出现问题。这个需要再调查。


    2、我手動啟用虛擬網卡,最后完成整個測試拿到的cpk,是否可以提交ms并通過。注意cpk viewer里面顯示全部pass。
    [A] 可以


    3、如果我還是想通過wlk來自動測試并通過,應該如何處理?比如我是否可以調整測試項順序,讓Plug and Play Driver Test最后進行測試。
    [A] 先测Pnpdtest with concurrent IO in parallel with DevPathExer,等1,2 分钟后再安排Plug and Play Driver Test等其它测试。


    http://www.microsoft.com/china/whdc http://ctcwhql.spaces.live.com/blog/

    明白了。我就直接enable网卡吧。
    多谢!!!
    2010年1月11日 9:05