none
关于net3.5和net3.0版本的问题 RRS feed

  • 问题

  • 我的服务器需要装64位的net3.0和SP1版本的组件,但很多时候需要在线下载,即很慢,又不方便。
    网上有net3.5和3.5SP1的版本,如果我直接安装net3.5和3.5版本的SP1,是否可以向下兼容呢?
    也就是说,是不是以后所有需要net2.0、3.0的组件时,我都可以用Net3.5来代替呢?

    谢谢


    小驴儿
    2010年4月12日 3:21

答案

  • 可以代替

    .NET Framework 3.5包含了很多与.NET Framework 2.0与.NET Framework 3.0兼容的新功能。同时还包括了针对.NET Framework 2.0与.NET Framework 3.0的服务。

    .NET Framework 3.5在3.0版本的基础上增量的添加不少新功能,

    例如Windows Workflow Foundation(WF),

    Windows Communication Foundation(WCF),

    Windows Presentation Foundation(WPF)和Windows CardSpace。此外,.NET Framework 3.5包括了多个领域中的新功能,


    努力+方法=成功
    • 已标记为答案 驴熊 2010年4月13日 15:16
    2010年4月12日 3:35
  • 你好!

    正如开心所说的,“.NET Framework 3.5包含了很多与.NET Framework 2.0与.NET Framework 3.0兼容的新功能”。其原因是,.NET Framework 3.5的安装过程中,包含了对.NET 2.0和3.0的安装,所以你装了.NET 3.5的同时,也会安装.NET 2.0和3.0。

    希望对你有所帮助。
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • 已标记为答案 驴熊 2010年4月13日 15:18
    2010年4月13日 5:53

全部回复

  • 可以代替

    .NET Framework 3.5包含了很多与.NET Framework 2.0与.NET Framework 3.0兼容的新功能。同时还包括了针对.NET Framework 2.0与.NET Framework 3.0的服务。

    .NET Framework 3.5在3.0版本的基础上增量的添加不少新功能,

    例如Windows Workflow Foundation(WF),

    Windows Communication Foundation(WCF),

    Windows Presentation Foundation(WPF)和Windows CardSpace。此外,.NET Framework 3.5包括了多个领域中的新功能,


    努力+方法=成功
    • 已标记为答案 驴熊 2010年4月13日 15:16
    2010年4月12日 3:35
  • 你好!

    正如开心所说的,“.NET Framework 3.5包含了很多与.NET Framework 2.0与.NET Framework 3.0兼容的新功能”。其原因是,.NET Framework 3.5的安装过程中,包含了对.NET 2.0和3.0的安装,所以你装了.NET 3.5的同时,也会安装.NET 2.0和3.0。

    希望对你有所帮助。
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • 已标记为答案 驴熊 2010年4月13日 15:18
    2010年4月13日 5:53