none
win8的Metro下的Silverlight RRS feed

  • 常规讨论

  • 微软宣布Metro下的IE10将不支持插件, 那么,会支持sl5吗?

    假如不支持,那么,sl5是不是就到头了?!因为这意味着从手机到平板,在浏览器里无法运行sl

    个人猜测是IE10可能会不支持,理由是sl5开发工具里的缺省控件尺寸不适合于触摸。

    。。。。

     

    2012年2月3日 5:53

全部回复

  • 有没下一个版本,这个无法知道。但是,SL 5的功能我觉得已经很强大了,足够让你坐很多事了。

    并且Win8下 ,不是没有SL 5了。而是Win8 下你全用的是Xaml + WinRT类库。

    你掌握的Silverlight 知识并没有废掉,而是给你提供了更广的API的支持。


    努力!完成了js解析器,还差一个svg插件,一个绘图程序,做好自己,呵呵~!
    2012年2月6日 2:21
    版主
  • 我也觉得SL 5的功能已经很强大,即使不升级也已够用。而且当前我也找不到比sl更好体验和功能的东西, html5为时尚早。

    问题是未来若不能在Metro下的IE10中运行的话,那么,我们必须为应用程序在windows上准备两个版本:一个供win7和xp在ie中用;一个供Metro和arm平板用。做过wp7的应该知道:即使是大家都叫silverlight,但其实变化很大,相信sl向Xaml + WinRT移植工作量不小。

    Metro抛弃sl5, 让我觉得是判了它死刑。

    2012年2月7日 5:11