none
VS2012禁用intellisense后,代码更改并且保存后,CPU就占用高(稳定在25%左右),请问各位有没解决方法! RRS feed

  • 问题

  • VS2012禁用intellisense后

    代码更改并且保存后,CPU就占用高(稳定在25%左右,大概满一个线程)

    如果没更改,而保存或者运行都不会发生此问题

    测试过不管有没VisualAssistX都会这样

    请问各位有没解决方法!

    2014年10月27日 2:11

答案

  • 确实是这样的,我重新搭建了一个VS2012的windows 7机器,也有这个问题,安装VS2012 update 4也是存在这个问题。而且一个问题是,如果你打开Text Edit 窗口,CPU又变成很小了,点击OK,就有这个问题了。但是VS2013没有这个问题了,所以,最好还是用VS2013!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月13日 10:41
    版主

全部回复

  • 您好,

    请问你是在哪里看到的CPU,任务管理器吗?你可不可以给我一张截图?

    你的意思是,关闭“intellisense”后,整个VS就占 25%的CPU?你是如何禁用 “intellisense”的,在text Editor吗?不禁用之前的CPU是怎么样的?

    也许你可以重启机器,或者在安全模式下运行VS检查一下:

    http://msdn.microsoft.com/en-us/library/ms241278.aspx

    如果确定是VS IDE的问题,你有没有在VS2013试过同样的操作,如果可能你可以告诉我详细的步骤,我会在不同的环境下检验。还有你所谓代码更改保存,是对同一个项目?如果不同项目有变化吗?


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年10月27日 9:57
    版主
  • 您好,

    感谢您的回复,很抱歉这么多天了才上来看了下帖子。

    根据后来的尝试,工具->文本编辑器->C/C++ ->高级-> IntelliSense中的“禁用自动更新”选项,才是产生问题的原因。

    我尝试禁用了 IntelliSense中的其它功能,都没产生这个问题。之前禁用 “intellisense”就产生该问题是因为它会将 “intellisense”全部功能禁用。

    唯独将 IntelliSense中的“禁用自动更新”选项改成“ture”,就会出现代码确实有更改过的前提下,使用“保存”功能或者“运行”之类的功能(这些功能会自动执行“保存”功能)后,CPU上升上25%左右并持续稳定的情况。

    CPU占用率以及内存使用,是在任务管理器中观察到。

    不禁用之前,会不时出现占用较高内存的多个vcpkgsvr.exe进程,目前出现过1-3个的可能,大部分是出现2个的情况。

    尝试过重启机器。安全模式没尝试过,VS2013没尝试过。

    所谓代码更改保存,是指项目中的代码在有更改变化的前提下,IDE执行保存操作。可以理解为“有效的保存”。

    操作系统是 windows7 32bit,CPU是I5 480M。

    希望您能得到参考。

    2014年11月5日 6:53
  • 你的意思是如果把“禁用自动更新”选项改成“ture”,就会产生CPU上升的问题对吧?默认的应该是“false”。

    我有遇到这种解释:

    Disable Auto Updating:

    IntelliSense updating is delayed until an actual request for IntelliSense is made. This delay can result in a longer execution time of the first IntelliSense operation on a file, but it may be helpful to set this option on very slow or resource-constrained machines. If you choose this option, you also implicitly choose the “Disable Error Reporting” and “Disable Squiggles” options.

    好像这个设置确实会或多或少的影响性能!也许你可以改变另外两个选项试试!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月7日 9:01
    版主
  • 不禁用IntelliSense和自动更新,另外“Disable Error Reporting” and “Disable Squiggles”这个禁用的情况下,依旧会不时出现占用较高内存的多个vcpkgsvr.exe进程

    如果把“禁用自动更新”选项改成“ture”,项目中的代码在有更改变化的前提下,IDE执行保存操作后,devenv.exe占用CPU从0%-2%马上上升到25%左右并保持

    安装的是VS2012_ULT_chs.iso

    2014年11月10日 3:29
  • >>如果把“禁用自动更新”选项改成“ture”,项目中的代码在有更改变化的前提下,IDE执行保存操作后,devenv.exe占用CPU从0%-2%马上上升到25%左右并保持。

    所以,如果只是把“禁用自动更新”选项改成“ture”,但是不改变项目code的情况下,CPU还是正常的,对吧?

    如果这样的话,我觉得那就要考虑你真正如何更改代码的了。也许,它真的影响/触发了IntelliSense的自动更新功能或者别的。

    安全模式下运行VS,要不你试试?

    http://msdn.microsoft.com/en-us/library/ms241278.aspx


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月10日 7:54
    版主
  • 对的,code没变化的话,点保存不会出现问题

    比如输入个 a 或者输入个 int a;或者加个分号 ; 之后点保存都会出现这个问题

    试了下安全模式,发现问题依在

    devenv.exe占用CPU在22%-27%浮动

    2014年11月10日 11:03
  • 这个问题确实不好重现。你是所有的程序都有这个问题,还是只是特定的程序存在这个问题?

    我用VS2013 试了一下,没有问题。你要不告诉我你具体的VS2012的版本吧!我试着在我这边重现一下。另外,你最好安装VS2012 update 4.

    如果只是特定的程序有这个问题,那可能要考虑程序的性能了。


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月11日 6:08
    版主
  • 所有项目,一个空项目随便输入个字符,然后点保存,也会发生

    并且发生问题后的此时如果在选项里把“禁用自动更新”改回 "false",CPU又会降回0-2%

    不太了解这个版本,版本号如下:

    Microsoft Visual Studio Ultimate 2012
    版本 11.0.50727.1 RTMREL

    感谢版主

    另外,发帖之前有百度到有人做过类似的调查,链接:http://bbs.pediy.com/showthread.php?t=163611

    如果实在难以解决,我可以考虑更新Update 4试试(如果目前不是Update 4)或者更换VS2013

    2014年11月12日 5:49
  • 确实是这样的,我重新搭建了一个VS2012的windows 7机器,也有这个问题,安装VS2012 update 4也是存在这个问题。而且一个问题是,如果你打开Text Edit 窗口,CPU又变成很小了,点击OK,就有这个问题了。但是VS2013没有这个问题了,所以,最好还是用VS2013!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月13日 10:41
    版主
  • 好的

    非常感谢版主

    我换VS2013去

    2014年11月14日 4:02
  • 不用客气!:)


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2014年11月14日 5:20
    版主