none
Select CD-ROM Boot Type when installing Server 2008 64-bit with Hyper-V

    Question

  • Hello. I am not sure if this is the correct place to post this, so I am sorry if I didn't post in the correct location. I would like to try Hyper-V, so I decided to install Server 2008 64-bit with Hyper-V on my Macbook Pro (I know this is not supported by boot camp, but I also have used other unsupported operating systems). But, booting off of the CD yields this:

           1.
           2.
    Select CD-ROM Boot Type :

    I am wondering if anyone else has experienced this and can tell me what to do (note that the Macbook Pro seems to have a minor issue with keyboard entry when booting into Bios emulation). The only Google result is this Japanese web page: http://toshi3.cocolog-nifty.com/blog/2007/09/index.html. Also, 64-bit Vista seems to boot and install correctly.

    I apologize for my possible ignorance,
    Rmsuperstar99
    Wednesday, January 23, 2008 10:13 PM

Answers

  • This is nothing that Windows Server 2008 is doing - this might be an interaction with BootCamp. By default, if the bootloader notices that an OS already exists, it will not boot into the installer, and will give the "Press Any Key to boot from CD/DVD" prompt for 5 seconds before finishing.

    Saturday, January 26, 2008 12:10 AM
    Owner

All replies

  • Just press "1" and enter - it should then proceed to boot.

     

    Cheers,

    Ben

    Wednesday, January 23, 2008 11:51 PM
    Owner
  • Press "1" and enter is not a happy solution because after the reboot the installation continue. It is stupid to stop the installation process in the middle to ask the user to press "1" and enter.

     

    Friday, January 25, 2008 12:22 PM
  • This is nothing that Windows Server 2008 is doing - this might be an interaction with BootCamp. By default, if the bootloader notices that an OS already exists, it will not boot into the installer, and will give the "Press Any Key to boot from CD/DVD" prompt for 5 seconds before finishing.

    Saturday, January 26, 2008 12:10 AM
    Owner
  • Thanks. Smile

    I had assumed that, so then the problem of it not taking key entry is with my Macbook Pro. Oddly, I still got this menu after formating all the partitions with disk utility, and even after deleting all the partitions with a Server 2003 disc (Press any key to boot from cd in Server 2003 did not show up when this happened).

    -Rmsuperstar99
    Tuesday, January 29, 2008 2:05 AM
  • Not so sure if this is a boot camp "issue". I just installed successfully 64-bit Vista from a bootable DVD (MSDN ISO) w/o any questions from the system. Trying the same with a Windows Server 2008 DVD (MSDN ISO) gives the described boot options but the systems seem to hang or at least does not accept any keyboard input anymore. Question is what is the difference between a 64-bit Vista boot DVD and a Windows Server 2008 boot DVD.

    Tuesday, January 29, 2008 2:13 AM
  • Any updates?

     

    Tuesday, February 05, 2008 5:56 PM
  • Just tried this again with an ISO of the RTM 2008 x64 as well.  Same issue, and for what it's worth, the same happens on a brand-new 17" MBP 2.4ghz, a previous generation 15" Core Duo (not C2D) MBP, and my 20" Core Duo iMac.  From other posts on apple boards, the general consensus is that 2008 has problems identifying the keyboard type on the Macs, and therefore can't continue the boot.  I've also tried all machines above with external windows-genuine USB as well as PS2 (via USB adapter) keyboards, no joy.  Some things I hope to be trying next: remove MBP HD, install in Windows notebook, attempt to install 2008 from that platform then transplant drive back to MBP and cross fingers... also, I may try a bootcamp 2003 install and attempt an upgrade vs. clean install of 2008.
    Monday, February 11, 2008 1:49 PM
  • Problem solved!

     

    Just copy all files from DVD or ISO image to temporary folder and then use oscdimg.exe from
    Windows Automated Installation Kit (AIK) to create new .iso file. Then burn new install dvd.

     

    Monday, February 11, 2008 8:11 PM
  •  

    Same problem here, but on Intel D975XBX2 mobo and clean RAID10 boot array.

    Every time machine reboots during OS install I have to press 1.

     

    What is the purpose of this options?

    Tuesday, March 04, 2008 2:22 AM
  •  

    What oscdimg command options did you use?
    Tuesday, March 25, 2008 2:12 PM
  • Here are the command options that I used to create ISO image.

     

    oscdimg.exe -n -m -bC:\WS2008_DVD\boot\etfsboot.com C:\WS2008_DVD C:\temp\WS2008.iso

     

    There is a nice blog post about this problem from Jowie. You can find it here:

    "Select CD-ROM Boot Type :" prompt while trying to boot from Vista x64 DVD burnt from .iso file

    Tuesday, March 25, 2008 3:38 PM
  • Sunday, April 06, 2008 6:35 AM
  • 1.  In the settings of your DVD-burning software,  make sure  'Don't add ';1' version number to files'  is checked.  This ISO 9660 file record name format is the cause of our impediment.     http://support.microsoft.com/kb/931708

     

    2.  Create a bootable disk of the Server 2008 files.

     

    That was all I did to install Windows Server 2008 Enterprise 64-bit on my new and gorgeous iMac with Boot Camp.  I didn't need CDimage.exe or OSCDimg.exe or a new .iso or anything else.

     

     

    ---------------------------------------------------  HELP!  ---------------------------------------------------

     

     

    My iSight is missing the driver for Windows Server 2008 Enterprise 64-bit .  Is it working for you?  Where did you get the driver?  Boot Camp (latest edition as of today, April 13) didn't install the driver when I installed Server 2008 Enterprise 32-bit either.  Thank you.

    Monday, April 14, 2008 4:31 AM
  • I cannot find oscdimg.exe in AIK. Where is is located?
    Thursday, July 03, 2008 7:25 AM
  • If you have this issue loading 64 bit versions burned from Iso on to a Windows machine I assume you are doing this and you have the machine either hooked to a KVM or you have usb keyboard and mouse? Hook a standard keyboard up to your machine, boot from the dvd. Hit 1.

    Sunday, August 10, 2008 3:16 PM
  • I had this problem, but it wasn't on a mac, it was on a standard Pc, with an intel desk board dx38bt


    It would install XP without this "Select CD-ROM Boot Type" prompt.  But not windows 2008 64 bit with hyper v


    I tried Nero and imgburn with the sugguested options didn't seem to make a difference. ( also asked a collegue would used a different iso and burner)

    I also reset the BIOS to default settings ( even though one of the PC's is brand new)

    None of this made any difference.

    As for the kvm/ usb Yes i am using both, but i can't use PS2 the PC has no PS2 ports


    In the end i followed these instructions (i didn't change and burning options)

    http://sergiomcfly.blogspot.com/2008/04/select-cd-rom-boot-type-when-installing.html

    and it installed successfully

     

    • Proposed as answer by helenp1983 Sunday, June 14, 2009 10:49 AM
    Friday, May 08, 2009 3:27 PM
  • Can someone elaborate on this?

    I've downloaded the Windows AIK, but there a 2 problems:
    1) When I try to intiate the .exe, I'm told it is a Windows-only file and cannot be run via MacOS
    2) I'm assuming "oscdimg.exe" is some kind of command prompt-
    can someone explain STEP-BY-STEP how to initiate this so ulimately
    a usable Window7 install disc can be created ??

    thanks so much!
    NpF
    Tuesday, September 29, 2009 1:26 AM
  • i used http://sergiomcfly.blogspot.com/2008/04/select-cd-rom-boot-type-when-installing.html to install my win7 x64 the thing is you need to have a windows computer to do the following guide. you cant do it on a mac unless you have like windows XP or Vista already installed.

    But that guide does work and if you have a disk already i would do the following

    oscdimg.exe -n -m -bd:\boot\etfsboot.com d:\ c:\windows7x64.iso

    where d is your dvd-rom drive.

    You might beable to do it threw Parallels or something but im not completely sure, i used my GFs laptop
    Tuesday, October 27, 2009 6:56 PM
  • I also used http://sergiomcfly.blogspot.com/2008/04/select-cd-rom-boot-type-when-installing.html and just followed the simple steps one by one
    and hey here i am with windows 7 x64 on my Apple Macbook

    Thanks everyone..
    Thursday, October 29, 2009 7:23 AM
  • 1) You normaly cant run Windows exe files on a Mac - may be try it with Wine (which helps you running windows exe files on a mac) - but i Think that will not work as expected. Better ask a friend with a running Windows machine to help you.

    2) On a Window Machine press the "Start" Button, and enter "cmd" in the field "Run" - and press enter. A black box will open (Yes its kind of DOS style, because it is something like that!) - In that window a command prompt will blink. Type "cd C:\server2008" and hit enter key. then follow the instructions on that website the guy above posted.

     

    Cheers,

    Sendel

    Monday, June 06, 2011 5:39 PM