none
SQL 2008 R2 SP3 ugrade failure

    Question

  • SQL 2008 R2 SP3 upgrade failure Current Version: Microsoft SQL Server 2008 R2 (SP2) - 10.50.4305.0 (X64) Apr 3 2014 17:55:58 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 6.1 <x64>(Build 7601: Service Pack 1) (Hypervisor) Exit code : 325526488 Exit acility code: 871 Exit error code: 9176

    Could not find any resources for the specified culture or the neutral culture. Make sure "Errors.resources" was correctly embedded or linked into assembly "Microsoft.SqlServer.Discovery" at compile time, or that all the satellite assemblies required are loadable and fully signed.

    

    </x64> Please advise.
    • Edited by Trilok Adhi Tuesday, December 09, 2014 9:07 PM
    Tuesday, December 09, 2014 9:03 PM

Answers

All replies

  • Hi Trilok,

    According to your description, you encounter the error when installing SQL Server 2008 R2 SP3. For further analysis, please help to post the detail.txt which locates in C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log \*date*_*time*\.

    >>Could not find any resources for the specified culture or the neutral culture. Make sure "Errors.resources" was correctly embedded or linked into assembly "Microsoft.SqlServer.Discovery" at compile time, or that all the satellite assemblies required are loadable and fully signed.

    Regarding to the error message, based on my research, it could be caused by that some msi/msp files are missing or corrupted in windows installer cache (C:\Windows\Installer\). Please refer to this KB article to re-cache the msi/msp files if they are missing.

    There are some blogs about the same issue for your reference.

    Issues with Service Pack Install
    http://woodler-public.sharepoint.com/Blog/Post/5/Issues-with-Service-Pack-Install

    SQL Server patch fails with "Could not find any resources appropriate for the specified culture or the neutral culture"
    http://blogs.msdn.com/b/sqljourney/archive/2013/06/13/sql-server-patch-fails-with-quot-could-not-find-any-resources-appropriate-for-the-specified-culture-or-the-neutral-culture-quot.aspx

    Thanks,
    Lydia Zhang

    If you have any feedback on our support, please click here.




    Wednesday, December 10, 2014 2:39 AM
    Moderator
  • How do I send you file detail.txt?

    This page doe not allow me to attaché a file..

    Please let me know your email to do so.

    Thanks!

    Wednesday, December 10, 2014 4:05 PM
  • How do I send you file detail.txt?

    This page doe not allow me to attaché a file..

    Please let me know your email to do so.

    Thanks!

    You can post the content on Skydrive,dropbox or some shared location and then post link here so that we can access

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My Technet Wiki Article

    MVP

    Wednesday, December 10, 2014 4:16 PM
    Moderator
  • Hi, here is the link https://onedrive.live.com/redir?resid=5397DD9063D9B744%21106 Thanks!
    Wednesday, December 10, 2014 5:52 PM
  • Hello,

    SQL Server setup is trying to find the SQLSysClrTypes_Cpu64 MSI package on the C:\Windows\Installer\257f1f.msi path. I found the following line on the file you submitted:


    Package SQLSysClrTypes_Cpu64: - The path of cached MSI package is: C:\Windows\Installer\257f1f.msi


    Try copying the MSI from a SQL Server 2008 R2 RTM media and name it 257f1f.msi or use the FindSQLInstalls.vbs script on the following article to copy the file for you. Put the SQL Server 2008 R2 RTM media on the same place where it was when you installed the instance before running the script.

    http://support.microsoft.com/kb/969052

    Hope this helps.


    Regards,


    Alberto Morillo
    SQLCoffee.com




    Wednesday, December 10, 2014 7:05 PM
    Moderator
  • Hi,

    Tried copying the MSI from a SQL Server 2008 R2 RTM media and name it 257f1f.msi it did not help.

    Here is the link to file created using FindSQLInstalls.vbs script https://onedrive.live.com/redir?resid=5397DD9063D9B744%21107

    Tried copying msi and msp files suggested in the file created and sp3 install again produced the same original error. Please advise.

    Thursday, December 11, 2014 3:21 PM
  • Hi Trilok,

    Please open the installer cache (C:\Windows\Installer) and install the 257f1f.msi manually. If it succeeds, it should bypass the error this time when running the patch setup again. However, if the msi setup fails, please post the error message for analysis.


    Thanks,
    Lydia Zhang


    Tuesday, December 16, 2014 9:21 AM
    Moderator