none
Windows 2012 and Hyper V stuck at stopping why

    Question

  • A customer asked me if it was possible to virtualize Windows Home Server 2011 on Windows Server 2012

    So I setup a test system running Windows 2012 Standard

    Setup a virtual

    every time the virtual reboots to install something, it gets stuck on stopping

    the only way around it is to end task the service, and reboot 2012

    Tuesday, September 11, 2012 3:28 AM

All replies

  • I'm having the exact same problem. It was for a while then I started noticing ever time I'd try to reboot or shutdown my VM's it will say Stopping for state and just stuck there until you reboot the host server. When you select that VM in the manager there's no options shown for shutdown or power off. Have you had any luck fixing this?
    Saturday, September 29, 2012 6:22 PM
  • Have the same issue. Seems to be related to the vSwitches. If you disconnect the VM from the switch it will shutdown just fine. Reattach it to the switch and it will get stuck on stopping again.

    I've tried recreating the switch, but that doesn't seem to make a difference. Even if you recreate it with a different name the problem persists.

    Did you guys manage to find a solution yet?


    Casper Pieterse, Principle Consultant - UC, Dimension Data North America, Microsoft Certified Master: Exchange 2007 / 2010

    Thursday, October 04, 2012 5:43 PM
  • Same here. The only way I seemed to find a partial fix is by doing an export of the machine to a different server, then do a "live migration" back to its original server and that seemed to work in some case. I am also wondering it the issue is not related to the new Windows Backup feature that can backup virtual machines separately.

    Benji.


    Benjilafouine

    Sunday, October 21, 2012 4:18 PM
  • I was able to confirm this as a NIC driver issue in the host. Using a different interface card resolved my issue.

    Casper Pieterse, Principle Consultant - UC, Dimension Data North America, Microsoft Certified Master: Exchange 2007 / 2010

    Monday, October 22, 2012 11:02 AM
  • Can you people out there try to delete your virtual network adapters in the VMs and replace them with the "legacy network adapters"? Please report your findings here.

    Thanks.


    Benjilafouine

    Wednesday, October 24, 2012 7:14 AM
  • I have tried switching to a legacy network adapter in both at Windows 2012 VM and Ubuntu VM. The time to shut down the VM still is taking upwards of 10 minutes to complete. Any other ideas?
    Monday, October 29, 2012 8:08 PM
  • Actually, yes, I have another idea (I have been working with Microsoft on this issue). Recreate a new virtual switch with a regular network adapter and uncheck option "Allow management operating system to share this network adapter". It seemed to fix the issue completely even if this is only a workaround.

    However, be aware when unchecking the option: your "virtual network card" will disappear from Windows 2012. If you had a fixed IP address for this card it will still remain in use through the registry (a bit complicated to manage but it works).

    I hope MS can provide me with more details on what seems to be a bug.

    Benoit


    Benjilafouine

    • Proposed as answer by hecgomrec Wednesday, June 14, 2017 8:06 PM
    Thursday, November 01, 2012 7:23 PM
  • I had the same issue, so I followed the lead from the above post and added a new network adapter to the system for administration and isolated the VM's. Machines now have no issue shutting down. This issue only arose after setting up remote access with VPN. I suspect that is the combination which caused the issue. I suspect that disabling remote access may have solved the problem, but did not go down that road.

    Wayne

    • Proposed as answer by ZeroHour Thursday, April 04, 2013 7:50 AM
    Monday, February 18, 2013 3:30 AM
  • I had the same issue, so I followed the lead from the above post and added a new network adapter to the system for administration and isolated the VM's. Machines now have no issue shutting down. This issue only arose after setting up remote access with VPN. I suspect that is the combination which caused the issue. I suspect that disabling remote access may have solved the problem, but did not go down that road.

    Wayne

    When I had enabled incoming VPN with Windows 8 hyper-v broke until I removed the connection, thanks for the pointer.

    http://www.edugeek.net - The I.T. Professionals life line

    Thursday, April 04, 2013 7:51 AM
  • Does anyone know if this has been resolved since this last post. I do not like having to disable the virtual Ethernet adapter everytime I need to reboot a machine.

    Also, it seems to be the same for creating checkpoints too. I create a new checkpoint and it sits on 0% until I disable the network adapter. Ridiculous.

    I am seriously considering another network card, purely for Hyper-V if this does indeed fix the problem.

    Wednesday, April 24, 2013 9:21 PM
  • Still not fixed as of last week. However, on a system with 2+ network adapters, just disabling option "Allow management operating system to share this network adapter" on the card assigned to VMs fixes the issue (but the network card disappears from the view).

    Benji.


    Benjilafouine

    Wednesday, April 24, 2013 10:59 PM
  • Same Problem on Microsoft Server 2012. On 2012, uninstalled Remote Access with VPN and the problem went away. I'm not having any problems on Windows 8 Hyper-V with the same exact configuration. ..todd
    Sunday, May 05, 2013 8:46 PM
  • I am seeing the same problem. Server 2012 Hyper-V, 4 PT Broadcom NIC ( NetXtreme Driver V 15.2.0.5 ). 3 Virtual switches, 2 work fine but the third will hang any server it is attached to.

    I re-created the Virtual switch and it appeared to be happy for a while, but it has gone bad again. 

    Not happy! Other 2012 Hyper-V server has no problem with same config. Looks like a software issue of some sort.


    Wednesday, May 08, 2013 6:34 AM
  • Same issue, on a Dell T5500 with netxtreme 14.8.1.13

    Disabling routing and remote access service solved the issue. More research needed.

    Update:

    I reinstalled Windows Server 2012 fresh same pc, and this time I loaded remote access last, and only choose to install VPN and not remote access, and still same issue.  I'm also convinced its a nic driver issue.  I updated to latest on Broadcom site.. didn't work.  My work around will be to setup VPN service on one of my VM's I'll have running, hopefully that will work.  Other solution is add another nic card as stated above and isloate VM's to that 2nd NIC.



    • Edited by x01e Sunday, May 19, 2013 5:03 AM
    • Proposed as answer by Bradley Davidson Thursday, August 01, 2013 12:05 AM
    • Unproposed as answer by Bradley Davidson Thursday, August 01, 2013 12:06 AM
    • Proposed as answer by David Trounce Friday, August 09, 2013 11:06 PM
    Saturday, May 18, 2013 2:31 AM
  • I finally found this link to get a hotfix and it worked for me:

    http://support.microsoft.com/kb/2823643/en-us

    • Proposed as answer by David Trounce Friday, August 09, 2013 9:46 PM
    Thursday, August 01, 2013 12:06 AM
  • This hotfix didn't work for me. Server 2012 Standard, an Ubuntu VM with passthrough disks

    Uninstalling the Remote Access role from the host allowed the VM to completely stop. This is clearly a bug.

    Friday, August 09, 2013 11:08 PM
  • This happens to me whenever the virtual has iscsi drives connected to it from within the virtual itself.   Only solution is to reboot the host.   Don't have Remote Access installed.   The host is a blade so installing another nic isn't an option.  Mgmt traffic is unchecked.  The hotfix does not seem to apply to my situation, but I may try it anyway.   Anyone found any other answers?  

    Anne

    Tuesday, September 03, 2013 4:42 PM
  • Still does it on Windows 2012 R2
    Friday, October 11, 2013 4:05 AM
  • Anne,

    Did you ever apply the hotfix with any luck?  Also do you mind if I ask what type of blade?  I'm seeing the same issues with HP BL460 and Server 2012 R2.

    Jim

    Monday, November 18, 2013 6:28 PM
  • I applied fix a while ago and it does not work for me.  Removing the remote access role is the only fix I have found so far.

    Jim

    Tuesday, November 19, 2013 9:51 PM
  • Any news?

    We have the same issue with Server 2012 R2 and HP BL460 in a 3 node cluster.

    Dennis


    Wednesday, March 05, 2014 7:56 AM
  • Has anyone come up with a solution to this?

    I have 14 HP BL660 G8s and all of them produce this issue. I have tried different drivers, teaming, no-teaming, different load-balancing algorithms, etc etc

    The Only time the machine shuts down is when Management is disabled, but this only works for a short time then I have to hard reset the host.

    Thanks

    Adrian


    • Edited by 4id3y Friday, April 11, 2014 9:20 AM
    Friday, April 11, 2014 8:59 AM
  • Running Windows 2012 R2 Update 1 and was having the same issue.

    Removed RAS from this host and the issue went away. So looks like conflict with Remote Access Services.


    If this post helps to resolve your issue, please click the "Propose as Answer" If you find it helpful , mark it as helpful by clicking on "Vote as Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster. If you need an expert migration consultant to assist your organization feel free to contact me directly.

    Jason Sherry | Blog | Hire Me | Twitter: @JasonSherry
    Microsoft Infrastructure Architect, MCSE: M, MCTIP, Microsoft Exchange MVP

    • Proposed as answer by LavAzza_za Tuesday, September 01, 2015 10:37 AM
    Friday, April 18, 2014 3:51 PM
  • Hi folks, does anybody have opened a case with Microsoft?!
    My servers have the same issue.
    This must be fixed!!!

    My case is the same:  I have Remote Access Services and I must, but when I stoped it (the service "Routing and Remote Access"), the virtual machines spent just a few seconds to shutdown or reboot.

    These are headquarter and affiliates servers, and we must have VPN access to them.

    Microsoft fix this bug ASAP!  I have seen people talking about it since early last year!



    • Edited by Daniel Mourthé Thursday, May 15, 2014 4:15 AM
    • Proposed as answer by LavAzza_za Tuesday, September 01, 2015 10:37 AM
    Wednesday, May 14, 2014 2:10 AM
  • This needs to be fixed. It has been a known issue for way too long.

    There is a workaround if you have more than one NIC in the machine.

    NIC #1 will be left for RRAS.

    NIC #2 will only be used for Hyper V. In the Hyper V manager go to Virtual Switch Manager and under External Network make sure you have NIC #2 selected and uncheck "Allow management operating system to share this network adapter.

    Friday, May 16, 2014 4:32 AM
  • Hi,

    I have a Windows Server 2012 guest running on a Server 2012 Hyper-V host and it has been slow to login and slow to shut down.

    I needed to reboot today and it took approx 8 minutes to shut down.

    Once it eventually rebooted I took a look at the event log.

    I found that there was about a 6 minute delay between system events in the log, and when it did respond it was with a warning from the "WinRM" service, the Windows remote management service.

    A bit of a look and I figured this is something that I was willing to turn off.

    I disabled and stopped the Service.

    I then rebooted and the server shut down in approx 10 seconds.

    This seems to be the resolution for my slow shut down issues.

    • Proposed as answer by jcrawfor74 Friday, June 20, 2014 3:39 AM
    Thursday, June 19, 2014 3:16 AM
  • Hi JCrawfor,

    You did not specified if you has disabled "WinRM" service in the host or in the guest. Or in both.

    Remember that if you disable the "WinRm" service, you will not be able to manage the system remotely by, for example, any console inside the "Server Manager".  But it may not even be an issue (no having WinRM).

    Best Regards,

    Daniel

    Monday, June 23, 2014 7:48 PM
  • Hi,

    Yes, sorry, I made this change on the guest only. I made no configuration change to the host.

    I wrote a blog post on the issue I have been trying to resolve, where I was a little more descriptive.

    http://ntsblog.homedev.com.au/index.php/2013/11/08/slow-login-hyperv-wait-local-session-manager/

    Since implementing this change the reboot issue has been resolved 100%, but the slow hyper-v login which is my root problem has still been causing minor issues. I have had one failed login attempt in the past 3 weeks, so it is much improved, but possibly not resolved 100%.

    As for the management of this server, it is actually a development box, so does not need the same level of remote management as a production box, so from my perspective I have not had any issues with having the WinRM service turned off

    Cheers


    • Edited by jcrawfor74 Sunday, June 29, 2014 11:29 PM
    Sunday, June 29, 2014 11:28 PM
  •  I have the same problem, WinRM service turned off - not solve the problem.

    another solution?

    Monday, October 20, 2014 6:42 AM
  • I had the same problem, I disabled the service on Hyper V management, then I deleted the vitual machine, I restated service and I started from the beginning and it worked! cheers.
    Thursday, November 13, 2014 2:27 AM
  • The best way to do this, i have found is to use Process Explorer by sysinternals.

    What you have to do is find vmms.exe which will have the current VM's as child processes.

    Look for the one that has relatively little activity in the threads tab.

    Most of the production VM's will have multiple threads running, while an errant one will not.

    Simply kill the one without any valid threads, and Bob's your uncle.

    Friday, November 14, 2014 12:22 AM
  • That solution won't get you anywhere. You get access denied when you want to end the process - so that solution that everyone is copying around does not work. 
    Tuesday, September 01, 2015 10:37 AM
  • This is STILL an an ongoing issue in Server 2012 R2. As soon as RRAS is removed it behaves normally again. How infuriating!!

    Thursday, January 12, 2017 4:30 PM
  • I have this same issue with Windows Server 2016 - fully patched up to Feb 16, 2017.
    Friday, February 17, 2017 3:09 AM
  • I have this same issue with Windows Server 2016 - fully patched up to Feb 16, 2017.
    FIVE FUK'N YEARS LATER - STILL NOT FIXED

    Software developer

    Wednesday, April 05, 2017 9:38 AM
  • I have this same issue with Windows Server 2016 - fully patched up to Feb 16, 2017.
    I'm experiencing this with Server 2016 as well... 

    DG

    Tuesday, April 25, 2017 10:37 AM
  • In regards to a hung Windows Server 2012 / 2016 VM while restarting on Hyper-V, please see this thread: https://social.technet.microsoft.com/Forums/windowsserver/en-US/c5f2786c-ffac-4f14-b7a9-00612cdf784e/server-2016-vm-hangs-shutting-downrestarting-when-the-pagefile-is-on-a-different-vhdx?forum=winserverhyperv.

    Setting "System Failure" > "Write debugging information" to "none" resolved my issues too.

    HTH :)

    Thursday, May 11, 2017 8:05 AM
  • In regards to a hung Windows Server 2012 / 2016 VM while restarting on Hyper-V, please see this thread: https://social.technet.microsoft.com/Forums/windowsserver/en-US/c5f2786c-ffac-4f14-b7a9-00612cdf784e/server-2016-vm-hangs-shutting-downrestarting-when-the-pagefile-is-on-a-different-vhdx?forum=winserverhyperv.

    Setting "System Failure" > "Write debugging information" to "none" resolved my issues too.

    HTH :)

    Just to be clear.  Did you change the system failure settings on the host server or the guest VMs?  I have some Linux guest clients that exhibit exactly the same behavior.

    When one of my VMs gets stuck at stopping, they all will.  So I may be able to shut down VMs 4 or 5 times perfectly.  Then one will get stuck and once it does, all VMs on that server will get stuck when I shut them down or restart them.

    Thursday, May 11, 2017 11:06 AM
  • Just to be clear.  Did you change the system failure settings on the host server or the guest VMs?  I have some Linux guest clients that exhibit exactly the same behavior.

    When one of my VMs gets stuck at stopping, they all will.  So I may be able to shut down VMs 4 or 5 times perfectly.  Then one will get stuck and once it does, all VMs on that server will get stuck when I shut them down or restart them.

    In my environment, only Windows Server 2016 has this issue of being hung on shutdown. Not Linux, not Windows Server 2012 R2 and below, they all shutdown and reboot perfectly. I tried the suggested fix, and that worked strangely.

    Use

    wmic recoveros set DebugInfoType = 0

    if you don't want to click through all the screens.

    Friday, May 12, 2017 9:39 AM
  • Actually, yes, I have another idea (I have been working with Microsoft on this issue). Recreate a new virtual switch with a regular network adapter and uncheck option "Allow management operating system to share this network adapter". It seemed to fix the issue completely even if this is only a workaround.

    However, be aware when unchecking the option: your "virtual network card" will disappear from Windows 2012. If you had a fixed IP address for this card it will still remain in use through the registry (a bit complicated to manage but it works).

    I hope MS can provide me with more details on what seems to be a bug.

    Benoit


    Benjilafouine

    I had this issue lately on my 2012 Server.  DHCP, DNS, RAS, AD DS and Hyper-V roles installed.  Restart was not an option!!! tried this and worked perfectly!!  I have only 2 VMs, yes the virtual Hyper-V NIC disappeared (thanks God... less complicated like that) and guess what?? they now work even faster!!!

    Thanks a lot!!!


    • Edited by hecgomrec Wednesday, June 14, 2017 8:14 PM
    Wednesday, June 14, 2017 8:10 PM
  • I have tried all the suggestions and none have worked.

    All my servers / hosts / vm's are 2012r2

    At each school I have 1 host with 2 vm's. vm1 is DC and vm2 is data server.

    At each school its only vm1 DC that will hang at 90% shutting down, the vm2 data server is fine, so it looks like a client only issue that is only an issue if its a DC.

    Now for the odd part. Recently I created a new test host and a test vm1 DC. test vm1 DC does shutdown as it should, but if I restore / import one of my live vm1 DC's to my new test host it will not shut down.

    All hosts and vm DC's were installed from the same media and using the same instructions, the only difference is the live vm DC's were created a few years ago.

    So on my test host I have a new vm dc that does shutdown and an older vm dc that will not.

    I have been trying to find a fix for a good few years now




    • Edited by ASnet0007 Monday, July 03, 2017 11:23 AM
    Monday, July 03, 2017 11:21 AM
  • August 2017 - still no solution.

    Running Server 2016 fully patched.  A lot of the discussion on this topic involves network cards, so i have tried nearly everything.  My server has 4 NICs on the motherboard and one PCI card that provides two more 10G NICs. I have tried creating virtual switches using each NIC, I have tried creating some with "allow management OS to share" switched on and some with it off. I have even tried both the Microsoft supplied NIC drivers that came with Win Server 2016 and also installed Intel's latest drivers.  I have not found one of these combinations that get rid of this issue.

    I have not even read any posts that describe what is actually going wrong, so AFAIK it may not even have to do with the network stack at all!

    Friday, August 18, 2017 2:33 PM
  • Same problem here.  windows 2016 VM on Windows 2016 Hyper-V host.  

    A clean install of windows 2016 on a brand new VM worked fine.

    After the IIS was added,  it got stuck!   at both shutting down and rebooting. 

    Other VMS (windows 2012, windows 2008 R2, windows 2003) on the same host are working fine. 



    • Edited by F2000SA Thursday, November 09, 2017 8:17 PM
    Thursday, November 09, 2017 8:16 PM
  • How can we get someone from Microsoft to respond to this thread?  Still no fix and since it affects Linux guests as well as Windows 7,8,10 guests, it seems the issue is with the HOST OS (Windows Server 2016 in my case).  I just had to manually kill 4 VMs and reboot the server again today because of this issue.
    Friday, November 10, 2017 3:19 PM
  • My recommendation would be to re-post under a new thread. Think that will be your best bet for a response.

    Casper Pieterse - Snr. Solution Architect - Dimension Data

    Friday, November 10, 2017 8:00 PM