sysprep server 2008 with installed sql server 2008


  • I am running windows server 2008 r2 on a virtual machine. I have intalled sql server 2008 r2 in it. When I sysprep, copy and re-deploy the syspreped image, I need to re-configure sql server 2008 because it does not let me login into its database engine using old credentials.

    I have searched a lot on the internet about sql server 2008 sysprep and all sites suggest the same method:
    insert sql server 2008 r2 media
    goto Advanced link on left column
    goto Image preparation of a stand-alone instance
    bla bla bla...

    Now following the above steps, problem occurs when I run setup support rules. All rules pass except unsupported for sysprep sql server products with failed status, and does not let me go next.

    the message box shows the following message:

    Rule "Unsupported for SysPrep SQL Server products" failed.

    A previous version of SQL Server that does not support SYSPrep was found installed in the machine. Remove the imcpmpatible product(s) and then re-run setup.

    I have also tried the last option in Advanced link:
    image completion of a prepared stand alone instance.
    It does not let me select Instance ID at Select a prepared Instance step, and I get stuck here.

    Can anyone please help in this regard to rightly sysprep and configure sql server 2008 on windows server 2008?

    I shall be very thankful for that.


    Tuesday, September 28, 2010 9:20 AM

All replies

  • I'm having a similar problem.  I don't get the "Unsupported for SysPrep SQL Server products" error under setup support rules, all those tests pass.

    But I can't select Instance ID at Select a prepared Instance step , and I get stuck there.  There's an instance using the default Instance Name (MSSQLSERVER) with an Instance ID (MSSQL10_50.FIRST) that I had set up before creating this VM OVF template.

    Monday, January 31, 2011 8:11 PM
  • Tuesday, November 13, 2012 1:14 PM