none
Why WIA Device added is listed twice in Windows 10 (Version 1903,18362.30) OS ?

    Question

  • Hello Community,

    We are testing our WIA driver on Windows 10 (Version 1903,18362.30) OS. 

    We added a WSD WIA device after successful installation of WIA driver.

    But in control printers if we right click on added WIA device then we can see duplicate devices listed under Scan Properties(2 entries shown for one device).

    Device manager also shows duplicate entries under Imaging devices (2 entries shown for added one device). We observe this behavior only from 1903. No such issue found in Windows 10 before 1903.

    Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Added screenshot for reference.
    • Edited by Divya Kr Tuesday, April 23, 2019 6:52 AM
    Tuesday, April 23, 2019 6:43 AM

All replies

  • Hello Community,
    Please respond to below query:
    We are testing our WIA driver on Windows 10 (Version 1903,18362.30) OS. 
    We added a WSD WIA device after successful installation of WIA driver.
    But in control printers if we right click on added WIA device then we can see duplicate devices listed under Scan Properties (2 entries shown for one device). Device manager also shows duplicate entries under Imaging devices (2 entries shown for added one device). We observe this behavior only from 1903. No such issue found in Windows 10 before 1903.
    Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Thanks,

    Divya

    Friday, April 26, 2019 6:07 AM
  • Hello Community,
    Please respond to below query:

    Is that Bug in Windows 10 (Version 1903,18362.30) OS to display single WIA device added as 2 entries under Scan Properties.
    And Device manager also shows duplicate entries under Imaging devices
    We observe this behavior only from 1903. No such issue found in Windows 10 before 1903.
    Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Thanks,

    Divya
    Wednesday, May 8, 2019 6:53 AM
  • Do the two Device Manager entries have different hardware iDs?

    Tim Roberts | Driver MVP Emeritus | Providenza & Boekelheide, Inc.

    Friday, May 10, 2019 1:28 AM
  • No, hardware iDs are same for two Device Manager entries.
    Please note, we are installing single WIA driver and adding single device. But there are 2 entries displayed. This behavior was not seen in Redstone3 or any OS before that.
    we are observing it from 19H1 (1903) only.


    • Edited by Divya Kr Friday, May 10, 2019 1:21 PM
    Friday, May 10, 2019 12:34 PM
  • Select one of the devices and then change the view to by connection. The device will still be selected and you can see its parent. Change the view back to device type, select the second device and change to by connection again. What are the two parent device names? How is the device connected to the host?

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, May 11, 2019 3:26 PM
  • Hi Doron Holan,

    Parent device names are also same. Device is added through Add Printer Wizard, WSD device.

    Added screenshot of Device manager:

    We observe this behavior only from 1903. No such issue found in Windows 10 before 1903.

    Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Thanks,

    Divya

    Monday, May 13, 2019 9:56 AM
  • Question
    You cannot vote on your own post

    Hi Doron Holan,

    Parent device names are also same. Device is added through Add Printer Wizard, WSD device.

    Added screenshot of Device manager:

    We observe this behavior only from 1903. No such issue found in Windows 10 before 1903.

    Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Thanks,

    Divya

    Monday, May 20, 2019 11:58 AM
  • No, hardware iDs are same for two Device Manager entries.
    Please note, we are installing single WIA driver and adding single device. But there are 2 entries displayed. This behavior was not seen in Redstone3 or any OS before that.
    we are observing it from 19H1 (1903) only.
    Monday, May 20, 2019 11:59 AM
  • Hello Community,

    Please respond to above query of Windows 10 Version 1903.

    Is it a bug? Is this known issue of 1903(19H1) OS build? Is MS providing any fix for this in future build or update?

    Regards,

    Divya

    Monday, May 20, 2019 12:00 PM