none
Hardware Development Kits for Windows 10 are now available! (July 2015) RRS feed

  • General discussion

  • Hardware Development Kits for Windows 10 are now available! (July 2015)

    Install the hardware development tools to build, test, and deploy drivers; test and measure your hardware running Windows; and customize, assess, and deploy Windows 10 on your hardware:

    • Visual Studio Community 2015
    • Windows SDK for Windows 10
    • Windows Driver kit (WDK) 10
    • Windows Hardware Lab Kit (HLK) for Windows 10
    • Windows Assessment and Deployment kit (ADK) for Windows 10

    Get the kits and tools

    Keep up with the Windows Insider Program to get access to early releases and become part of the Windows community.

    Become a Windows Insider

    Known Issues

    We will update this thread with any known issues for this release.

    Wednesday, July 29, 2015 10:40 PM

All replies

  • Hi. (almost) Out of the box ADK 10 WinPE (only added commandline support) throws an error when I configure network settings. Configure Network settings error: "Enter the static IP address" even tough it's entered.

    I used this feature without problems with earlier WinPE.

    Odd enough, when I check ipconfig after the error, I see that default gateway got applied...


    upd: if I enter IP without subnet mask, I get the missing subnet mask error. as soon I add the subnet mask, it will always thro the "enter static IP address" error
    • Edited by cgsilver Friday, August 14, 2015 10:36 AM new info
    Friday, August 14, 2015 10:34 AM
  • Hi. (almost) Out of the box ADK 10 WinPE (only added commandline support) throws an error when I configure network settings. Configure Network settings error: "Enter the static IP address" even tough it's entered.

    I used this feature without problems with earlier WinPE.

    Odd enough, when I check ipconfig after the error, I see that default gateway got applied...


    upd: if I enter IP without subnet mask, I get the missing subnet mask error. as soon I add the subnet mask, it will always thro the "enter static IP address" error

    would be nice, when you show, what you tried...
    do you need a static IP?

    if you have a DHCP server running, then you should get a proper IP with simply calling:
    WPEUTIL InitializeNetwork
    (as long your network device has proper drivers "DRVLOAD <network_driver>.inf")

    Tuesday, August 25, 2015 11:07 AM
  • Hello,

    iam devloop a DriverApplication , and open WinUsb , all works fine, but now we must compile this
    for WindowsXP (MashinVisionSoftware) , i have download WDK for XP and installed it.

    But i don't find a XP Switch for Plattform Toolset to Driver XP , there stay on WindowsApplicationForDrivers10.0. 
    I think this Switch change only the path for "inc" and "lib".

    I have  Change the Switch from "WindowsApplicationForDrivers10.0"  to  "Visual Studio 2015 - Windows XP (v140_xp)"
    and then i have add  winusb.h  and winusb.lib Folder Manual.  Result 1700 Error Messages .. What i can do to compile my DriverApplication for XP Very Thanks for any helps. Karsten from Berlin.

    Tuesday, November 24, 2015 6:00 PM