How do I remove ALL exclusions from indexing in Windows 7


  • I've tried to configure my windows 7 machine to index all locations (so that search searches ALL directories on all local drives). However it seems that ProgramData and AppData directories are still being excluded.

    If I look at my "indexed locations" dialog the Exclude column for my C: drive says "ProgramData; Data; AppData; AppData". How do I remove these exclusions?

    miércoles, 18 de noviembre de 2009 12:31

Todas las respuestas

  • You have to explicitly check them in the control panel. Since they are excluded by default, they would not be included just because a parent directory is included - you have to specificly include the excluded locations.
    • Propuesto como respuesta Andrei Aron MS jueves, 19 de noviembre de 2009 23:19
    miércoles, 18 de noviembre de 2009 17:25
  • Thanks Ari,

    Those directories aren't listed in the checkboxes, I suspect because they are hidden folders. If I unhide them I get a checkbox which I can check. The annoyance then is that the text ""ProgramData; Data; AppData; AppData" doesn't tell me the full path of the excluded folders.

    However, if I change my "Folder Settings" to "Show Hidden Files and Folder" the I DO get checkboxes for those folders which I can then check. Hopefully search will find files now. I'll post again if it doesn't.



    jueves, 19 de noviembre de 2009 9:47
  • John, please have in mind that those locations are excluded for a good reason: those are high-traffic locations that contains files that are in most cases meaningless (i.e. various applications' temp files, binaries, etc)

    There are two consequences of indexing these:
    1. indexing/search performance decreases - you're indexing a lot more files, so the indexer will have to do more work, have a larger database, etc.
    2. your results might get polluted by gibberish from the temp files I mentioned before.

    I would recommend that you index only a subset of those locations that you know you need rather than the whole thing.
    jueves, 19 de noviembre de 2009 23:21
  • Hi Andrei,

    I'm sort of aware of those cosiderations. Let me explain why I needed to un-exclude them.

    I only noticed that those directories were excepted when I started using Visual Studio 2010.  Frequently, VS2010 generates an exception and tells me to look at "ActivityLog.XML" for details. A "windows" search of my machine found no such file, but command line tools (mks, cygwin) did locate the file. Frustration began to set in... Having found where the file was with the command line tool, I was determined to fiind out why the windows search didn't, Hence this post. These are exactly the cases where one needs a reliable search - to find a file when one has no idea at all where it is.

    So, maybe the problem in VS2010 putting the file in a non indexed location and/or not telling me where the file is when it tells me to look at it.

    viernes, 20 de noviembre de 2009 9:09
  • Seconded to johnd2.

    No workaround present.


    Thank you.  I'm tired of 0x80040d54|FAIL because someone put the files in AppData.
    viernes, 05 de marzo de 2010 16:49
  • I know necromancy is BAD but havent yet found a more recent thread of this topic. I have been trying to look for a set of files that SHOULD be in appdata but might be someplace else. Before installing Win 764bit i had been using Win XP 32 bit and i used the Windows trasnfer wizard thing to migrate info from XP to 7. Well I cant find some save games for GTA IV and ALOT of savegames for various games are stored in appdata so would love to be able to index appdata for files that i know (hopefully) exist but not sure of location or even naming convention. MS fails again.
    sábado, 27 de noviembre de 2010 6:24
  • Hello Robert,

    First, you don't need to index AppData to search a folder under it.  In Windows Explorer, just navigate to the folder and do a non-indexed search.

    Second, although it is possible to index AppData with a hack, it is a really bad idea.  I know because I tried it.  What happens is that the indexer (and your hard drive) is forever working, trying to keep up with the temporary files that are constantly created and deleted.  As a result, my PC bogged down badly.  Microsoft made the right decision when they excluded AppData from indexing.

    And no, I'm not going to post the hack.

    Doug M. in NJ

    sábado, 27 de noviembre de 2010 15:30
  • So then the question becomes, why would Micro$oft put some of the most CRITICAL flies, OST's and PST's in the JUNK non indexed, excluded by default folders?   All I wanted to do today is find my OST, and it took a friggin hour to track down why Windows is HIDING MY FILES from me.

    Why would Micro$oft put some of the most CRITICAL flies, OST's and PST's in the JUNK folder?  Why, why, why... I can't take it anymore, I am go ing ot the MAC store to see that they gots.

    sábado, 13 de agosto de 2011 16:58
  • Hi Ari, There apears no way I can get in to remove indexing from the exclude part of my search. Whatever way I go in I cannot allow indexing on APPDATA ?

    Sincerely Tony.

    jueves, 11 de octubre de 2012 13:12
  • The comments below suggest that Windows 7's search feature won't do what you would like it to. Therefore you may want to investigate a third-party alternative that will "search everything" on you hard drive.
    jueves, 07 de marzo de 2013 20:22
  • hi ,

    i have had the same problem

    got to control panel

    go to folder optiosn, make all hiden files "show"

    now go to outlook , to index settings ,index options ,modify , go to c/user / ( be careful - go to all user and go to folder appdata , check all of app data ,ur name app data,everyone app data ,whatever you have ) click okay .

    now go again to control panel ,hide all ,restart outlook . let to make serach indexing .and hope even for you to have all in order 

    regards ,

    • Propuesto como respuesta Alfredxh jueves, 30 de enero de 2014 10:25
    jueves, 30 de enero de 2014 10:25