Using the Windows SDK for Windows 7 and .NET Framework 3.5 SP1 with Visual Studio 2008


  • Hi, I'm trying to build a simple setup proyect and found that Visual Studio 2008 is looking for the Windows SDK v6.0A.

    Here are my software and hardware details:

    - Windows XP SP3
    - Visual Studio 2008 Professional Edition SP1
    - Language: Visual Basic
    - I visited Microsoft Update and there are no new updates for me

    I'm confused because all the SDKs recommended the installation of the Windows SDK for Windows 7 and .NET Framework 3.5 SP1. I installed this SDK and it seems that it wasn't the right for me. I know the name (Windows 7) should have raised a warning, but on the webpage it says it's compatible with Windows XP.

    Now, I'd like to know what will happen if I install an earlier SDK? Will this cause any problem? Is there a way to tell VS that it should use this newer version of the SDK?

    Thanks in advance,

    Carlos Mallen
    martes, 26 de enero de 2010 19:27

Todas las respuestas

  • Is it using version 6 by explicitly using the path, or is it using the WindowsSdkDir Macro.  If it's using the macro, here's a post that tells you how to change it:

    martes, 26 de enero de 2010 20:39
  • Here are some of the messages I receive when trying to build the proyect:

    Warning    2    Could not find prerequisite '.NET Framework 3.5' in path 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\'

    Warning    3    Could not find prerequisite 'Windows Installer 3.1' in path 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\'

    Error    4    Could not find required file 'setup.bin' in 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Engine'

    martes, 26 de enero de 2010 21:18
  • what project are you trying to build?
    miércoles, 27 de enero de 2010 1:26
  • I'm trying to build a steup proyect.

    File -> New Proyect -> Setup and Deployment -> Setup Proyect.

    Thanks for your time.
    miércoles, 27 de enero de 2010 2:29
  • Well, to point out one important thing, where it says Windows 7 SDK it means that it is an SDK which includes Windows 7 Functionality. It doesn't mean it is only for Windows 7. As a FYI, the version of the SDK which comes with VS2008 is the Windows Vista SDK.

    But at the same time I wonder if this is an issue with the SDK and not your setup. The files which it says it is missing are on my system under the exact path and I have the Windows 7 SDK installed. (The point to note is in your error messages it is giving warnings about the Windows 6.0A SDK, not 7 and 6.0A is part of Visual Studio).

    If I were you I would check your setup doing a reinstall if necessary.
    Visit my (not very good) blog at
    miércoles, 27 de enero de 2010 7:10
  • On the Windows SDK blog ( there's a section about how to "Use the Windows SDK Configuration Tool to set the Current SDK". I'll give it a try, because I already have the Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 Service Pack 1 installed. I'll tell you later if this worked.
    miércoles, 27 de enero de 2010 16:27
  • I went to the Windows SDK Configuration Tool and tried to set version v7.0 as the current version (Start->All Programs->Microsoft Windows SDK v7.0->Visual Studio Registration->Windows SDK Configuration Tool). The operation failed because there were missing components.

    The solution was to perform a full install of the Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 SP1 (Start->Control Panel->Add or Remove Programs->Microsoft Windows SDK for Windows 7 (7.0)->Change and then use the wizard to select all components).

    I returned to the Windows SDK Configuration Tool and changed the current version to v7.0 successfully. However, Visual Studio send me the same error messages explained earlier when trying to build my setup proyect.

    There's an article about the Windows SDK Configuration Tool in this forum:
    How to get the WinSDK Configuration Tool to work

    And here's another in the Windows SDK blog:
    WinSDK bug notification: SDK Config Tool appears to work but fails

    Up to this point I don't know what else to do. I have tried setting the current version at the command prompt, as explained in the articles cited above, without success.
    jueves, 28 de enero de 2010 16:45
  • Hey crescens2k, sorry for being stubborn, but I wanted to use the latest SDK. I reinstalled Visual Studio 2008 as you suggested and now I have the Windows SDK v6.0A that Visual Studio was asking for. My setup proyect built without problems. I still haven't verified that I can use the Windows SDK v7.0.
    viernes, 29 de enero de 2010 18:29
  • microsoft problems are so confused :(


    About some new information ,please kindly let me know.



    and btw, some ppl want to know nike air max sports news?





    viernes, 03 de junio de 2011 13:50