Destination Folder Access Denied


  • Just purchased  a vista business HP machine. Machine is part of an internal network. If I try to copy file from any other machine on the network from the VISTA machine, it gives me message "Destination Folder Access Denied" "You Need Permission to Perform this action".  But I can copy the files from other machines on the network to the VISTA machine?????????
    Saturday, April 28, 2007 11:53 AM

All replies

  • I have run into the same issue. I'm sure I was able to do this in the past. I am running under non-privileged account and cannot copy files from a network share to my own workstation. The network share is mapped using alternate credentials. I can see the file but I cannot open it directly or copy it to my local harddrives. I've also tried this from a command shell running as admin with no success.

    I've tried turning on Network Discovery and File Sharing with no success.

    I can't really see anything in the event logs either.


    I share your frustration.



    Monday, April 30, 2007 3:12 PM
  • The problem in my case was permissions on the source file (Duh!).

    Unknown to me, Administrator access had been limited to listing the files in that folder. Once I set the permissions correctly, the file copied as expected. This was not done intentially by the user but something happened to the permissions when the files were copied from a unix-based file source.

    I'm somewhat embarrassed but wonder why the error message said "destination folder access denied" when it was clearly the source folder that had issues.





    Monday, April 30, 2007 3:58 PM
  • I had the same exact problem occur on seemingly random files, when copying from my old PC (running XP) to my new PC running Vista.


    I was confounded why it way saying "Destination Folder Access Denied", and nearly threw the new PC out the window, until I thought maybe it's a permission problem from the source.  Indeed, some of the files on my original PC didn't have proper permssions set to allow access from the network.  I wasted at least 8 hours trying to figure this out. 


    The error message is extremely misleasing.  Why would the copy indicate the "Destination" folder has access denied?  If the copy can't determine where the access denied is occurring (which seems very unlikely), then they should change the wording to something like "Access denied due to source or destination", so I could more easily figure out what the problem is.


    Microsoft, are you listening?

    • Proposed as answer by casino-royale Tuesday, September 28, 2010 7:43 PM
    Sunday, May 27, 2007 1:44 PM
  • I have a similiar problem but no exactly what your experiencing. I am trying to delete a folder with files that i have to delete to get halo to work. As like you it brings up the access denied message when im an admin. any solutions to this?
    Thursday, July 05, 2007 6:34 PM
  • i've read deleting individual files within the folder
     first will enable you to delete the folder.

    my problem is there are 150+ .tmp files and folders directly under my c:\ directory (both files and folders on the same "level") and i get the dfad error when trying to kill them. i cannot change permissions for the drive so i may commit filecide (my word), but i instead have to change the permissions for each file and folder, one at a time, so they can be trashed.

    in the meantime, the drive is still "locked down," so i don't have full access to the machine i bought and paid for...
    Friday, July 13, 2007 9:48 PM
  • I'm experiencing a similar problem ... I'm transferring files from my old XP laptop to new Vista laptop and need to access data files under the >local settings>application data>Microsoft directory, however, when I try and access the 'local settings' folder, I get an "Access is Denied" error message ... I thought it was a permissions issue, but I my user account is set up as 'Administrator' ... just curious if you had any suggestions.  thx.


    Monday, August 06, 2007 6:29 PM
  • Had same problems when moving files to trash bin. Just stick to XP. At least it works.

    Tuesday, August 14, 2007 9:50 AM
  • Just share the root folder or drive and delete the file from a computer with xp. I just ran into the same problem, tried to change permissions and no luck. I was able to get rid of the folder from another pc however!

    • Proposed as answer by casino-royale Tuesday, September 28, 2010 7:44 PM
    Monday, August 20, 2007 7:09 AM
  • Simple but effective.   I tried changing permissions etc. to no avail.

    Right clicked on offending folder (or file) and selected 'cut', paste onto desktop.   Then right click and 'cut' again and paste onto memory stick.    Then delete from memory stick.   Voila


    Friday, August 24, 2007 1:50 PM
  • The problem being a source thing is correct.


    If you want to copy files from an XP machine to a Vista machine over your local network, you have to grant the "Guest" account on the XP machine rights to work with that directory.  Since the operation is controlled, I grant the Guest account full control, copy the stuff I need, then imediately remove the Guest accounts rights.


    It's working as designed, just might not be the way you want it.


    BTW - Just giving the Guest account full access of the share DOES NOT grant the Guest account the rights to the individual folders, you will still have to grant the rights.  I know, troublesome at least but it will get you past your issue.


    Saturday, September 01, 2007 5:43 PM
  • Are you running VirusScan 8.5i on the target computer?


    VirusScan 8.5 by default blocks other computers from droping autorun.inf files in your system.

    Make sure you uncheck the blocking of "prevent creation of remote autorun files" in the Access Control panel in the target computer.  That should take care of your problem. 


    Alaska, USA


    • Proposed as answer by Wirerunnernyc Thursday, January 26, 2012 7:17 PM
    Tuesday, September 11, 2007 6:14 AM
  • I am encountering this same error, "Destination Folder Access denied"  I encounter the error primarily when I try saving files off the web.   I think I have also encountered it when moving file from one folder to another.  Two conditions that might be of note in my situation are 1.  I have two versions of XP installed on this Machine being 32-bit and 64-bit versions, which have permissions for the XP userprofiles and directories already defined.  2. Mcafee Virus Scan 8.5i is installed, I am wondering as well if Mcafee is the problem.   


    This issue with Destination Folder Access denied is quite annoying.  I had never experienced this error in XP so was pointing at Vista as the problem.  I will have to try uninstalling or disabling McAfee and trying again.  If McAfee is not at fault than I will reinstall it.  On another note I have been running this OS as a limited user because I felt that it was more secure that way and I have been elevating myself to admin to do admin tasks, in this case only to get the same error message again as Admin.  I have even tried logging in as Admin to perform the task and still been presented with the error in question.


    If this is a Vista flaw than I hope that it is fixed in Service Pack 1 as this is a definite killer of the usefullness of this operating system to me, that is if it is going to be giving me problems like this. 

    Monday, December 10, 2007 4:19 PM
  • Interestingly if I disable the on access scanner of McAfee and the on access protection I still get the error message, but the system is saving the file, this is downloading an attachment from a web page where this problem is occuring in this case.  After saving the file and getting the error message I am prompted to save again with a SAVE / CANCEL button, at which point if I don't change the file name the system prompts me to overwrite.  If I overwrite the previously saved file than no problem, it just overwrites it this time.  I say Microsoft needs to fix this mechanism in Vista!
    Monday, December 10, 2007 4:51 PM
  • Hi,

      i ran into the same problem.  I uninstallled McAfee VirusScan 8.5i. Then I was able to successfully download files off the Internet.  I am gonna try installing another virus scanner and see if the problem repeats.  Hope this helps. 

    Sunday, December 16, 2007 8:42 PM
  • Just as a note there is a good free alternative Virus scanner out there --- free for home users, not free for businesses.  The one that I like so far is Avast, it even has it own firewall built into it.  It is manufactured by a Czechoslovakian company, as stated  on their web site, which is


    Let me know if this helps you.



    Thursday, December 20, 2007 3:13 PM
  • You're dealing with permission issues.  Here is the easy way I got around the same problem.


    ON SOURCE MACHINE (presumably the non vista one)

    a) Copy the folder or the files that you want to transfer to the new PC to a root directory (outide of your My Documents or Desktop).  For me, the eas thing to do was create a folder on the c:\ and put everything in there.  This gets the files out of the protected USER ACCOUNTS on the XP machine

    b) Make sure you share the folder so it can be accessed on the network




    b) Copy to wherever you would like


    Hope this helps!




    Tuesday, February 12, 2008 2:43 AM

    Vista is so retarded.  I copied a folder containing some files from an external hard drive on to my desktop (as a quick place to store them) then I decided I wanted to move them to "Documents" and I kept getting the error "Destination Folder Access Denied" with the stupid-*** options to "try again" or "cancel" WTF? I am the only user on this PC, and I am an administrator.  This frustrated the *** out of me.  Eventually I was able to copy/paste this folder into "Documents" and then delete it.  but isn't that the same thing as moving? Yet another reason Vista sucks balls.  Here's a couple more:


    The Network and Sharing center sucks - what happened to "My network places" and "Network connections" everything you needed was there, and it was simple.


    Defragmenter - what happened to the graphical display? It was neat seeing the before and after of my file system.  Also, the percentage complete was kind of nice.


    Try changing your encryption key to your WLAN.  What a pain in the ***! In XP you could simply disconnect from the network, and then reconnect, re-enter the new key and BAM you were back online.  Not in Vista, you have to go to the stupid *** "Network and Sharing  center" and then go to "manage network connections" remove the network from your list, then go back and re-join the wireless network. what a pain in the ***!


    I truly hope this OS we all know as "Vista" doesn't make it.  In my opinion it sucks! *AND* I have technical data to back my opinion. 


    Thanks for letting me vent Smile


    -=Matthew L=-

    A+, Net+, i+, Sec+, MCP, CIW, Wireless#

    Saturday, August 16, 2008 7:39 PM
  • Yes!!..,, this STUPID Vista really SUCKS !!!!!!...,, I've got the same problems as yours..,, even if I am the Administrator, the ONLY user in my computer!!...,, DENIED me to access control MY folders...

    I've tried to delete a damn folder that is completely rubbish on the Program Files folder because I tried to uninstall it but It fails, because this Vista CRASHED Suddenly with the BLUE SCREEN OF DEATH!!...., and so I tried to delete this manually but I can't remove this rubbish, because......

    It DENIES me to control access in THIS folder.....,, "Destination Folder Access Denied" WHAT A STUPID THING!!!!

    I am the ADMINISTRATOR and the only OWNER of my computer but it keeps DENYING me to grant permission!! and I continued it by pressing the button but It keeps telling me this STUPID THING
    "Destination Folder Access Denied"!!....

    "TRY AGAIN, CANCEL"... then I tried again but until the END OF THE WORLD! It REPEATS!!!!! And because of this,
    I can't reinstall the program because this Vista CRASHED when I uninstall this!!!

    ERrRrrrr.....!!! I feel that I can even throw my computer JUST BECAUSE OF THIS!!... DENYING THE OWNER!!

    OF COURSE !!!!!!..,, I tried the WHOLE thing that I commonly read on the forums..

    "Properties -> Security Tab -> Edit Permissions ->"  but NON of this thing Works!!!....,,

    It keeps DENYING THE ADMINISTRATOR!!!!!!!.... even I've disabled UAC (User Account Control).....
    just the same STUPID THING HAPPENS!!!

    I'm REALLY REALLY losing my patience with the Customer Services of Microsoft!!.... because Microsoft still have NO answers in this STUPID problem even this MSDN Forums DON'T Answers!!!

    HEY!!...,, MICROSOFT!! Do we need to ASK BILL GATES to give us just a STUPID Permission to

    Sunday, November 23, 2008 12:28 PM
  • Lol.  The person who suggested using the memory stick, I'm gonna remember that.  It resolved the issue for me just fine, although that's a pretty silly thing to have to do.  I need to talk to my brother who was able to "fix" his vista machine to eliminate "permissions" altogether.
    Tuesday, January 06, 2009 12:46 AM
  • I vehemently agree with grungegirl84 and Ken above. This "permissions" business is a incredible design blunder and indicates unspeakable cluelessness on the part of the designers. If Shadohpanther's brother was able to eliminate permissions I'd really like to know how it was done.

    Incidentally, I came on this forum because Vista wasn't letting me copy music files from a root directory (to which they had come via repeated trips with memory sticks, since Vista does not allow sharing of "shared" network folders) to my official "music" folder. I hit the "skip" option and found that Vista had arbitrarily transfered two out of seven folders. Without changing any settings, I tried again, and this time it worked. Vista isn't just illogical, it's imposition of permission rules is basically random.

    Any operating system that fails to allow the owner of a computer to transfer files from one folder to another on that same computer is a badly designed system. There's simply no excuse for making a system that doesn't allow file transfers.

    Saturday, August 15, 2009 8:09 PM
  •  >Any operating system that fails to allow the owner of a computer to transfer files from one folder to another on that same computer is a badly designed system. There's simply no excuse for making a system that doesn't allow file transfers.

    Actually, that's what is called discretionary access control.  You should check the permissions on the source and destination files and directories.

    Some basic information on ACLs:

    Monday, August 17, 2009 5:28 PM
  • I am having the same problem. i am copying 700+ pics from XP to Vista SP1 over my network. Probably 20% failed to copy with the dreaded DFAD error. All of the files were loaded onto the XP machine the same way, transferred from my camera using Nikon's PictureProject. The difference seems to be that the pics I didn't subsequently edit and save using PictureProject are the ones that failed to copy.

    Granting read access to those files for the Guest account worked. I was then able to copy those files.

    It is unclear to me why Nikon's PictureProject would apply different sharing permissions in creating and saving files.

    My account names on the two machines don't match. I wonder what would have happened if they had matched?

    BTW, this was after 3 unsuccessful attempts to use Microsoft's "Easy Transfer" utility. The instance on the destination Vista machine just stopped with no error message. Eventually the instance on the source XP machine stopped to with a network disconnected icon flashing. I guess it ran out of space.

    All the way through this I kept muttering "I wish I had bought a MAC".

    Wednesday, September 02, 2009 7:09 PM
  • ETB_UW, thank you for posting your solution. This turned out to be my issue, and it looks like, two years on, Microsoft has not fixed this very deceptive error message.
    Friday, October 02, 2009 8:37 AM
  • Let's call it three years. I have a brand new Windows 7 machine. I'm trying to access a $ share on my XP machine. I have set permissions for EVERYONE to FULL CONTROL on the drive and all the folders. I don't remember having this problem with Vista (don't know why I didn't), but it is aggravating nonetheless.

    When I map, I map using the XP login credentials on the XP machine, making me the "actual" owner of the files. On the local XP machine, I can right-click and create a new folder in any location on the drive. On Windows 7, mapped using the same account that I just did that with locally, I get the ridiculous DFAD error. I have tried granting every permission in the world. It is not permissions based on the XP share.

    It has something to do with accessing the $ share via a drive map. To top it off, I'm running Windows 7 Pro. Supposed to be the "cream of the crop", right?

    Anyone have any ideas? Anyone? Buehler? Buehler?


    Tuesday, August 03, 2010 12:48 AM
  • Well i got the same problem to im making a antivirus program and i need to how to get All Files from the directory inclusing sub directories.

    but it says access denied


    Cmon Microsoft Do something!

    make it easier to get files and that kind of stuff.

    Wednesday, February 09, 2011 5:21 PM
  • I had the same problem and it was my anti virus software
    Monday, March 21, 2011 7:18 PM
  • I have this same 'DFAD' problem, but mostly when just trying to rename a file or folder.  That really puzzles me as to why that would pose any kind of security risk, given that its an administrator account.  And the OS should have no problem seeing the commands are coming from the keyboard, and not remotely by some hacker trying to phuck with it.

    MS has gotten it right 2 times...  Win 2000 Pro and XP.  But Vista is the king of BS, with ME close on its heels.  Actually ME was worse, but that was probably compounded by the hardware technology of the time.  If ME were run on a modern machine side-by-side with Vista, Vista would probably suck harder.

    Another thing that pisses me off, is with every release of Windows, you're lucky to get a few features that are a good idea, and that actually work.  Most the time however, they just screw things up worse.  Everything else is just the same old thing, renamed, and moved around somewhere else, so you have no idea where it is, and no way of finding out in help because its called something else now.  So all you're left with is an expensive Solitaire game running on $1500 of hardware. 

    But you have to deal with it, because that old version (that worked and you knew so well) is no longer supported, so no new updates to keep it secure.

    Why does MS do it?  Who knows.  Why don't all the water spill off the Earth if its round?  It just don't.  Accept it and be happy.


    ~ f t an't broke, don't fx t.  f t s broke, to hell with t.

    Tuesday, March 22, 2011 3:01 AM
  • Indeed, I quite agree with those on the ridiculousness of this issue. Though so many others have already commented, I thought it couldn't hurt to mention I too have this issue with Vista, (and I know I have done this operation before, without this problem). Microsoft had apparently released a fix for it but that was back in 2008, for Service Pack 1 (from the types of posts on this thread around that time, clearly that worked well). I just wanted to add that my solution (simple but it worked) was similar to the one covered by BBot. The only difference is I'm not transferring to a different OS/machine. I'm just transferring to a different folder within the same system. I took the contents of the first folder (the one it griped about) and placed them in a new folder into the desired destination. I didn't copy/paste it (not really different, I know) I actually moved the highlighted contents themselves, and this, apparently, was OK.

    Vista, please relax. Just because your grandma and kids are saner than you doesn't mean you can't age gracefully.

    Thursday, September 15, 2011 9:00 AM
  • Thank you!!! Disabled McAfee antivirus 8.7.0i's "Prevent creation of remote autorun files" by doing:

    1. Go to Windows system tray.
    2. Right-click on McAfee icon.
    3. Select Viruscan Console.
    4.  Right-click Access Protection.
    5. Select Properties.
    6. Highlight Antivirus Standard Protection.
    7. On right side, go to "Prevent remote creation of autorun files".
    8. Uncheck Bock and Report options.
    9. Also go to "Prevent mass mailing worms from sending mail".
    10. Uncheck Bock and Report options.
    11. Click Apply button.
    12. Click OK button.

    That's it. Other antivirus software have similar fileblocking options. Check with antivirus manufacturer.

    • Proposed as answer by jhsiax Monday, April 20, 2015 3:51 PM
    Thursday, January 26, 2012 7:22 PM