locked
CertEnroll via Internet Explorer - DCOM was unable to communicate with the computer RRS feed

  • Question

  • Hi,

    I am testing software developed in my company that requests certificates against a windows 2008  MS certifcate authority.

    Previously we used a desktop application that references CertEnroll and this app can call the MSCA without any problems. We have now switched over to a browser based client using Internet Explorer. The client machine is a windows 7 machine but it seems that the win7 machine does not have the ability to communicate with the MSCA via DCOM. 

    I have set up dcom error logging and in the event viewer the following error message appears when I try to invoke the application;

    "DCOM was unable to communicate with the computer dev-ad.domain.gdqc.comdomain-DEV-AD-CA using any of the configured protocols."

    I am assuming this is a permissions issue somewhere on either the client machine or the windows 2008 CA machine, has anyone had this problem before and solved it? I would be very grateful for any advice. 

    thanks.



    • Edited by ronan001 Sunday, June 23, 2013 6:47 PM
    Sunday, June 23, 2013 6:46 PM

All replies

  • hi,

    i solved this problem. the object that contained the name of my CA machine dev-ad.domain.gdqc.comdomain-DEV-AD-CA  was being deserialised incorrectly where the backslash was being removed. It should have been 

    dev-ad.domain.gdqc.com\\domain-DEV-AD-CA 

    Fixed.

    Monday, June 24, 2013 6:41 PM