none
WinFX Runtime Components 3.0 Beta 2 installation problems

    Question

  • Hello,

    I was using the February CTP until Beta 2. I’ve downloaded the new WinFX Runtime Components 3.0 Beta 2 and I can’t install them. I’ve uninstalled older version using the tool Microsoft has provided (the MSI file) and I’ve also removed several other components that I thought could cause the problem. I’m still receiving the following error:

    [05/24/06,00:29:52] VS Scenario: [2] CPrevProductInstalledCheck failed : <font face=Verdana size=8pt>
    Thank you for participating in the Beta program. You must uninstall all pre-release products in a specific order before you can continue with setup. For detailed information, see the <a color=#3F4F7F HOVER-COLOR=#C3120C href="http://go.microsoft.com/fwlink/?LinkId=54981">uninstall support page</a> and the <a color=#3F4F7F HOVER-COLOR=#C3120C href="http://go.microsoft.com/fwlink/?LinkId=65603">readme</a>.<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;- Windows Communication Foundation<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;- WinFX Runtime Components 3.0 - Beta 2<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;- Windows Presentation Foundation Beta 2 v3.0.51116.0
    [05/24/06,00:29:52] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()

    Have you experienced difficulties installing Beta 2 Components for developers? What could be reason for the above error message?

    Thank you for your help,
    - Stanimir

    SNIP: here is a bit more from the Error Log; this line is repeated 6 times:

    [05/24/06,00:29:52] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()
    [05/24/06,00:43:42] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603

    Tuesday, May 23, 2006 10:47 PM

Answers

  • Hi,

    Please try following the below steps.  If the dd_wcf_retCA*.txt log does not show the error below, please respond to this thread with the error snippet from the CA log file.

    Thanks,

    Doug

    2.8 WinFX Beta 2 installation fails on a system with WinFX Jan CTP or earlier previously installed

    WinFX installation fails with this error:

    ERROR_INSTALL_FAILURE 1603 Fatal error during installation

    And in one of the %temp%\dd_wcf_retCA*.txt log files, it shows the following:

    ServiceModelReg [15:48:08:041]: Installing: Microsoft Digital Identity Service (idsvc)
    ServiceModelReg [15:48:08:073]: Error: System.ComponentModel.Win32Exception: The name is already in use as either a service name or a service display name
     

    To resolve this issue

    1. Open a commnd prompt
      1. Click: Start
      2. All Programs
      3. Accessories
      4. Command Prompt
    2. In the command prompt, type: sc delete “InfoCard Service"
    3. Restart the WinFX Beta 2 installation

     

    Wednesday, May 24, 2006 12:05 AM

All replies

  • Hi,

    Please try following the below steps.  If the dd_wcf_retCA*.txt log does not show the error below, please respond to this thread with the error snippet from the CA log file.

    Thanks,

    Doug

    2.8 WinFX Beta 2 installation fails on a system with WinFX Jan CTP or earlier previously installed

    WinFX installation fails with this error:

    ERROR_INSTALL_FAILURE 1603 Fatal error during installation

    And in one of the %temp%\dd_wcf_retCA*.txt log files, it shows the following:

    ServiceModelReg [15:48:08:041]: Installing: Microsoft Digital Identity Service (idsvc)
    ServiceModelReg [15:48:08:073]: Error: System.ComponentModel.Win32Exception: The name is already in use as either a service name or a service display name
     

    To resolve this issue

    1. Open a commnd prompt
      1. Click: Start
      2. All Programs
      3. Accessories
      4. Command Prompt
    2. In the command prompt, type: sc delete “InfoCard Service"
    3. Restart the WinFX Beta 2 installation

     

    Wednesday, May 24, 2006 12:05 AM
  • Hello Doug,

    Thanks for the reply. I have tried your solution and it does work. Funny thing, though, I have tried it before but I guess I have misspelled the name of the InfoCard service.

    Thanks for your help,
    - Stanimir

    Wednesday, May 24, 2006 12:19 AM
  • I thought I would share this knowledge. When I uninstalled february CTP bits, it left the "Microsoft Digital Identity Service" (idsvc) on my xp even though I did not have prior bits installed. So I followed the advicse in the post and typed following at the command line:


    sc delete idsvc


    It removed this service.
    Friday, May 26, 2006 4:08 PM
  • FYI - I had the same install error and had to use the following command to delete the service:

    sc delete "InfoCard Service"

    after that - the install worked fine.

     

     

     

    Saturday, May 27, 2006 2:45 AM
  • Hi,

    I have the same problem when trying to uninstal WinFX beta2.

    The dd_wcf_retCA....txt file contains the following:

    === Verbose logging started: 5.7.2006  22:00:14  Calling process: C:\WINDOWS\WinFX\v3.0\Windows Communication Foundation\ServiceModelReg.exe ===
    ServiceModelReg [22:00:15:100]: Information: The ServiceModelReg tool will take the following actions:
    Removing configuration section system.serviceModel from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    Removing configuration section system.runtime.serialization from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    Removing configuration section system.serviceModel.activation from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    Removing configuration entry for BuildProvider:
     System.ServiceModel.Activation.ServiceBuildProvider, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Removing compilation assembly node from System.Web section group:
     System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL
    Removing compilation assembly node from System.Web section group:
     System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL
    R...
    ServiceModelReg [22:00:15:110]: Uninstalling: Machine.config Section Groups and Handlers
    ServiceModelReg [22:00:15:110]: Warning: Configuration section system.serviceModel does not exist in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    ServiceModelReg [22:00:15:110]: Warning: Configuration section system.runtime.serialization does not exist in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    ServiceModelReg [22:00:15:120]: Warning: Configuration section system.serviceModel.activation does not exist in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config.
    ServiceModelReg [22:00:15:120]: Uninstalling: Xws System.Web Build Provider
    ServiceModelReg [22:00:15:180]: Warning: A configuration entry for BuildProvider System.ServiceModel.Activation.ServiceBuildProvider, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 does not exist.
    ServiceModelReg [22:00:15:180]: Uninstalling: Xws System.Web Compilation Assemblies
    ServiceModelReg [22:00:15:200]: Warning: All Xws compilation assembly nodes do not exist in System.Web section group.
    ServiceModelReg [22:00:15:200]: Uninstalling: Xws Http Handlers
    ServiceModelReg [22:00:15:210]: Warning: HttpHandlers node *.svc does not exist in System.Web section group.
    ServiceModelReg [22:00:15:210]: Uninstalling: Xws Http Modules
    ServiceModelReg [22:00:15:220]: Warning: HttpModules node ServiceModel does not exist in System.Web section group.
    ServiceModelReg [22:00:15:220]: Uninstalling: Xws Web Host Script Mappings
    ServiceModelReg [22:00:15:310]: Error: System.FormatException: Input string was not in a correct format.
       at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
       at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
       at System.Double.Parse(String s, NumberStyles style, NumberFormatInfo info)
       at System.ServiceModel.Install.InstallHelper.GetHighestOtherWcfRuntimeInstallPath()
       at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.UninstallScriptMapFromPath(DirectoryEntry path, OutputLevel outputLevel)
       at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.Uninstall(OutputLevel outputLevel)
       at Microsoft.Tools.ServiceModel.ServiceModelReg.Run(String[] args)
       at Microsoft.Tools.ServiceModel.ServiceModelReg.TryRun(String[] args)

    Wednesday, July 05, 2006 8:15 PM
  • Update:

    manually running the following from cmd prompt solwer my problem:
    C:\WINDOWS\WinFX\v3.0\Windows Communication Foundation>ServiceModelReg.exe -ua

    Wednesday, July 05, 2006 8:59 PM
  • i too have the same problem.

    Error: 'document.all.RPCreated.style' is null or not an object

    URL: file:///C:/Documents and  Settings /nani/Local Settings/Temp/IXP000.TMP/wht482.xml

     Do you want to continue running script on this page?

    Error Signature:

    EventType : wap10setup     P1 : 13165     P2 : 3.0.03906.22_waprc0_x86_sfx    
    P3 : mc     P4 : inst     P5 : f    
    P6 : dd_ca_uninstallxwsregexe_x86.3643236f_fc70_11     P7 : 0     P8 : 1603
    P9 : -     P10 : windows communic    

     

    Log file:

    [07/10/06,15:27:05] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603
    [07/10/06,15:27:05] WapUI: [2] DepCheck indicates Windows Communication Foundation Beta 2 is not installed.
    [07/10/06,15:27:05] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.
    [07/10/06,15:33:09] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603
    [07/10/06,15:33:10] WapUI: [2] DepCheck indicates Windows Communication Foundation Beta 2 is not installed.
    [07/10/06,15:33:10] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.
    [07/10/06,15:40:57] VS Scenario: [2] *** Blocking Components exist and must be satisified before continuing to install ***
    [07/10/06,15:40:57] VS Scenario: [2] WinFX Runtime Components 3.0 Beta 2 - WEB
    [07/10/06,15:40:57] VS Scenario: [2] *** End of Blocking Component List ***
    [07/10/06,15:41:04] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()
    [07/10/06,16:02:23] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603
    [07/10/06,16:02:24] WapUI: [2] DepCheck indicates Windows Communication Foundation Beta 2 is not installed.
    [07/10/06,16:02:24] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.
    [07/10/06,16:03:11] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603
    [07/10/06,16:03:11] WapUI: [2] DepCheck indicates Windows Communication Foundation Beta 2 is not installed.
    [07/10/06,16:03:11] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.
    [07/10/06,16:20:06] Windows Presentation Foundation Beta 2: [2] Error - file does not exist: c:\windows\winfx\v3.0\winfx runtime components 3.0 - beta 2\.\wcu\wpf\wpf.msi
    [07/10/06,16:20:06] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.
    [07/10/06,16:20:06] Windows Workflow Foundation: [2] Error - file does not exist: c:\windows\winfx\v3.0\winfx runtime components 3.0 - beta 2\.\wcu\winwf\WF_3.0_x86.msi
    [07/10/06,16:20:06] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.
    [07/10/06,16:20:07] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147023293.
    [07/10/06,16:20:08] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.
    [07/10/06,16:32:40] Windows Communication Foundation Beta 2: [2] Error: Installation failed for component Windows Communication Foundation Beta 2. MSI returned error code 1603
    [07/10/06,16:32:40] WapUI: [2] DepCheck indicates Windows Communication Foundation Beta 2 is not installed.
    [07/10/06,16:32:40] WapUI: [2] DepCheck indicates WinFX Runtime Components 3.0 - Beta 2 was not attempted to be installed.

     

    Thanks in advance

    Nani

    Monday, July 10, 2006 9:34 PM
  •  Doug Hall wrote:

    Hi,

    Please try following the below steps.  If the dd_wcf_retCA*.txt log does not show the error below, please respond to this thread with the error snippet from the CA log file.

    Thanks,

    Doug

    2.8 WinFX Beta 2 installation fails on a system with WinFX Jan CTP or earlier previously installed

    WinFX installation fails with this error:

    ERROR_INSTALL_FAILURE 1603 Fatal error during installation

    And in one of the %temp%\dd_wcf_retCA*.txt log files, it shows the following:

    ServiceModelReg [15:48:08:041]: Installing: Microsoft Digital Identity Service (idsvc)
    ServiceModelReg [15:48:08:073]: Error: System.ComponentModel.Win32Exception: The name is already in use as either a service name or a service display name
     

    To resolve this issue

    1. Open a commnd prompt
      1. Click: Start
      2. All Programs
      3. Accessories
      4. Command Prompt
    2. In the command prompt, type: sc delete “InfoCard Service"
    3. Restart the WinFX Beta 2 installation

     

    Thursday, August 21, 2008 5:36 AM