Microsoft Access 2007


  • I was attempting to start Microsoft Office Access 2007 and received the following message: 


    The system DLL user32.dll was relocated in memory.  The application will not run properly.  The relocation occurred because the DLL C:\Windows\system32\SHELL32.dll occupied an address range reserved for Windows system DLLs. The vendor supplying the DLL should be contacted for a new DLL."


    I woudl greatly appreciate in assistance in this matter. I believe this is a result of installing another application or update that was downloaded.


    Thank you

    Sunday, April 08, 2007 10:51 PM

All replies

  • Hi Eric,

    I went to article 935448 in the knowledge base and download the 935448 package.  The file I downloaded was WindowsXP-KB935448-x86-ENU.

    I notice the DLL in that knowledge base article is NOT the same as the one I mentioned in my message. I'm thinking maybe that's why it's not working

    After the download, I re-started my computer and attempted to run Access and got the same result.

    Thanks in advance for your cooperation in this matter

    Darren Smith
    Tuesday, April 10, 2007 12:47 AM
  • Can you post your version numbers for shell32.dll and user32.dll?
    Wednesday, April 11, 2007 3:12 AM
  • Eric,

    How or where can I acquire the version numbers?

    Wednesday, April 11, 2007 3:17 AM
  • right click - properties on the files in the windows\system32 directory
    Wednesday, April 11, 2007 6:22 AM
  • Eric,

    Here's the information your requested

    Shell32.dll - Version number 6.0.2900.3051

    user32.dll - Version number - 5.1.2600.3099

    Darren Smith
    Wednesday, April 11, 2007 11:07 PM
  • The version look correct. How technical do you wan to get? This will tell you who is causing this.


    Thursday, April 12, 2007 3:54 AM
  • I just need to run the Process Explorer application?
    Thursday, April 12, 2007 4:01 AM
  • On second thought, that may not work because the proces never started. What is your sound card on the machine?
    Thursday, April 12, 2007 11:56 PM
  • Hi Eric,

    It's Realtek HD Audio, I'm curious what is the connection between the audio and Microsoft Access?

    Friday, April 13, 2007 12:41 AM
  • Realtek is injecting thier DLL into every process at a wrong memory address, cause the other DLLs to be relocated. Please revisit becuase this issue has been updated. Realtek has released version 1.64 to address this problem.




    April 12, 2007 The following changes were made to this article:
    Updated the "Symptoms" section to include version information for the affected versions of Realtek HD Audio Control Panel and to document that Realtek has released version 1.64 to address this problem.
    Updated the "Symptoms" section to include information about an additional program that is affected by this problem. Microsoft has confirmed that this problem affects Suunto Ski Manager (made by Suunto), versions 1.0.2 , 1.1, and 1.2. .
    Updated the "Resolution" section to add prerequisite information, restart information, and file information for this update. This information was unintentionally removed on April 10, 2007.
    Updated the "Resolution" section to add deployment information, removal information, and information about how to verify that the update is installed.
    Added this table to list major technical revisions to this content.

    Friday, April 13, 2007 11:32 PM
  • I have installed this "fix" several times but it's not working
    Saturday, April 14, 2007 2:27 AM
  • Hi Eric,

    When I click on that link, do I download the zip or exe file?  Should I click site 1, site 2 or site 3?

    Darren Smith
    Sunday, April 15, 2007 1:07 AM
  •  Hi


    Seems I have exactly same problem when I try to install programs,


    The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\Windows\System32\SHELL32.dll occupied an address range reserved for Windows system DLLs. The vendor supplying the DLL  should be contacted for a new DLL.


    I have the same versions as above and have installed the fix ‘WindowsXP-KB935448-x86-ENU(2).exe’ several times as well (although I do not have a realtek) but still get the above error when I try to .exe other programs,






    AVG’s avgcc.exe


    Just to name a few.


    I have a ‘Sound Blaster Xfi’ sound card.


    Recent installs around the time I first encountered the error have been….

    Windows XP KB926239

    Windows XP MSComPackV1

    Windows XP Wudf01000

    Windows XP Media Player 11

    Although I have created restore points previous to these installs I am not able to restore to an earlier date.


    Any help will be much appreciated….


    Thanks in advance



    Friday, April 20, 2007 12:18 AM